404 error home translations

Popular automatic website translation tool

404 error home translations

Postby Maartenen11 » Fri Dec 13, 2013 2:05 pm

Hello,

I came across an 404 error when I try to reach the homepage button after selecting a laguage (English or German). the url is /en.html and /de.html.
/en and /de works well.

The site main language is dutch.

I'm using gtranslate pro plugin.
Could you give me advice on this?

Sincerely, Maarten Boer
Maartenen11
 
Posts: 3
Joined: Tue Dec 10, 2013 2:11 pm

Re: 404 error home translations

Postby Yana » Fri Dec 13, 2013 7:55 pm

Hi,
Which version of GTranslate Pro you installed? If it is GTranslate Pro general version (gtranslate folder in the root directory) , you should check gtranslate .htaccess rules.
If you are using GTranslate Pro joomla system plugin please make sure that you enabled apache mod_rewrite in gtranslate general settings page.
You can find the documentation here : https://gtranslate.io/docs/57-gtranslat ... umentation
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4133
Joined: Thu Jan 12, 2012 6:21 pm

Re: 404 error home translations

Postby Maartenen11 » Sat Dec 14, 2013 6:25 pm

Hello,

Thx for your quick reply.

The joomlaplugin, mod_rewrite was already in use (with .html suffix) with standard J2.5 rules.
Following settings in module:
Operate with GTranslate Pro version - on
Translation method - Redirect
site language - dutch
And in plugin:
SSL Verify Peer - Yes
Detect Main Language - no
Detect User Language - no
Debug Mode - None
Site Language - dutch
I use Sobipro component on homepage.

Greetz,

Maarten
Maartenen11
 
Posts: 3
Joined: Tue Dec 10, 2013 2:11 pm

Re: 404 error home translations

Postby Yana » Sat Dec 14, 2013 7:17 pm

Hi,

Did you rename htaccess.txt to .htaccess ? Try to change gtranslate system module order.
If you can send me FTP access and backend admin access I can check the settings. You can use the contact form on homepage.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4133
Joined: Thu Jan 12, 2012 6:21 pm

Re: 404 error home translations

Postby Maartenen11 » Mon Dec 16, 2013 5:31 pm

Al works well now without .html suffix in glabal Joomla comfiguration.
Will take the client some time to redirect all urls and change Addwords accounts though ;-)
Thx for your time, its a nice extension.

Greetz,

Maarten
Maartenen11
 
Posts: 3
Joined: Tue Dec 10, 2013 2:11 pm

Re: 404 error home translations

Postby Yana » Mon Dec 16, 2013 5:34 pm

You're welcome!
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4133
Joined: Thu Jan 12, 2012 6:21 pm

Re: 404 error home translations

Postby enwebsoluciones » Wed Aug 20, 2014 9:07 am

Hello, if I deactivate the suffix on Joomla the home menu works fine, but the products with VirtueMart are not getting translated.

When the suffix is Activate the products works but no the home
www.rackart.com/en/

Any workaround?
enwebsoluciones
 
Posts: 8
Joined: Wed Aug 20, 2014 9:04 am

Re: 404 error home translations

Postby Yana » Thu Aug 21, 2014 1:53 pm

Hi,

Please try to remove suffix via .htaccess file . Here are the rules

RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} !index.php
RewriteCond %{REQUEST_URI} !(.*)/$
RewriteRule ^(.*)$ http://rackart.com/$1/ [L,R=301]
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4133
Joined: Thu Jan 12, 2012 6:21 pm

Re: 404 error home translations

Postby enwebsoluciones » Sun Aug 24, 2014 12:39 am

Hello, thank you for the reply.

I apply the codo you give me. But I get a Loop Error.
inside the .htaccess i found this code:

RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the request is for something within the component folder,
# or for the site root, or for an extensionless URL, or the
# requested URL ends with one of the listed extensions
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.

Let me know.
enwebsoluciones
 
Posts: 8
Joined: Wed Aug 20, 2014 9:04 am

Re: 404 error home translations

Postby Edvard » Sun Aug 24, 2014 1:47 am

Hi,

Can you please post your whole .htaccess file, so I can modify it for you and send back?

Thank you!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

full htaccess

Postby enwebsoluciones » Sun Aug 31, 2014 11:12 pm

# -FrontPage-

SetEnv PHPRC /home/rackart/php.ini
IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

<Limit GET POST>
order deny,allow
deny from all
allow from all
</Limit>
<Limit PUT DELETE>
order deny,allow
deny from all
</Limit>
AuthName rackart.com
AuthUserFile /home/rackart/public_html/_vti_pvt/service.pwd
AuthGroupFile /home/rackart/public_html/_vti_pvt/service.grp


##
# @package Joomla
# @copyright Copyright (C) 2005 - 2013 Open Source Matters. All rights reserved.
# @license GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
##

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block out any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the request is for something within the component folder,
# or for the site root, or for an extensionless URL, or the
# requested URL ends with one of the listed extensions
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.
enwebsoluciones
 
Posts: 8
Joined: Wed Aug 20, 2014 9:04 am

Re: 404 error home translations

Postby Edvard » Mon Sep 01, 2014 10:16 pm

Hi,

Please use the following configuration:

# -FrontPage-

SetEnv PHPRC /home/rackart/php.ini
IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

<Limit GET POST>
order deny,allow
deny from all
allow from all
</Limit>
<Limit PUT DELETE>
order deny,allow
deny from all
</Limit>
AuthName rackart.com
AuthUserFile /home/rackart/public_html/_vti_pvt/service.pwd
AuthGroupFile /home/rackart/public_html/_vti_pvt/service.grp


##
# @package Joomla
# @copyright Copyright (C) 2005 - 2013 Open Source Matters. All rights reserved.
# @license GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
##

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

## Mod_rewrite in use.

RewriteEngine On

# gtranslate special rule
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)\.html$ /$1/ [R=301,L]

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block out any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the request is for something within the component folder,
# or for the site root, or for an extensionless URL, or the
# requested URL ends with one of the listed extensions
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: 404 error home translations

Postby enwebsoluciones » Tue Sep 02, 2014 10:03 am

Thank you. It works as we needed.
Great support!
enwebsoluciones
 
Posts: 8
Joined: Wed Aug 20, 2014 9:04 am

Re: 404 error home translations

Postby Edvard » Tue Sep 02, 2014 3:39 pm

Thanks! Good to hear that.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest

2GLux
cron