500 Error Gtranslate Pro on IIS

Popular automatic website translation tool

500 Error Gtranslate Pro on IIS

Postby mwangner » Fri Jan 20, 2012 11:23 pm

I have read through the troubleshooting guide and other posts. I am running on IIS 6.0 and cannot use apache. I do have a mod_rewrite equivalent and I am trying to sort through that myself but I cannot even get gtranslate to work when addressing it directly (500 error)

I have gtranslate pro installed here:

You can see my PHP information here:

I want to make sure it's working properly before I go through the trouble of figuring out how to convert the Mod_rewrite to url_rewriter format. IIS does not recognize the chmod commands sent by ftp programs so I have logged on locally and set the cache directly and contents to everyone-->full control and have not touched the file permissions of the gtranslate folder. I have also set Debug to true in the config file, but when calling the file I receive only a 500 error.
Posts: 14
Joined: Fri Jan 20, 2012 11:06 pm

Re: 500 Error Gtranslate Pro on IIS

Postby Edvard » Sun Jan 22, 2012 9:01 pm


Please check the file and folder permissions for gtranslate and translate.php.

Make sure to use the default permissions after you upload it. You should ONLY change cache and cache/XX folders permissions to 777.

You can try to remove gtranslate folder and re-upload it again and don't change any permissions. After if it shows errors about not able to write you will add the write permission later.

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Site Admin
Posts: 4151
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

  • Related Topics
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests