add ?language_edit=1 to the URL Gives 500 Server Error

Popular automatic website translation tool

add ?language_edit=1 to the URL Gives 500 Server Error

Postby damienbut » Wed Dec 14, 2011 2:10 pm

Hi,

I recently installed GTranslate Pro and cannot edit the default translations using the ?language_edit=1 to end of the URL for the language that I want to edit.

Any ideas why this might be happening as this is the only reason I bought the pro version?

Thanks for any help.
damienbut
 
Posts: 6
Joined: Wed Dec 14, 2011 1:48 pm

Re: add ?language_edit=1 to the URL Gives 500 Server Error

Postby alt_f4 » Wed Dec 14, 2011 4:10 pm

URL of the page? Maybe the folder is not writeable? Folder permissions to 777?

Regards, alt_f4
Last edited by alt_f4 on Wed Dec 14, 2011 4:13 pm, edited 1 time in total.
alt_f4
 
Posts: 68
Joined: Tue May 31, 2011 2:43 pm

Re: add ?language_edit=1 to the URL Gives 500 Server Error

Postby damienbut » Wed Dec 14, 2011 4:13 pm

damienbut
 
Posts: 6
Joined: Wed Dec 14, 2011 1:48 pm

Re: add ?language_edit=1 to the URL Gives 500 Server Error

Postby alt_f4 » Wed Dec 14, 2011 4:16 pm

alt_f4
 
Posts: 68
Joined: Tue May 31, 2011 2:43 pm

Re: add ?language_edit=1 to the URL Gives 500 Server Error

Postby damienbut » Wed Dec 14, 2011 4:21 pm

Yes. As per the instructions I set 777 recursively for the /var/www/vhosts/nedvizimost.co.uk/httpdocs/gtranslate/cache folder and all folders inside it
damienbut
 
Posts: 6
Joined: Wed Dec 14, 2011 1:48 pm

Re: add ?language_edit=1 to the URL Gives 500 Server Error

Postby alt_f4 » Wed Dec 14, 2011 4:27 pm

There is a redirection to a URL like http://www.nedvizimost.co.uk/index.php? ... aHR0cDo.... do you have a SEO / SEF component? On our Joomla-Site it´s working fine...maybe Edvard can help ;-)

Best wishes, alt_f4
alt_f4
 
Posts: 68
Joined: Tue May 31, 2011 2:43 pm

Re: add ?language_edit=1 to the URL Gives 500 Server Error

Postby damienbut » Wed Dec 14, 2011 4:30 pm

Yes, Search Engine Friendly URLs and Use Apache mod_rewrite are enabled in Joomla. I tried turning these off but get the same problem.
damienbut
 
Posts: 6
Joined: Wed Dec 14, 2011 1:48 pm

Re: add ?language_edit=1 to the URL Gives 500 Server Error

Postby alt_f4 » Wed Dec 14, 2011 4:47 pm

And, of course, you´ve adopted the .htaccess for GTranslate?

Code: Select all
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA]
alt_f4
 
Posts: 68
Joined: Tue May 31, 2011 2:43 pm

Re: add ?language_edit=1 to the URL Gives 500 Server Error

Postby damienbut » Wed Dec 14, 2011 5:18 pm

Yes I have.
damienbut
 
Posts: 6
Joined: Wed Dec 14, 2011 1:48 pm

Re: add ?language_edit=1 to the URL Gives 500 Server Error

Postby damienbut » Wed Dec 14, 2011 5:51 pm

I have found what the problem was. The contact form module on each page was somehow conflicting with the edit function in GTranslate
damienbut
 
Posts: 6
Joined: Wed Dec 14, 2011 1:48 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest

2GLux
cron