enterprise show an error message

Popular automatic website translation tool

enterprise show an error message

Postby nohayestilo » Wed Aug 14, 2013 2:14 pm

Hi good morning
For technical problems I had to load a backup of my joomla site. The backup was prior to installing GTranslate. Now to return to follow the steps to configure GTranslate not get it to work.
When I click on the flags of language receive the following error message:

An error occurred.

Sorry, the page you are looking for is currently unavailable.
Please try again later.

If you are the system administrator of this resource Then you should check the Error log for details.

Faithfully yours, nginx.

Can you tell me where is the error?
Thanks.
nohayestilo
 
Posts: 10
Joined: Wed Jul 10, 2013 1:38 pm

Re: enterprise show an error message

Postby nohayestilo » Wed Aug 14, 2013 2:52 pm

Hi
My web server has a new lock to non-Spanish speaking countries to access the joomla administrator and configuration files. It may be this the problem? if this is the problem please send me the IP address for Gtranslate enterprise version to order it unlocked.
Thanks
nohayestilo
 
Posts: 10
Joined: Wed Jul 10, 2013 1:38 pm

Re: enterprise show an error message

Postby Yana » Wed Aug 14, 2013 4:12 pm

Hi,

GTranslate server IP address is 94.23.220.123 . Please unblock it.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: enterprise show an error message

Postby tope » Wed Aug 14, 2013 8:43 pm

Hi, the ip is unlock in my webserver.
Now when i click the flag to change language don´t do nothing....
tope
 
Posts: 7
Joined: Wed Jul 10, 2013 1:45 pm

Re: enterprise show an error message

Postby Yana » Wed Aug 14, 2013 11:27 pm

Hi,
Can you send me your domain name?
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: enterprise show an error message

Postby nohayestilo » Wed Aug 14, 2013 11:30 pm

nohayestilo
 
Posts: 10
Joined: Wed Jul 10, 2013 1:38 pm

Re: enterprise show an error message

Postby Yana » Thu Aug 15, 2013 5:26 pm

Hi,

Just have checked your website and can see the error. Please ask your hosting provider to check again and unblock our IP address.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: enterprise show an error message

Postby nohayestilo » Thu Aug 15, 2013 11:25 pm

Hi,
My hosting provider ask me ¿For module GTranslate you are using the Bing translator?
The ip is already unblock.
Thanks
nohayestilo
 
Posts: 10
Joined: Wed Jul 10, 2013 1:38 pm

Re: enterprise show an error message

Postby Yana » Fri Aug 16, 2013 3:13 pm

Hi,
Can you please remove www redirection for our network requests? You can find the documentation here https://gtranslate.io/docs/58-gtranslat ... umentation

Please let me know if you have any questions.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: enterprise show an error message

Postby nohayestilo » Fri Aug 16, 2013 9:05 pm

Hi
When I insert the code in my .htacces file (changing domain.com for thecrazyfifties.es)
RewriteCond %{HTTP:X-GT-Lang} ^$
RewriteCond %{HTTP_HOST} ^domain.com
RewriteRule (.*) http://www.domain.com/$1 [R=301,L]

the site show this message:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
nohayestilo
 
Posts: 10
Joined: Wed Jul 10, 2013 1:38 pm

Re: enterprise show an error message

Postby Yana » Fri Aug 16, 2013 11:52 pm

Hi,
You should remove www redirection for your website and then add the rules.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: enterprise show an error message

Postby nohayestilo » Tue Aug 20, 2013 2:37 pm

Hi,
This is my .htacces archive.... its the code ok? they dont work and show the error message again.


##
# @package Joomla
# @copyright Copyright (C) 2005 - 2012 Open Source Matters. All rights reserved.
# @license GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
##

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

## Mod_rewrite in use.
RewriteCond %{HTTP:X-GT-Lang} ^$
RewriteCond %{HTTP_HOST} ^thecrazyfifties.es
RewriteRule (.*) http://www.thecrazyfifties.es/$1 [R=301,L]

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block out any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the request is for something within the component folder,
# or for the site root, or for an extensionless URL, or the
# requested URL ends with one of the listed extensions
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.
nohayestilo
 
Posts: 10
Joined: Wed Jul 10, 2013 1:38 pm

Re: enterprise show an error message

Postby Yana » Wed Aug 21, 2013 12:32 am

Hi,
Please add RewriteEngie On before gtranslate rules :

RewriteEngine On
RewriteCond %{HTTP:X-GT-Lang} ^$
RewriteCond %{HTTP_HOST} ^thecrazyfifties.es
RewriteRule (.*) http://www.thecrazyfifties.es/$1 [R=301,L]
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: enterprise show an error message

Postby nohayestilo » Wed Aug 21, 2013 3:26 pm

Hi, Thank you so much....
Now its all running ok.
Best regards.
nohayestilo
 
Posts: 10
Joined: Wed Jul 10, 2013 1:38 pm

Re: enterprise show an error message

Postby Yana » Wed Aug 21, 2013 9:06 pm

Hi,
Good to hear that. You're welcome!
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux