Error 500 using Pro

Popular automatic website translation tool

Error 500 using Pro

Postby KrisTian » Wed Sep 28, 2011 10:53 am

Hello.

I am using GTranslate Pro v.3.141592 on Joomla 1.5.
I set all as recommended in the txt file, and server requirement are ok.
When I want to translate a page, I get a 500 error message :

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


I tried uninstall and install several times, but the problem is still the same.
Did someone have a solution for this issue ?

Thanks in advance.

Regards.
KrisTian
 
Posts: 6
Joined: Wed Sep 28, 2011 10:48 am

Re: Error 500 using Pro

Postby Edvard » Wed Sep 28, 2011 4:16 pm

Can you check your .htaccess file? There should be instructions to avoid 500 server error. Make sure that you don't have syntax errors and check the file permissions as described in the troubleshooting.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Error 500 using Pro

Postby KrisTian » Wed Sep 28, 2011 4:46 pm

Hello Edvard.

Thanks for your quick reply.
I check permission folder and it is ok.

Here is my .htaccess :

Code: Select all
#####################################################
#  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

##  Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

#
#  mod_rewrite in use

RewriteEngine On
# gtranslate config
        RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
        RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
        RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA]
        RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA]

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
## Deny access to extension xml files (uncomment out to activate)
#<Files ~ "\.xml$">
#Order allow,deny
#Deny from all
#Satisfy all
#</Files>
## End of deny access to extension xml files
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

#  Uncomment following line if your webserver's URL
#  is not directly related to physical file paths.
#  Update Your Joomla! Directory (just / for root)

# RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section


It is the same I used in the past and was working before update...
Is there something wrong ?

Thanks in advance for your quick help.

Regards.
KrisTian
 
Posts: 6
Joined: Wed Sep 28, 2011 10:48 am

Re: Error 500 using Pro

Postby Edvard » Thu Sep 29, 2011 4:09 pm

You can try to comment Options +FollowSymLinks line by adding # before it.

Can you write the permissions of gtranslate folder and subfolders and files in it?

What is your domain name?
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Error 500 using Pro

Postby KrisTian » Thu Sep 29, 2011 7:34 pm

I tried uncomment, but still the same.

Folder and subfolder of cache are 777, and there are no files inside the subfolder...

You can check this here

Thanks for your help
KrisTian
 
Posts: 6
Joined: Wed Sep 28, 2011 10:48 am

Re: Error 500 using Pro

Postby Edvard » Fri Sep 30, 2011 4:10 pm

I think that you have also changed gtranslate folder permissions and files permissions inside it.

Try to delete everything and upload again, then change only cache and subfolders permissions to 777.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Error 500 using Pro

Postby KrisTian » Fri Sep 30, 2011 9:42 pm

Ok things are ging better... I think that my problem was because I forgot to download the "info.php" file :oops:
But now, when I try to change the language, nothing happens. No error, but no translation too...

I set the site language to french in admin, but when I choose a language on the site I see that he consider defaut language as english.

Thanks in advance for your help, I think we are on the good way :mrgreen:
KrisTian
 
Posts: 6
Joined: Wed Sep 28, 2011 10:48 am

Re: Error 500 using Pro

Postby Edvard » Fri Sep 30, 2011 9:48 pm

Check gtranslate/config.php file. What do you have there for MAIN_LANG?
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Error 500 using Pro

Postby KrisTian » Mon Oct 03, 2011 12:05 pm

One more issue solved ! I think the biggest bug is me... :)

There is still a problem on translation. Only some part of page are translated. For example, this page. It should be in english, but the main text is still in french ?!
KrisTian
 
Posts: 6
Joined: Wed Sep 28, 2011 10:48 am

Re: Error 500 using Pro

Postby Edvard » Mon Oct 03, 2011 3:20 pm

I've just checked and can see this error: "Daily Limit Exceeded".

It seems that you have exceeded your Translate API usage limits. You need to fix that issue from https://code.google.com/apis/console/

Currently not all the users get courtesy limit from Google. Google is making it's API commercial. So there are 3 options:

1. Pay Google and use their API
2. Use free Bing Translator instead (you can find how to enable Bing from gtranslate/config.php file)
3. Use Google translate without API, for that you need to use this rewrite rules instead:

Code: Select all
# gtranslate config
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2&force_no_api=1 [L,QSA]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1&force_no_api=1 [L,QSA]
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux