GTPro - Error when attempting save of manual translations

Popular automatic website translation tool

GTPro - Error when attempting save of manual translations

Postby creativeraven » Sat Jan 26, 2013 4:14 am

Getting an error window popup when logged in and attempting to save a manual translation as follows:

<br />
<b>Warning</b>: unlink(/home/signetfl/public_html/plugins/system/gtranslate/cache//2ae4089665f6c54eb892fa950813f01f) [<a href='function.unlink'>function.unlink</a>]: No such file or directory in <b>/home/signetfl/public_html/plugins/system/gtranslate.php</b> on line <b>166</b><br />
Success

Client has just completed all their human translations and is anxious to get them implemented. Can anyone advise on this error and recommend a solution to resolve it.

Thanks in advance for your help.
creativeraven
 
Posts: 9
Joined: Sat Jun 02, 2012 1:58 am

Re: GTPro - Error when attempting save of manual translation

Postby Yana » Sat Jan 26, 2013 7:42 pm

Hi,
Make sure that the cache folder has write (delete) permission.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm

Re: GTPro - Error when attempting save of manual translation

Postby creativeraven » Sat Jan 26, 2013 11:54 pm

Hi Yana,
/public_html/plugins/system/gtranslate/gtranslate/cache/ (aka, "the cache folder") has permissions set to "777". This is the highest permissions settings that we can assign ourselves. In fact, the security is actually the lowest setting, as it's the most permissive permissions setting! It is so permissive that it is a security risk according to our Hosting Provider.

So, looks like we might need to look into this further. Your suggestions?
creativeraven
 
Posts: 9
Joined: Sat Jun 02, 2012 1:58 am

Re: GTPro - Error when attempting save of manual translation

Postby creativeraven » Sat Jan 26, 2013 11:56 pm

I can grant back end access to a GTranslate tech if that will help. Please PM me for details.
creativeraven
 
Posts: 9
Joined: Sat Jun 02, 2012 1:58 am

Re: GTPro - Error when attempting save of manual translation

Postby creativeraven » Sun Jan 27, 2013 5:13 am

:geek: We got the hosting provider involved to research the permissions and did a number of tests to recreate the error. Here's the feedback:

"It looks like when you initially save the edit, it appends .human to the end of the cache file (fd16406b64f1dca758f3526d25eebc9e becomes fd16406b64f1dca758f3526d25eebc9e.human). That works successfully the first time. The next time you save the edit, it searches for the file but without the .human at the end of the filename, which is why it throws that warning. It does save the edits that you make, but it is not able to modify the cache filename for an unknown reason. I would take this to the plugin developer(s) to see if they can further troubleshoot this issue. The file it references in the warning message is encoded with IonCube Loader, which makes it difficult for us to troubleshoot this further."

The cache folder has the proper write (delete) permission so that's working. It is just this warning message keeps popping up. I can anticipate someone making an edit, saving it and then reading it and discovering "oops, made a typo", goes back into the correct and when saving a second time is presented with this warning and will be concerned that the system isn't working.

Can you please assist in providing some technical information or guidance as to how we can fix this and stop this warning message. Our hosting provider did as much as they could but it would appear we need your team to be involved because of the encoding with ionCube.

Thanks for your help.
creativeraven
 
Posts: 9
Joined: Sat Jun 02, 2012 1:58 am

Re: GTPro - Error when attempting save of manual translation

Postby Yana » Sun Jan 27, 2013 4:59 pm

Hi,
If you can see the changes on your site, then it is OK. I suggest you to disable error reporting . You don't need to worry about the notices, by default your php error reporting should be set to E_ALL & ~E_NOTICE, which doesn't log notices, probably you have E_ALL .
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux