gtranslate pro : no debug.txt

Popular automatic website translation tool

gtranslate pro : no debug.txt

Postby DenisC » Tue Jun 24, 2014 9:22 pm

Hi,

I use gtranslate on a wordpress installation, installing gtranslate pro, put the sitemap, installing gtranslate free and set to use gtranslate pr.
I go to home page, goto the french url : the url is OK : nothing happen. I use ?force_translation=1 in url, but only have : Cannot translate: $string.

Example:
Cannot translate: Welcome,

Then i try to debug, i set
Code: Select all
define('API_KEY', 'ownAPIkey');
...
define('DEBUG', true);
...

In gtranslate/config.php file

Remove limit.txt, recall the page : but limit.txt is set again.

My url is http://www.traveler-change.com/fr
DenisC
 
Posts: 11
Joined: Thu Jun 19, 2014 11:20 am

Re: gtranslate pro : no debug.txt

Postby Edvard » Tue Jun 24, 2014 11:01 pm

Hi,

Please create a blank debug.txt file inside gtranslate folder and set permission to 666, so it will be able to write the debug info into the debug file.

BTW. It seems that you have your own API key, it is an optional feature and it is not required. May be it causes the issues, since probably you have reached your API key usage daily limit and it doesn't translate further.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: gtranslate pro : no debug.txt

Postby DenisC » Wed Jun 25, 2014 11:09 am

Hi,

Code: Select all
/var/www/gtranslate/cache# ls -la *.txt
-rw-rw-rw- 1 www-data www-data 0 Jun 25 08:48 debug.txt


Got to : http://www.traveler-change.com/fr/

Code: Select all
/var/www/gtranslate/cache# ls -la *.txt
-rw-rw-rw- 1 www-data www-data  0 Jun 25 08:48 debug.txt
-rw-r--r-- 1 www-data www-data 10 Jun 25 09:04 limit.txt
/var/www/gtranslate/cache# cat debug.txt
[email protected]:/var/www/gtranslate/cache#


Denis
PS: I test first without the google API : white page or same think. I reput the INSERT-YOUR-KEY in it and same think.
DenisC
 
Posts: 11
Joined: Thu Jun 19, 2014 11:20 am

Re: gtranslate pro : no debug.txt

Postby Edvard » Wed Jun 25, 2014 11:42 am

Hi,

The debug.txt file should be inside gtranslate folder, not inside cache folder.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: gtranslate pro : no debug.txt

Postby DenisC » Wed Jun 25, 2014 12:49 pm

Ok .... better now .....

One thing more: If i go to a language page, there are no automatic translation i must use force_translation=1.

Code: Select all
[email protected]:/var/www/gtranslate# tail debug.txt -f

* About to connect() to www.traveler-change.com port 80 (#0)
*   Trying 94.23.239.194...
* connected
* Connected to www.traveler-change.com (94.23.239.194) port 80 (#0)
> GET / HTTP/1.1
User-Agent: Mozilla/5.0 (X11; Linux i686; rv:30.0) Gecko/20100101 Firefox/30.0
Host: www.traveler-change.com
Accept: */*
Cookie: wp-settings-5=editor%3Dtinymce; wp-settings-time-5=1403166297; wordpress_logged_in_fXXXXXXXXXXXXXXXXXXXXX=XXXXXXXXXXXXXXXXXXXXXx; wordpress_logged_in_XXXXXXXXXXXXXXXXX=XXXXXXXXXXX; wordpress_logged_in_3XXXXXXXXXXXXXX=XXXXXXXXXXXXXXXXXXXXXx

* additional stuff not fine transfer.c:1037: 0 0
* additional stuff not fine transfer.c:1037: 0 0
* additional stuff not fine transfer.c:1037: 0 0
* additional stuff not fine transfer.c:1037: 0 0
* HTTP 1.1 or later with persistent connection, pipelining supported
< HTTP/1.1 200 OK
< Date: Wed, 25 Jun 2014 08:30:59 GMT
< Server: Apache/2.2.22 (Debian)
< X-Powered-By: PHP/5.4.4-14+deb7u11
< Expires: Wed, 11 Jan 1984 05:00:00 GMT
< Cache-Control: no-cache, must-revalidate, max-age=0
< Pragma: no-cache
< X-Pingback: http://www.traveler-change.com/xmlrpc.php
< Link: <http://www.traveler-change.com/?p=14>; rel=shortlink
< Vary: User-Agent,Accept-Encoding
< Access-Control-Allow-Origin: *
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=UTF-8
<
* Connection #0 to host www.traveler-change.com left intact
* Closing connection #0
DenisC
 
Posts: 11
Joined: Thu Jun 19, 2014 11:20 am

Re: gtranslate pro : no debug.txt

Postby Edvard » Wed Jun 25, 2014 9:17 pm

Hi,

I can see translations now, for example http://www.traveler-change.com/ru/

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: gtranslate pro : no debug.txt

Postby DenisC » Thu Jun 26, 2014 10:43 am

Edvard wrote:Hi,

I can see translations now, for example http://www.traveler-change.com/ru/

Thanks!

Hi,

Yes but not for http://www.traveler-change.com/yi/

I have other problem : did i make a new post or continue here (think i can manage the problem myself).
DenisC
 
Posts: 11
Joined: Thu Jun 19, 2014 11:20 am

Re: gtranslate pro : no debug.txt

Postby Edvard » Thu Jun 26, 2014 4:07 pm

Give it some time to translate or use force_translation.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux