gTranslate Pro dont work

Popular automatic website translation tool

gTranslate Pro dont work

Postby KaiDomroese » Sun Nov 06, 2011 4:24 pm

Hi,

(sorry, my english is not so good.)
Yesterday I bought gTranslate, before I had the free version.

I have installed ionCube here: http://www.mein-elektroauto.com/gtransl ... wizard.php .

Update2: Ok, now I have no error message - but the translation still does not work

[s]But gTranslate write:
Site error: the file /kunden/283986_38527/webseiten/wordpress/gtranslate/translate.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation.
[/s]

I do not know what I must to do, that gTranslate work.
Please help me.

Many greetings
Kai

PS: This is a part from the php.ini:

...
zend_optimizer.enable_loader = On
zend_optimizer.optimization_level = 15
zend_extension = "/kunden/283986_38527/webseiten/wordpress/ioncube/ioncube_loader_lin_5.2.so"
...
(Blog use php5.2)

PPS:

Here are the debug.txt:

"* About to connect() to http://www.mein-elektroauto.com port 80 (#0)
* Trying 46.252.18.25... * connected
* Connected to http://www.mein-elektroauto.com (46.252.18.25) port 80 (#0)
> GET / HTTP/1.1

User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

Host: http://www.mein-elektroauto.com

Accept: */*

Cookie: wpcontaxe_cntvisits=443; wpcontaxe_lastvisit=1320598840; __utma=50537653.974986834.1314093506.1320593369.1320597237.200; __utmz=50537653.1319840697.170.164.utmcsr=google|utmccn=(organic)|utmcmd=organic|utmctr=forvision; wp-settings-1=editor%3Dtinymce%26hidetb%3D1%26imgsize%3Dmedium%26align%3Dnone%26m0%3Do%26m10%3Do%26m9%3Do%26m1%3Do%26m6%3Do%26m12%3Do%26m11%3Dc%26m7%3Do%26wplink%3D0%26m5%3Do%26m8%3Do%26galcols%3D4; wp-settings-time-1=1320515485; PHPSESSID=5af6f906b9ec1c85049cebb0cd286155; MySQLDumper=83b6e469e93d3f9a13db47826e6201e2; w3tc_referrer=http%3A%2F%2Fwww.mein-elektroauto.com%2Fwp-admin%2Fupdate.php%3Faction%3Dinstall-plugin%26plugin%3Dw3-total-cache%26_wpnonce%3D0cf719f18b; wordpress_test_cookie=WP+Cookie+check; __utmc=50537653; wordpress_logged_in_b693a0b7a7444f6cedac48fd57f03e13=KaiDomroese%7C1320708105%7C043011f8e8e9a88c87d8f1d5854fb11b; googtrans=/de/de; googtrans=/de/de; __utmb=50537653.11.10.1320597237



< HTTP/1.1 200 OK

< Date: Sun, 06 Nov 2011 17:06:03 GMT

< Server: Apache/2.2.20

< X-Pingback: http://www.mein-elektroauto.com/xmlrpc.php

< Expires: Wed, 11 Jan 1984 05:00:00 GMT

< Cache-Control: no-cache, must-revalidate, max-age=0

< Pragma: no-cache

< X-Powered-By: W3 Total Cache/0.9.2.4

< Set-Cookie: wpcontaxe_cntvisits=444; expires=Mon, 05-Nov-2012 17:06:04 GMT; path=/

< Set-Cookie: wpcontaxe_lastvisit=1320599164; expires=Mon, 05-Nov-2012 17:06:04 GMT; path=/

< Last-Modified: Sun, 06 Nov 2011 17:06:04 GMT

< Vary: User-Agent,Accept-Encoding

< Connection: close

< Transfer-Encoding: chunked

< Content-Type: text/html; charset=UTF-8

<

* Closing connection #0
* About to connect() to http://www.mein-elektroauto.com port 80 (#0)
* Trying 46.252.18.25... * connected
* Connected to http://www.mein-elektroauto.com (46.252.18.25) port 80 (#0)
> GET / HTTP/1.1

User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

Host: http://www.mein-elektroauto.com

Accept: */*

Cookie: wpcontaxe_cntvisits=443; wpcontaxe_lastvisit=1320598840; __utma=50537653.974986834.1314093506.1320593369.1320597237.200; __utmz=50537653.1319840697.170.164.utmcsr=google|utmccn=(organic)|utmcmd=organic|utmctr=forvision; wp-settings-1=editor%3Dtinymce%26hidetb%3D1%26imgsize%3Dmedium%26align%3Dnone%26m0%3Do%26m10%3Do%26m9%3Do%26m1%3Do%26m6%3Do%26m12%3Do%26m11%3Dc%26m7%3Do%26wplink%3D0%26m5%3Do%26m8%3Do%26galcols%3D4; wp-settings-time-1=1320515485; PHPSESSID=5af6f906b9ec1c85049cebb0cd286155; MySQLDumper=83b6e469e93d3f9a13db47826e6201e2; w3tc_referrer=http%3A%2F%2Fwww.mein-elektroauto.com%2Fwp-admin%2Fupdate.php%3Faction%3Dinstall-plugin%26plugin%3Dw3-total-cache%26_wpnonce%3D0cf719f18b; wordpress_test_cookie=WP+Cookie+check; __utmc=50537653; wordpress_logged_in_b693a0b7a7444f6cedac48fd57f03e13=KaiDomroese%7C1320708105%7C043011f8e8e9a88c87d8f1d5854fb11b; googtrans=/de/et; googtrans=/de/et; __utmb=50537653.12.10.1320597237



< HTTP/1.1 200 OK

< Date: Sun, 06 Nov 2011 17:07:43 GMT

< Server: Apache/2.2.20

< X-Pingback: http://www.mein-elektroauto.com/xmlrpc.php

< Expires: Wed, 11 Jan 1984 05:00:00 GMT

< Cache-Control: no-cache, must-revalidate, max-age=0

< Pragma: no-cache

< X-Powered-By: W3 Total Cache/0.9.2.4

< Set-Cookie: wpcontaxe_cntvisits=444; expires=Mon, 05-Nov-2012 17:07:43 GMT; path=/

< Set-Cookie: wpcontaxe_lastvisit=1320599263; expires=Mon, 05-Nov-2012 17:07:43 GMT; path=/

< Last-Modified: Sun, 06 Nov 2011 17:07:43 GMT

< Vary: User-Agent,Accept-Encoding

< Connection: close

< Transfer-Encoding: chunked

< Content-Type: text/html; charset=UTF-8

<

* Closing connection #0
* About to connect() to http://www.googleapis.com port 443 (#0)
* Trying 209.85.147.95... * connected
* Connected to http://www.googleapis.com (209.85.147.95) port 443 (#0)
* successfully set certificate verify locations:
* CAfile: none
CApath: /etc/ssl/certs
* SSL connection using ECDHE-RSA-RC4-SHA
* Server certificate:
* subject: C=US; ST=California; L=Mountain View; O=Google Inc; CN=*.googleapis.com
* start date: 2011-09-20 06:07:19 GMT
* expire date: 2012-09-20 06:17:19 GMT
* subjectAltName: http://www.googleapis.com matched
* issuer: C=US; O=Google Inc; CN=Google Internet Authority
* SSL certificate verify ok.
> POST /language/translate/v2 HTTP/1.1

Host: http://www.googleapis.com

Accept: */*

X-HTTP-Method-Override: GET

Content-Length: 96

Content-Type: application/x-www-form-urlencoded



< HTTP/1.1 403 Forbidden

< Content-Type: application/json; charset=UTF-8

< Date: Sun, 06 Nov 2011 17:07:46 GMT

< Expires: Sun, 06 Nov 2011 17:07:46 GMT

< Cache-Control: private, max-age=0

< X-Content-Type-Options: nosniff

< X-Frame-Options: SAMEORIGIN

< X-XSS-Protection: 1; mode=block

< Server: GSE

< Transfer-Encoding: chunked

<

* Connection #0 to host http://www.googleapis.com left intact
* Closing connection #0
Request: key=*****Here is the Api-Key from Google&q=%EF%BB%BF&userip=78.55.199.114&source=de&target=ko

Response: {
"error": {
"errors": [
{
"domain": "usageLimits",
"reason": "dailyLimitExceeded",
"message": "Daily Limit Exceeded"
}
],
"code": 403,
"message": "Daily Limit Exceeded"
}
}

* About to connect() to http://www.mein-elektroauto.com port 80 (#0)
* Trying 46.252.18.25... * connected
* Connected to http://www.mein-elektroauto.com (46.252.18.25) port 80 (#0)
> GET / HTTP/1.1

User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

Host: http://www.mein-elektroauto.com

Accept: */*

Cookie: wpcontaxe_cntvisits=444; wpcontaxe_lastvisit=1320599280; __utma=50537653.974986834.1314093506.1320593369.1320597237.200; __utmz=50537653.1319840697.170.164.utmcsr=google|utmccn=(organic)|utmcmd=organic|utmctr=forvision; wp-settings-1=editor%3Dtinymce%26hidetb%3D1%26imgsize%3Dmedium%26align%3Dnone%26m0%3Do%26m10%3Do%26m9%3Do%26m1%3Do%26m6%3Do%26m12%3Do%26m11%3Dc%26m7%3Do%26wplink%3D0%26m5%3Do%26m8%3Do%26galcols%3D4; wp-settings-time-1=1320515485; PHPSESSID=5af6f906b9ec1c85049cebb0cd286155; MySQLDumper=83b6e469e93d3f9a13db47826e6201e2; w3tc_referrer=http%3A%2F%2Fwww.mein-elektroauto.com%2Fwp-admin%2Fupdate.php%3Faction%3Dinstall-plugin%26plugin%3Dw3-total-cache%26_wpnonce%3D0cf719f18b; wordpress_test_cookie=WP+Cookie+check; __utmc=50537653; wordpress_logged_in_b693a0b7a7444f6cedac48fd57f03e13=KaiDomroese%7C1320708105%7C043011f8e8e9a88c87d8f1d5854fb11b; googtrans=/de/et; googtrans=/de/et; __utmb=50537653.14.10.1320597237



< HTTP/1.1 200 OK

< Date: Sun, 06 Nov 2011 17:08:12 GMT

< Server: Apache/2.2.20

< X-Pingback: http://www.mein-elektroauto.com/xmlrpc.php

< Expires: Wed, 11 Jan 1984 05:00:00 GMT

< Cache-Control: no-cache, must-revalidate, max-age=0

< Pragma: no-cache

< X-Powered-By: W3 Total Cache/0.9.2.4

< Set-Cookie: wpcontaxe_cntvisits=445; expires=Mon, 05-Nov-2012 17:08:12 GMT; path=/

< Set-Cookie: wpcontaxe_lastvisit=1320599292; expires=Mon, 05-Nov-2012 17:08:12 GMT; path=/

< Last-Modified: Sun, 06 Nov 2011 17:08:12 GMT

< Vary: User-Agent,Accept-Encoding

< Connection: close

< Transfer-Encoding: chunked

< Content-Type: text/html; charset=UTF-8

<

* Closing connection #0
* About to connect() to http://www.mein-elektroauto.com port 80 (#0)
* Trying 46.252.18.25... * connected
* Connected to http://www.mein-elektroauto.com (46.252.18.25) port 80 (#0)
> GET / HTTP/1.1

User-Agent: Mediapartners-Google

Host: http://www.mein-elektroauto.com

Accept: */*

Cookie:



< HTTP/1.1 200 OK

< Date: Sun, 06 Nov 2011 17:08:24 GMT

< Server: Apache/2.2.20

< Expires: Thu, 19 Nov 1981 08:52:00 GMT

< Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0

< Pragma: no-cache

< X-Pingback: http://www.mein-elektroauto.com/xmlrpc.php

< Vary: Cookie,User-Agent,Accept-Encoding

< X-Powered-By: W3 Total Cache/0.9.2.4

< Set-Cookie: PHPSESSID=3ae9077da5fb5444c737fb6fb5f7bfbf; path=/

< Set-Cookie: wpcontaxe_cntvisits=1; expires=Mon, 05-Nov-2012 17:08:25 GMT; path=/

< Set-Cookie: wpcontaxe_lastvisit=1320599305; expires=Mon, 05-Nov-2012 17:08:25 GMT; path=/

< Last-Modified: Sun, 06 Nov 2011 17:08:26 GMT

< Connection: close

< Transfer-Encoding: chunked

< Content-Type: text/html; charset=UTF-8

<

* Closing connection #0
* About to connect() to http://www.mein-elektroauto.com port 80 (#0)
* Trying 46.252.18.25... * connected
* Connected to http://www.mein-elektroauto.com (46.252.18.25) port 80 (#0)
> GET / HTTP/1.1

User-Agent: contaxe.com

Host: http://www.mein-elektroauto.com

Accept: */*

Cookie:



< HTTP/1.1 200 OK

< Date: Sun, 06 Nov 2011 17:08:20 GMT

< Server: Apache/2.2.20

< Expires: Thu, 19 Nov 1981 08:52:00 GMT

< Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0

< Pragma: no-cache

< X-Pingback: http://www.mein-elektroauto.com/xmlrpc.php

< Vary: Cookie,User-Agent,Accept-Encoding

< X-Powered-By: W3 Total Cache/0.9.2.4

< Set-Cookie: PHPSESSID=42aad052d7dc09b71244552af0c50227; path=/

< Set-Cookie: wpcontaxe_cntvisits=1; expires=Mon, 05-Nov-2012 17:08:21 GMT; path=/

< Set-Cookie: wpcontaxe_lastvisit=1320599301; expires=Mon, 05-Nov-2012 17:08:21 GMT; path=/

< Last-Modified: Sun, 06 Nov 2011 17:08:28 GMT

< Connection: close

< Transfer-Encoding: chunked

< Content-Type: text/html; charset=UTF-8

<

* Closing connection #0
KaiDomroese
 
Posts: 3
Joined: Sun Nov 06, 2011 4:11 pm

Re: gTranslate Pro dont work

Postby Edvard » Sun Nov 06, 2011 9:28 pm

Hi,

Seems that you have fixed the issue with ionCube.

You need to remove the API key and it will work without API. Just select the main language in the config.php and left everything else as is.

After that you need to delete gtranslate/cache/limit.txt file.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: gTranslate Pro dont work

Postby KaiDomroese » Sun Nov 06, 2011 9:40 pm

Thanks for your answer,
i delete the limit.txt and the API.key in the config.php.
But it still does not work.
Here are my config.php:

<?php
define('MAIN_LANG', 'de'); // Main language code: en, ar, bg, hr, cn, ct, cs, da, et, tl, fi, fr, gl, el, iw, hi, es, nl, id, ja, ca, ko, lt, lv, mt, de, no, pt, ru, ro, sr, sk, sl, sv, th, tr, uk, hu, vi, it, pl, sq

define('API_KEY', ''); // You can get your Google Translate API key from https://code.google.com/apis/console/?api=translate
define('AUTO_DETECT_LANG', false); // set to true if you have mixed language content, works with Google only
define('CACHE_TIME', 365*24*60*60); // 1 year by default, no need to decrease
define('LICENSE', 'license.dat');
define('SSL_VERIFY_PEER', true); // disable if you get CA certificate error and cannot reconfigure your server to solve the issue
define('FOLLOW_LOCATION', false); // if your site have redirects for some URLs and for that reason you see blank pages, you need to enable this feature
define('USE_BING_TRANSLATOR', false); // Enable it to use Bing Translotor instead of Google Translate
define('BING_API_KEY', 'INSERT-YOUR-KEY'); // If the option above is enabled you need to get your Bing API key from http://www.bing.com/developers/createapp.aspx (PHP SOAP client is required)
define('DEBUG', false); // turn on for debug mode

// username and password to edit translations, please change for security reasons,
// this is not your google login/pass, you need to think something new
define('USER', '***'); There no stars,
define('PASS', '***');
KaiDomroese
 
Posts: 3
Joined: Sun Nov 06, 2011 4:11 pm

Re: gTranslate Pro dont work

Postby Edvard » Sun Nov 06, 2011 9:55 pm

Hi,

Please check: http://www.mein-elektroauto.com/en/

Try to use this rewrite rules instead:

Code: Select all
# gtranslate config
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2&force_no_api=1&force_translation=1 [L,QSA]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1&force_no_api=1&force_translation=1 [L,QSA]
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: gTranslate Pro dont work

Postby KaiDomroese » Tue Nov 08, 2011 10:47 pm

Thank you very much, it works so far.
But why the current articles are not translated?

Ok... i think its the translation limit from Google - or?
Now be translated as the current article ...
KaiDomroese
 
Posts: 3
Joined: Sun Nov 06, 2011 4:11 pm

Re: gTranslate Pro dont work

Postby Edvard » Wed Nov 09, 2011 5:44 pm

I cannot find any articles that are not translated. Can you send a link?

BTW. You need to configure GTranslate language selector to use Redirect translation method and turn on Pro option. Currently you are using Google Default translation method.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux
cron