[Solved] Gtranslate pro & google api 2.0

Popular automatic website translation tool

[Solved] Gtranslate pro & google api 2.0

Postby lakis21 » Fri Feb 03, 2012 9:48 pm

hallo, I am using the gtranslate pro for 9 months now. I have the latest version installed. Because I 've change server I didn't copy the cache folder of gtranslate.
after 15 days on the new server I have not translation for the serbian language.
My site is http://www.makishouse.com.
I think that serbian in not support form google free or bing.
I register for Google translate API 2.0 I place the api key on the config file but it doesn't work... :(
What I have to do to enable and work?
I need the serbian translation.

Thank you!
lakis21
 
Posts: 22
Joined: Mon May 09, 2011 12:05 pm

Re: Gtranslate pro & google api 2.0

Postby Yana » Fri Feb 03, 2012 11:24 pm

Hi,
The translation isn't made because you don't have an appropriate certificate, so your host can verify google translator server.
* About to connect() to www.googleapis.com port 443 (#0)
* Trying 209.85.147.95... * connected
* Connected to www.googleapis.com (209.85.147.95) port 443 (#0)
* SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
* Closing connection #0

Please fix this issue with the Certificate Authority (CA).
You can find logs here www.makishouse.com/gtranslate/debug.txt .
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4133
Joined: Thu Jan 12, 2012 6:21 pm

Re: Gtranslate pro & google api 2.0

Postby lakis21 » Sat Feb 04, 2012 9:57 am

Hi Yana,
I disable ssl define('SSL_VERIFY_PEER', false).
But the api doesn't work
no serbian...
here is my config:
Code: Select all
<?php
define('MAIN_LANG', 'en'); // Main language code: en, ar, bg, hr, cn, ct, cs, da, et, tl, fi, fr, gl, el, iw, hi, es, nl, id, ja, ca, ko, lt, lv, mt, de,

no, pt, ru, ro, sr, sk, sl, sv, th, tr, uk, hu, vi, it, pl, sq

define('API_KEY', 'AIzaSyDcsErJ73MB6ZTANH5w_WDUxxxxxxxx'); // You can get your Google Translate API key from https://code.google.com/apis/console/?

api=translate
define('AUTO_DETECT_LANG', false); // set to true if you have mixed language content, works with Google only
define('CACHE_TIME', 365*24*60*60); // 1 year by default, no need to decrease
define('LICENSE', 'license.dat');
define('SSL_VERIFY_PEER', false); // disable if you get CA certificate error and cannot reconfigure your server to solve the issue
define('FOLLOW_LOCATION', false); // if your site have redirects for some URLs and for that reason you see blank pages, you need to enable this feature
define('USE_BING_TRANSLATOR', false); // Enable it to use Bing Translotor instead of Google Translate
define('BING_API_KEY', 'INSERT-YOUR-KEY'); // If the option above is enabled you need to get your Bing API key from

http://www.bing.com/developers/createapp.aspx (PHP SOAP client is required)
define('DEBUG', true); // turn on for debug mode

// username and password to edit translations, please change for security reasons,
// this is not your google login/pass, you need to think something new
define('USER', 'xxxx');
define('PASS', 'xxxx');


Do I have to change anything else?
lakis21
 
Posts: 22
Joined: Mon May 09, 2011 12:05 pm

Re: Gtranslate pro & google api 2.0

Postby Yana » Sat Feb 04, 2012 10:32 pm

Hi,
It is not the SSL server certificate, it is just Certificate Authority (CA). With it your host verifies the other party.

You should check this with your hosting provider. The server doesn't configured properly. Please contact your hosting provider asking them to fix the issue and send this lines.

* About to connect() to http://www.googleapis.com port 443 (#0)
* Trying 209.85.147.95... * connected
* Connected to http://www.googleapis.com (209.85.147.95) port 443 (#0)
* SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
* Closing connection #0
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4133
Joined: Thu Jan 12, 2012 6:21 pm

Re: Gtranslate pro & google api 2.0

Postby lakis21 » Mon Feb 06, 2012 10:05 am

thank you, the error was on Referers on the api access, i've change it to:
Any referer allowed.
and then It worked.
I couldn't do anything on my windows 2008 r2, about the CA, so I left ssl define('SSL_VERIFY_PEER', false).
Now everything is working and the google is charging...

Thank you I have now Serbian Language back!
Regards,
Lakis
lakis21
 
Posts: 22
Joined: Mon May 09, 2011 12:05 pm

Re: [Solved] Gtranslate pro & google api 2.0

Postby Yana » Mon Feb 06, 2012 2:27 pm

Good to hear that!
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4133
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux