GTranslate Pro not working > Joomla 1.7.3

Popular automatic website translation tool

GTranslate Pro not working > Joomla 1.7.3

Postby swisschallenge » Fri Dec 23, 2011 7:56 pm

Hello Edvard
GTranslate working in Joomla 1.5 Pro perfectly. In December, we moved on to Joomla 1.7.3. GTranslate now no longer works. No translation takes place more! We have changed nothing except the new module for Joomla 1.7.x (mod_gtranslate1.6.x28.zip) uploaded. Can you help us.
Greetings Markus
www.swisschallenge.ch
swisschallenge
 
Posts: 8
Joined: Sat Jun 11, 2011 1:48 pm

Re: GTranslate Pro not working > Joomla 1.7.3

Postby Edvard » Sun Dec 25, 2011 7:16 pm

Hi,

Just sent the latest version for you. Please replace all the files in gtranslate folder with the ones in general/gtranslate folder from the product package and reconfigure gtranslate/config.php to ONLY add the main language of your website.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate Pro not working > Joomla 1.7.3

Postby swisschallenge » Tue Dec 27, 2011 7:17 pm

Hi Edvard
Thank you for the transmission of the new file. I've done the installation according to instructions. The plugin for Joomla 1.7 is installed. Unfortunately, there still is no translation. I get no error message.
Greeting Markus
swisschallenge
 
Posts: 8
Joined: Sat Jun 11, 2011 1:48 pm

Re: GTranslate Pro not working > Joomla 1.7.3

Postby trench » Wed Dec 28, 2011 1:59 pm

Unfortunately I have the same problem with the translation with Joomla 1.7.3, I hope that Edvard solves the problem ;)
trench
 
Posts: 21
Joined: Mon Sep 26, 2011 9:46 pm

Re: GTranslate Pro not working > Joomla 1.7.3

Postby Edvard » Thu Dec 29, 2011 4:52 pm

Hi,

Did you add API keys in the plugin configuration settings? In case you did that remove them.

Also, please turn on the debug mode to write into file, so I can check it for you.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate Pro not working > Joomla 1.7.3

Postby swisschallenge » Fri Dec 30, 2011 5:09 pm

Hi
I have no API key set in the System GTranslate plugin. I have set debug mode "Write in a translation log file". Nothing happens. Therefore, I have config.php "DEBUG" is set to true. File debug.txt in the Appendix.
Greetings Markus

Code: Select all
* About to connect() to www.swisschallenge.ch port 80 (#0)
*   Trying 92.43.216.109... * connected
* Connected to www.swisschallenge.ch (92.43.216.109) port 80 (#0)
> GET / HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Host: www.swisschallenge.ch
Accept: */*
Cookie: jpanesliders_panel-sliders=1; jpanesliders_module-sliders=0; jpanetabs_module-menu-assignment-tabs=0; jpanesliders_plugin-sliders-10061=0; d1a0253ed7de76a22db61f2559154731=6b1vt4dpje5ekc0s76i5ugqdp4; __utma=195079854.757080347.1325246066.1325246066.1325246066.1; __utmb=195079854.23.10.1325246066; __utmc=195079854; __utmz=195079854.1325246066.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); 51ae55ba0fe3a2e2c171236ad1aaa137=b8ocaulen33rkguh3scqfq3ir6

< HTTP/1.1 200 OK
< Date: Fri, 30 Dec 2011 12:27:49 GMT
< Server: Microsoft-IIS/6.0
< X-Powered-By: ASP.NET
< P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
< Content-Type: text/html; charset=utf-8
< Cache-Control: no-cache
< Pragma: no-cache
< Content-Length: 29409
<
* Connection #0 to host www.swisschallenge.ch left intact
* Closing connection #0
* About to connect() to www.googleapis.com port 443 (#0)
*   Trying 173.194.66.95... * connected
* Connected to www.googleapis.com (173.194.66.95) port 443 (#0)
* SSL connection using RC4-SHA
* Server certificate:
*     subject: C=US; ST=California; L=Mountain View; O=Google Inc; CN=*.googleapis.com
*     start date: 2011-11-21 03:59:39 GMT
*     expire date: 2012-11-21 04:09:39 GMT
*     subjectAltName: www.googleapis.com matched
*     issuer: C=US; O=Google Inc; CN=Google Internet Authority
*     SSL certificate verify result: unable to get local issuer certificate (20), continuing anyway.
> POST /language/translate/v2 HTTP/1.1
Host: www.googleapis.com
Accept: */*
X-HTTP-Method-Override: GET
Content-Length: 241
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 403 Forbidden
< Content-Type: application/json; charset=UTF-8
< Date: Fri, 30 Dec 2011 12:28:23 GMT
< Expires: Fri, 30 Dec 2011 12:28:23 GMT
< Cache-Control: private, max-age=0
< X-Content-Type-Options: nosniff
< X-Frame-Options: SAMEORIGIN
< X-XSS-Protection: 1; mode=block
< Server: GSE
< Transfer-Encoding: chunked
<
* Connection #0 to host www.googleapis.com left intact
* Closing connection #0
Request: key=AIzaSyBLAs71cEQaMQsftFKJEgJ2hupsd5NDihk&q=canyoning%2C+canyoning+tessin%2C+canyoning+ticino%2C+rafting%2C+rafting+ticino%2C+river+rafting%2C+outdoor%2C+adventure%2C+abenteuer%2C+aktivit%C3%A4ten&userip=178.198.217.145&source=de&target=en

Response: {
"error": {
  "errors": [
   {
    "domain": "usageLimits",
    "reason": "dailyLimitExceeded",
    "message": "Daily Limit Exceeded"
   }
  ],
  "code": 403,
  "message": "Daily Limit Exceeded"
}
}

* About to connect() to www.swisschallenge.ch port 80 (#0)
*   Trying 92.43.216.109... * connected
* Connected to www.swisschallenge.ch (92.43.216.109) port 80 (#0)
> GET / HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Host: www.swisschallenge.ch
Accept: */*
Cookie: jpanesliders_panel-sliders=1; jpanesliders_module-sliders=0; jpanetabs_module-menu-assignment-tabs=0; jpanesliders_plugin-sliders-10061=0; d1a0253ed7de76a22db61f2559154731=6b1vt4dpje5ekc0s76i5ugqdp4; __utma=195079854.757080347.1325246066.1325246066.1325246066.1; __utmb=195079854.24.10.1325246066; __utmc=195079854; __utmz=195079854.1325246066.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); 51ae55ba0fe3a2e2c171236ad1aaa137=b8ocaulen33rkguh3scqfq3ir6

< HTTP/1.1 200 OK
< Date: Fri, 30 Dec 2011 12:28:07 GMT
< Server: Microsoft-IIS/6.0
< X-Powered-By: ASP.NET
< P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
< Content-Type: text/html; charset=utf-8
< Cache-Control: no-cache
< Pragma: no-cache
< Content-Length: 29409
<
* Connection #0 to host www.swisschallenge.ch left intact
* Closing connection #0
* About to connect() to www.swisschallenge.ch port 80 (#0)
*   Trying 92.43.216.109... * connected
* Connected to www.swisschallenge.ch (92.43.216.109) port 80 (#0)
> GET / HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Host: www.swisschallenge.ch
Accept: */*
Cookie: jpanesliders_panel-sliders=1; jpanesliders_module-sliders=0; jpanetabs_module-menu-assignment-tabs=0; jpanesliders_plugin-sliders-10061=0; d1a0253ed7de76a22db61f2559154731=6b1vt4dpje5ekc0s76i5ugqdp4; __utma=195079854.757080347.1325246066.1325246066.1325246066.1; __utmb=195079854.25.10.1325246066; __utmc=195079854; __utmz=195079854.1325246066.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); 51ae55ba0fe3a2e2c171236ad1aaa137=b8ocaulen33rkguh3scqfq3ir6

< HTTP/1.1 200 OK
< Date: Fri, 30 Dec 2011 12:28:16 GMT
< Server: Microsoft-IIS/6.0
< X-Powered-By: ASP.NET
< P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
< Content-Type: text/html; charset=utf-8
< Cache-Control: no-cache
< Pragma: no-cache
< Content-Length: 29409
<
* Connection #0 to host www.swisschallenge.ch left intact
* Closing connection #0
swisschallenge
 
Posts: 8
Joined: Sat Jun 11, 2011 1:48 pm

Re: GTranslate Pro not working > Joomla 1.7.3

Postby Edvard » Tue Jan 03, 2012 6:01 pm

Hi,

I can see from the debug.txt file that you have api key somewhere:

Request: key=AIzaSyBLAs71cEQaMQsftFKJEgJ2hupsd5NDihk&q=canyoning%2C+canyoning+tessin%2C+canyoning+ticino%2C+rafting%2C+rafting+ticino%2C+river+rafting%2C+outdoor%2C+adventure%2C+abenteuer%2C+aktivit%C3%A4ten&userip=178.198.217.145&source=de&target=en

I think you have installed both the plugin for joomla and the one for general websites which is located in gtranslate folder of your www root.

If there is no API key in the plugin, then just disable it and replace gtranslate files with the ones in general/gtranslate folder in the product package. After that edit gtranslate/config.php file to select a correct main language of your website.

That should fix your issues.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate Pro not working > Joomla 1.7.3

Postby swisschallenge » Thu Jan 05, 2012 3:19 pm

Hi
I have deleted the folder "gtranslate" on the server and then all dates new uploaded. Now works the translation. It seems a new error. Edit text works, can not save "button save" = fail!. I delete everything again and upload all files again high. It works again, nothing more, although I have changed no other files. It's really annoying. The program responds differently to each installation. Can not be work!
Markus
swisschallenge
 
Posts: 8
Joined: Sat Jun 11, 2011 1:48 pm

Re: GTranslate Pro not working > Joomla 1.7.3

Postby Edvard » Sat Jan 07, 2012 11:02 pm

OK, now I can see that you have removed the plugin and installed it by following the installation steps from general/readme.txt.

However, did you change something in gtranslate/edit_translation.php file? It shouldn't tell fail after you hit the save button, it should prompt for login/password.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate Pro not working > Joomla 1.7.3

Postby swisschallenge » Sun Jan 08, 2012 5:21 pm

Hi Edvard
Your help bring me any further. I've spent much time with the problems of GTranslate. And I'm not a beginner. The problem is not on my installation. I hope you will soon publish an update that works without major adjustments. This version definitely makes no sense!
Markus
swisschallenge
 
Posts: 8
Joined: Sat Jun 11, 2011 1:48 pm

Re: GTranslate Pro not working > Joomla 1.7.3

Postby Edvard » Tue Jan 10, 2012 12:02 am

Hi,

It works as expected for my other clients. If you are not able to solve the issue, I can look into for you if you can give me temporary FTP access.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate Pro not working > Joomla 1.7.3

Postby swisschallenge » Tue Jan 10, 2012 1:32 pm

Hello Edvard
I send you the FTP access via email. Thank you very much.
Markus
swisschallenge
 
Posts: 8
Joined: Sat Jun 11, 2011 1:48 pm

Re: GTranslate Pro not working > Joomla 1.7.3

Postby paulg » Fri Jan 13, 2012 8:29 pm

Hi Markus,

Maybe Edvard has already solved it but it seems to me that everything works fine. Just try yourwebsite/en/ or /fr/ or /de/ or /it/ and translation works.
I guess you only have to active the free module for setting up the flags.

Greetings, Paul
paulg
 
Posts: 45
Joined: Wed Nov 30, 2011 12:38 pm

Re: GTranslate Pro not working > Joomla 1.7.3

Postby Yana » Thu Jan 19, 2012 12:06 am

Hi Markus,

You should download and install GTranslate Free module for your website from https://gtranslate.io. Select 'Redirect' translation method and turn 'Operate with GTranslate Pro' option On. This will enable the language selector.
If you'll have problems please send backend admin access details and we'll install it for you.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux