GTranslate Pro

Popular automatic website translation tool

Re: GTranslate Pro

Postby Edvard » Tue Apr 26, 2011 1:45 pm

Hi,

The first thing that I have noticed is that you don't use the language selector in the Redirect translation method. Second issue is that when I go to http://yesbo.de/en/ for English, I get 404 not found error. Please check the troubleshooting for solving the 404 issue.

P.S. If you want to use it in On Fly translation method meanwhile, make sure that jquery-translate.js file loads. I have checked and didn't find it, may be you have modified something...
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4184
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate Pro

Postby [email protected] » Fri Apr 29, 2011 1:21 am

GTranslate pro does not work - you may check http://www.herbalterra.com
I read this:
6. When I select a language I'm being redirected to a URL with the language code, but I still can see the original language.
- Make sure the API key is correct, read 5.

my config
Code: Select all
<?php
define('API_KEY', 'ABQIAAAAoQEMo2A9yveCC9GrveCWOxTr7EPMkdL0yTLoyTS3906kvdpxgxTR_BJdQ5K7u2BPqftxAlGiDVi7nA');
define('AUTO_DETECT_LANG', false); // set to true if you have mixed language content
define('CACHE_TIME', 365*24*60*60); // 1 year by default, no need to decrease
define('LICENSE', 'license.dat');
define('SSL_VERIFY_PEER', false); // disable if you get CA certificate error and cannot reconfigure your server to solve the issue
define('DEBUG', true); // turn on for debug mode

Image

- Enable debug: define('DEBUG', true); in gtranslate/config.php, delete cache/limit.txt if it exists and refresh the page. After that you will see a debug.txt file inside gtranslate folder, where you will see the communication between your server and google translator. Check the request URL for a translation and the response. If you have reached the daily limit for your API key you need to wait. If you get a Bad Request then the API key is incorrect.

Code: Select all
* About to connect() to www.herbalterra.com port 80 (#0)
*   Trying 95.211.73.157... * connected
* Connected to www.herbalterra.com (95.211.73.157) port 80 (#0)
> GET /zippo-pin-up-girl/zazhigalka-zippo-6892.html HTTP/1.1
User-Agent: Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)
Host: www.herbalterra.com
Accept: */*
Cookie:

* HTTP 1.0, assume close after body
< HTTP/1.0 200 OK
< Date: Thu, 28 Apr 2011 21:19:23 GMT
< Server: Apache/2
< X-Powered-By: PHP/5.2.14
< Set-Cookie: eee5cd81438bca57b6776a1bc26a8e41=85ea59fdd4d4bf0e38717b2f003ecb8b; path=/
< P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
< Set-Cookie: lang=deleted; expires=Wed, 28-Apr-2010 21:19:23 GMT; path=/
< Set-Cookie: jfcookie=deleted; expires=Wed, 28-Apr-2010 21:19:23 GMT; path=/
< Set-Cookie: jfcookie[lang]=deleted; expires=Wed, 28-Apr-2010 21:19:23 GMT; path=/
< Set-Cookie: kide_config=v%3D2%3B; expires=Sat, 28-May-2011 21:19:25 GMT; path=/
< Expires: Mon, 1 Jan 2001 00:00:00 GMT
< Last-Modified: Thu, 28 Apr 2011 21:19:26 GMT
< Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
< Pragma: no-cache
< Vary: Accept-Encoding,User-Agent
< Connection: close
< Content-Type: text/html; charset=utf-8
<
* Closing connection #0

What should I do now?
[email protected]
 
Posts: 6
Joined: Fri Apr 29, 2011 12:29 am

Re: GTranslate Pro

Postby Edvard » Fri Apr 29, 2011 8:22 pm

Your API key is incorrect. You need to get a Translate API key from https://code.google.com/apis/console/ .
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4184
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


Re: GTranslate Pro

Postby Edvard » Sat Apr 30, 2011 12:24 am

As I have mentioned in my previous post, you need to login to https://code.google.com/apis/console/ and enable the Translate API, after that you will get a key which you need to use in the config.php.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4184
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate Pro

Postby [email protected] » Sat Apr 30, 2011 2:10 am

I got new API but it does not help me to run your script
Code: Select all
* About to connect() to www.herbalterra.com port 80 (#0)
*   Trying 95.211.73.157... * connected
* Connected to www.herbalterra.com (95.211.73.157) port 80 (#0)
> GET /farmacevticheskoe-oborudovanie.html HTTP/1.1
User-Agent: Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)
Host: www.herbalterra.com
Accept: */*
Cookie:

* HTTP 1.0, assume close after body
< HTTP/1.0 200 OK
< Date: Fri, 29 Apr 2011 22:13:30 GMT
< Server: Apache/2
< X-Powered-By: PHP/5.2.14
< Set-Cookie: eee5cd81438bca57b6776a1bc26a8e41=e38e12d1fb50f914d0e2f2f47a952067; path=/
< P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
< Set-Cookie: lang=deleted; expires=Thu, 29-Apr-2010 22:13:29 GMT; path=/
< Set-Cookie: jfcookie=deleted; expires=Thu, 29-Apr-2010 22:13:29 GMT; path=/
< Set-Cookie: jfcookie[lang]=deleted; expires=Thu, 29-Apr-2010 22:13:29 GMT; path=/
< Set-Cookie: kide_config=v%3D2%3B; expires=Sun, 29-May-2011 22:13:32 GMT; path=/
< Expires: Mon, 1 Jan 2001 00:00:00 GMT
< Last-Modified: Fri, 29 Apr 2011 22:13:33 GMT
< Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
< Pragma: no-cache
< Vary: Accept-Encoding,User-Agent
< Connection: close
< Content-Type: text/html; charset=utf-8
<
* Closing connection #0
[email protected]
 
Posts: 6
Joined: Fri Apr 29, 2011 12:29 am

Re: GTranslate Pro

Postby Edvard » Sat Apr 30, 2011 2:51 pm

It seems that you have set an incorrect main language in config.php file. Make sure that you have define('MAIN_LANG', 'ru'); there... Did you delete that line accidentally when setting the API key?
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4184
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate Pro

Postby [email protected] » Sat Apr 30, 2011 11:56 pm

my config file
Code: Select all
<?php
define('API_KEY', 'AIzaSyDL5qbXC3aEuEqvax3pRW-whhu6ZLY2i5M');
define('MAIN_LANG', 'ru');
define('AUTO_DETECT_LANG', false);
define('CACHE_TIME', 365*24*60*60);
define('LICENSE', 'license.dat');
define('SSL_VERIFY_PEER', true);
define('DEBUG', true);
define('USER', '111');
define('PASS', '222');


and debug
Code: Select all
* About to connect() to www.herbalterra.com port 80 (#0)
*   Trying 95.211.73.157... * connected
* Connected to www.herbalterra.com (95.211.73.157) port 80 (#0)
> GET /poluchit-skidku.html HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Host: www.herbalterra.com
Accept: */*
Cookie: googtrans=/ru/en; ys-vmlastpage=s%3Ahttp%3A//www.herbalterra.com/administrator/index2.php%3Fpshop_mode%3Dadmin%26page%3Dorder.order_list%26option%3Dcom_virtuemart; kide_config=v%3D2%3Bgmt%3D-10%3Bretardo%3D178%3B; ys-orderstatuspanel-active=s%3Aext-comp-1003; jfcookie[lang]=ru; phpbb3_i3o7d_u=315; phpbb3_i3o7d_k=; phpbb3_i3o7d_sid=e18a41d637ff96e734db750fb6433594; aff_id=1; jcommentsadmin_group=Unregistered; affiliate_in=40; phpbb3_i3o7d_abbc3=0; googtrans=/ru/en; eee5cd81438bca57b6776a1bc26a8e41=c46c72e8772534658967463cb0e7dd5f; b4700d43a4b26e13cd84f7636a3bf0c6=c5aae209ee70c3e05558d2757429c6b5

< HTTP/1.1 200 OK
< Date: Sat, 30 Apr 2011 19:57:15 GMT
< Server: Apache/2
< X-Powered-By: PHP/5.2.14
< P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
< Set-Cookie: lang=deleted; expires=Fri, 30-Apr-2010 19:57:14 GMT; path=/
< Set-Cookie: jfcookie=deleted; expires=Fri, 30-Apr-2010 19:57:14 GMT; path=/
< Set-Cookie: jfcookie[lang]=ru; expires=Sun, 01-May-2011 19:57:15 GMT; path=/
< ETag: f7bd9b94049e67e7d7c103cce0661d26
< Expires: Mon, 1 Jan 2001 00:00:00 GMT
< Last-Modified: Sat, 30 Apr 2011 19:57:15 GMT
< Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
< Pragma: no-cache
< Vary: Accept-Encoding,User-Agent
< Transfer-Encoding: chunked
< Content-Type: text/html
<
* Connection #0 to host www.herbalterra.com left intact
* Closing connection #0
[email protected]
 
Posts: 6
Joined: Fri Apr 29, 2011 12:29 am

Re: GTranslate Pro

Postby Edvard » Mon May 02, 2011 2:23 pm

I can already see that the translator started to work. For now you just need to wait and it will translate and cache everything over time.

BTW. I suggest to use the GTranslate free for language selection. If you use the in your site, you will need to add class="nturl" to the <a> tags, so you will avoid double language codes in the URLs, ex. http://www.herbalterra.com/en/en/ .
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4184
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


Re: GTranslate Pro

Postby Edvard » Wed May 04, 2011 11:46 am

Not really, see for example Swedish: http://www.herbalterra.com/sv/

I can see that the left menu is already translated into Swedish. Also, checking the debug.txt I can see that it works. Currently you have reached the daily translation limit that's why your page is half translated. You can check your API key usage on https://code.google.com/apis/console/ . If you can see that it uses the daily limit for 100%, then everything is OK, you just need to give it some time.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4184
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia



  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest

2GLux