GTRanslate Pro translation issue

Popular automatic website translation tool

GTRanslate Pro translation issue

Postby [email protected] » Wed Jun 18, 2014 2:17 pm

Hi,
Using GTranslate Pro on this site: http://www.sit-right.se/
It works fine but as the site is in Swedish I do not want the http://www.sit-right.se/sv url when clicking the Swedish flag, is it possible to change so that when you are on the site and go for English with the english flag and then returns to the original page which is swedish there should not be any /sv in the URL which means the site is showing correct spellings etc. and not any weird translations?

Looking forward to your reply.

Thanks
Micke
[email protected]
 
Posts: 32
Joined: Thu Mar 22, 2012 10:05 pm

Re: GTRanslate Pro translation issue

Postby [email protected] » Wed Jun 18, 2014 2:57 pm

I have solved it temporarily by taking away the Swedish flag in the GTranslate module position. Then I added a Swedish flag as a own custom module with the flag as a linked image and the class="nturl" added to the a href tag.
Still though this only redirects you to the index page of the Swedish site not going to the Swedish version of the article you happen to be in at the moment.
So please if there is a less dirty solution to this I would be very happy.
Regards
Micke
[email protected]
 
Posts: 32
Joined: Thu Mar 22, 2012 10:05 pm

Re: GTRanslate Pro translation issue

Postby Yana » Wed Jun 18, 2014 5:55 pm

Dear Micke,

Please check the GTranslate module settings and make sure that you set the default language correctly. It shouldn't add the language code for the default language.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm

Re: GTRanslate Pro translation issue

Postby [email protected] » Wed Jun 18, 2014 6:06 pm

Yana wrote:Dear Micke,

Please check the GTranslate module settings and make sure that you set the default language correctly. It shouldn't add the language code for the default language.


Dear Yana,
The default language (Site Language) is set to Swedish in the Module manager settings.
I don't know what other options there is...
The plugin is not activated, should it be activated?
[email protected]
 
Posts: 32
Joined: Thu Mar 22, 2012 10:05 pm

Re: GTRanslate Pro translation issue

Postby Edvard » Wed Jun 18, 2014 10:13 pm

Dear Micke,

Please check gtranslate/config.php file and make sure that the default language is set to sv (Swedish). In that case when you go to domain.com/sv it will redirect to domain.com

Let me know.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux