Help dried up on last topic, hence new topic

Popular automatic website translation tool

Help dried up on last topic, hence new topic

Postby rentinthealgarve » Sat Mar 29, 2014 12:34 pm

http://pt.rentinthealgarve.co.uk/vrs/fr ... tionSearch

Highlighting the problem again. Enterprise version, part of the url is being translated and it is stopping my website from working. Just the word "front" in the url is being translated to "frente" and it should not be. How can I stop the url translating like this ? Then, when I then navigate away from this page i usually get "The requested URL /vrs/frente/index.php was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request". The server is whitelisted and I tried the new Gtranslate freecode. Help please there must be a fix for this.. thanks, Gavin
rentinthealgarve
 
Posts: 16
Joined: Fri Mar 28, 2014 1:38 pm

Re: Help dried up on last topic, hence new topic

Postby Edvard » Sat Mar 29, 2014 8:02 pm

Hi,

Can you please describe step-by-step what I need to do to see the issue. I can see that your link is working and I have tried to navigate to other pages of your site and it seems to work fine.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Help dried up on last topic, hence new topic

Postby rentinthealgarve » Sat Mar 29, 2014 9:19 pm

Ok, a step-by-step so you can see the problem....

With the English flag selected (default site language), the 2nd button on nav bar will open this page.....
http://www.rentinthealgarve.co.uk/vrs/f ... tionSearch

Clicking on the Portuguese flag, should bring up this page....
http://pt.rentinthealgarve.co.uk/vrs/fr ... tionSearch

but sometimes, it brings up this page, in error....
http://pt.rentinthealgarve.co.uk/vrs/fr ... tionSearch

Did you notice the "front" has been translated to "frente" ? It doesn't happen all the time, but when it does, the page does not load properly because the pins on the Google map do not display. PLUS, depending where you navigate to and if you change language, you are likely to have one of these....
http://no.rentinthealgarve.co.uk/vrs/fr ... jActionAdd

...with a page displaying "The requested URL /vrs/frente/index.php was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

You might not see this error all the time ("front" translating to "frente"), but when it does, a) the page does not display correctly and b) depending where you click to next, you are likely to get a 404.

As far as I can see, we just need the script to not translate words in the url.... it can put pt. in ftont of the url...but don't change any other part of the url please ! Thanks, I am surprised this hasn't happened to anyone else ?!? Kind Regards...
rentinthealgarve
 
Posts: 16
Joined: Fri Mar 28, 2014 1:38 pm

Re: Help dried up on last topic, hence new topic

Postby Edvard » Sat Mar 29, 2014 9:24 pm

Hi,

I can see that there is an issue when navigating from language to language. I can fix it for you, please send FTP access using our Contact us form on our home page.

Let me know.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Help dried up on last topic, hence new topic

Postby rentinthealgarve » Sat Mar 29, 2014 10:07 pm

Thanks Edvard, I have sent you ftp details via contact us on homepage.. How is it going ?
rentinthealgarve
 
Posts: 16
Joined: Fri Mar 28, 2014 1:38 pm

Re: Help dried up on last topic, hence new topic

Postby rentinthealgarve » Mon Mar 31, 2014 11:15 am

Edvard ? Were you not able to fix the error ?
rentinthealgarve
 
Posts: 16
Joined: Fri Mar 28, 2014 1:38 pm

Re: Help dried up on last topic, hence new topic

Postby Edvard » Mon Mar 31, 2014 11:50 am

Hi,

Please find the code you need to use for language selector:

Code: Select all
<a href="http://sv.rentinthealgarve.co.uk<?php echo $_SERVER['REQUEST_URI']; ?>" title="Swedish" class="gflag nturl" style="background-position:-700px -200px; margin: 2px 0px 2px 2px;"><img src="http://joomla-gtranslate.googlecode.com/svn/trunk/mod_gtranslate/tmpl/lang/blank.png" height="32" width="32" alt="Swedish" /></a>
                    <a href="http://no.rentinthealgarve.co.uk<?php echo $_SERVER['REQUEST_URI']; ?>" title="Norwegian" class="gflag nturl" style="background-position:-100px -200px;"><img src="http://joomla-gtranslate.googlecode.com/svn/trunk/mod_gtranslate/tmpl/lang/blank.png" height="32" width="32" alt="Norwegian" /></a>
                    <a href="http://de.rentinthealgarve.co.uk<?php echo $_SERVER['REQUEST_URI']; ?>" title="German" class="gflag nturl" style="background-position:-300px -100px;"><img src="http://joomla-gtranslate.googlecode.com/svn/trunk/mod_gtranslate/tmpl/lang/blank.png" height="32" width="32" alt="German" /></a>
                    <a href="http://fr.rentinthealgarve.co.uk<?php echo $_SERVER['REQUEST_URI']; ?>" title="French" class="gflag nturl" style="background-position:-200px -100px;"><img src="http://joomla-gtranslate.googlecode.com/svn/trunk/mod_gtranslate/tmpl/lang/blank.png" height="32" width="32" alt="French" /></a>
                    <a href="http://es.rentinthealgarve.co.uk<?php echo $_SERVER['REQUEST_URI']; ?>" title="Spanish" class="gflag nturl" style="background-position:-600px -200px;"><img src="http://joomla-gtranslate.googlecode.com/svn/trunk/mod_gtranslate/tmpl/lang/blank.png" height="32" width="32" alt="Spanish" /></a>
                    <a href="http://pt.rentinthealgarve.co.uk<?php echo $_SERVER['REQUEST_URI']; ?>" title="Portuguese" class="gflag nturl" style="background-position:-300px -200px;"><img src="http://joomla-gtranslate.googlecode.com/svn/trunk/mod_gtranslate/tmpl/lang/blank.png" height="32" width="32" alt="Portuguese" /></a>
                    <a href="http://rentinthealgarve.co.uk<?php echo $_SERVER['REQUEST_URI']; ?>" title="English" class="gflag nturl" style="background-position:-0px -0px;"><img src="http://joomla-gtranslate.googlecode.com/svn/trunk/mod_gtranslate/tmpl/lang/blank.png" height="32" width="32" alt="English" /></a>


I have modified vrs\app\views\pjLayouts\pjActionAdmin.php file, but I think that it was not the correct one which is being displayed on your site. If you can let me know where else you have placed the code, I can modify it myself.

Please let me know.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Help dried up on last topic, hence new topic

Postby rentinthealgarve » Mon Mar 31, 2014 12:38 pm

Edvard, we have put that code on two pages (search and login) to test, but it still wants to translate the url. Should it be working correctly immediately, or should we have to wait a while for 'something' to settle down, and give it time ? Thanks.
rentinthealgarve
 
Posts: 16
Joined: Fri Mar 28, 2014 1:38 pm

Re: Help dried up on last topic, hence new topic

Postby Edvard » Mon Mar 31, 2014 12:49 pm

Hi,

Since you have turned on the url translation feature the URLs will be translated. The issue you are having was with the language selector which caused 404 errors when navigating from one language to another. Now I can see that after the code change it doesn't show 404 error. Please let me know.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Help dried up on last topic, hence new topic

Postby rentinthealgarve » Mon Mar 31, 2014 1:34 pm

Edvard, are you saying that we have the option to turn off url translation ? or do you just mean that because we are using the enterprise version, (and it prefixes with *pt. for example), that prefix is the "translated part of the url" ?? thanks.
rentinthealgarve
 
Posts: 16
Joined: Fri Mar 28, 2014 1:38 pm

Re: Help dried up on last topic, hence new topic

Postby Edvard » Mon Mar 31, 2014 1:38 pm

Of course you have option to turn off url translation. But it will be for the whole site not just for part of URL.

You have turned the featue on yourself by adding a special meta tag. If you are not the one who did that for you, please consult your colleagues.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Help dried up on last topic, hence new topic

Postby rentinthealgarve » Mon Mar 31, 2014 9:36 pm

It is fixed, success, thank you.
rentinthealgarve
 
Posts: 16
Joined: Fri Mar 28, 2014 1:38 pm

Re: Help dried up on last topic, hence new topic

Postby Yana » Tue Apr 01, 2014 5:22 pm

You're welcome!
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm


Who is online

Users browsing this forum: No registered users and 0 guests

2GLux