[Solved] Internal Server Error

Popular automatic website translation tool

[Solved] Internal Server Error

Postby josept » Thu Nov 17, 2011 2:18 am

SOLVED
Last edited by josept on Sun Apr 15, 2012 2:45 am, edited 1 time in total.
josept
 
Posts: 37
Joined: Fri Nov 04, 2011 8:47 pm

Re: Internal Server Error

Postby Edvard » Thu Nov 17, 2011 5:14 pm

Check gtranslate/translate.php file permissions. Probably you have set it to 777. It should have the default permission.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Internal Server Error

Postby josept » Thu Nov 17, 2011 7:57 pm

I set to 644, and is the same problem
josept
 
Posts: 37
Joined: Fri Nov 04, 2011 8:47 pm

Re: Internal Server Error

Postby Edvard » Thu Nov 17, 2011 9:00 pm

Hi,

Chack also gtranslate folder permissions.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Internal Server Error

Postby josept » Fri Nov 18, 2011 3:43 pm

not working.

i´m using the plugin you send me to other account...

Can you please check.
Last edited by josept on Fri Nov 18, 2011 9:27 pm, edited 1 time in total.
josept
 
Posts: 37
Joined: Fri Nov 04, 2011 8:47 pm

Re: Internal Server Error

Postby Edvard » Fri Nov 18, 2011 6:00 pm

It was sent to your gmail email address on Nov 12, but that doesn't matter.

Try to delete gtranslate folder and re-upload it again.

After that when you go to http://example.com/gtranslate/config.php it should show a blank page instead of current 500 server error.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Internal Server Error

Postby josept » Sun Nov 20, 2011 5:04 pm

The urls are getting the language extension "clinicaveterinaria.pt/en" but it doesn´t translate
josept
 
Posts: 37
Joined: Fri Nov 04, 2011 8:47 pm

Re: Internal Server Error

Postby Jarrell22 » Mon Nov 21, 2011 3:10 pm

This post is to help anyone who is having 500 Internal Server Errors with their install of PHP 5.3 on IIS 7 in the Windows 2008 Server environment.
Error 500 generally occurs when the (web) server is not configured correctly. Many times it means that there is problem with your .htaccess file. Please check if you need to do any changes to .htaccess file things to work correctly.
Jarrell22
 
Posts: 3
Joined: Fri Nov 18, 2011 2:41 pm

Re: Internal Server Error

Postby Edvard » Mon Nov 21, 2011 3:58 pm

Thanks for the info!

The 500 error is gone now. Please make sure that you have selected a correct main language in gtranslate/config.php file. You need to only select a correct language and it will start to translate. If you have added a Google Translate API key, you need to remove it or pay Google to use it.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Internal Server Error

Postby josept » Mon Nov 21, 2011 5:50 pm

Only part of the site is being translated. Is any form of "force" the translation or knowing how to control it. Becouse some languages are not translating at all or part.
josept
 
Posts: 37
Joined: Fri Nov 04, 2011 8:47 pm

Re: Internal Server Error

Postby josept » Tue Nov 22, 2011 6:54 pm

I remove the google api, like you sai in the post.

now, the site www.clinicaveterinaria.pt/en is online half translated.

How can i fix it, is there any solution?

Thank you
josept
 
Posts: 37
Joined: Fri Nov 04, 2011 8:47 pm

Re: Internal Server Error

Postby Edvard » Tue Nov 22, 2011 11:12 pm

Hi,

If you see a partial translated content you can add force_translation=1 option in the URL like: http://www.clinicaveterinaria.pt/en/?fo ... nslation=1 and it will forcibly translate the content to the end.

You may also modify .htaccess file and replace lang=$1 with lang=$1&force_translation=1
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Internal Server Error

Postby josept » Wed Nov 23, 2011 1:38 am

Thank you very much

it worked.

It´s my second website with Gtranslate pro, and soon i will buy some more licences.

Congratulations for your work
josept
 
Posts: 37
Joined: Fri Nov 04, 2011 8:47 pm

Re: Internal Server Error

Postby Edvard » Wed Nov 23, 2011 5:51 pm

Thanks, good to hear that!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux
cron