Forum Archive - Kunena 1.6.3 and Gtranslate 1.5.23

Kunena 1.6.3 and Gtranslate 1.5.23
Apr 7, 2011 8:51 am by [email protected]
It looks like that Kunena 1.6.3 doesn't work if Gtranslate (onfly) is enabled on the same page. Here are the settings - mtupgrade on - load jquery off in gtranslate (since jquery is already loaded by yootheme template) - analytics off Gtranslate works correctly. Only Kunena stopped working, all javascript related UI elements don't react anymore (e.g. collapsing by clicking in minus symbol etc). Here is the error message: Error: $ is not a function Source File: http://www.yoonique.net/components/com_kunena/js/slimbox/slimbox-min.js Line: 1 You can test this on my site http://www.yoonique.net Kunena uses Mootools 1.2.
Re: Kunena 1.6.3 and Gtranslate 1.5.23
Apr 7, 2011 11:46 am by Edvard
I think you already have unloaded jQuery from GTranslate and now it is OK.
Re: Kunena 1.6.3 and Gtranslate 1.5.23
Apr 7, 2011 2:38 pm by [email protected]
Unfortunately it is not ok. Gtranslate works fine. But Gtranslate breaks Kunena. Please test and see for yourself. (for example click on the minus symbol in the top right corner, nothing happens, but it should collapse).
Re: Kunena 1.6.3 and Gtranslate 1.5.23
Apr 7, 2011 3:59 pm by Edvard
Please write this in Kunena support forum.
Re: Kunena 1.6.3 and Gtranslate 1.5.23
Apr 8, 2011 12:53 am by [email protected]
The answer of the Kunena forum is, that they only use the standard Mootools javascript library that is loaded by Joomla. They do not load any custom libraries. But they pointed out that gtranslate creates the javascript conflict, because when gtranslate is disabled Kunena works again. Could the issue be that gtranslate doesn't run in "noconflict mode"?
Re: Kunena 1.6.3 and Gtranslate 1.5.23
Apr 8, 2011 4:31 pm by Edvard
It runs in no conflict mode. Since the error is in http://www.yoonique.net/components/com_ ... box-min.js file, it need to be sorted out by Kunena.
Re: Kunena 1.6.3 and Gtranslate 1.5.23
Apr 9, 2011 2:44 am by [email protected]
I removed all your coding from the module except for the addscript part, and the conflict is still there. Which basically means jquery-translate.js and slimbox.js are not compatible ...
Re: Kunena 1.6.3 and Gtranslate 1.5.23
Apr 9, 2011 5:07 am by [email protected]
Ok, I debugged a bit and noticed that you actually modified the the translate library. I deleted the noconflict line and now everything works. Please fix this bug, since you don't need this line, if the library is loaded by another extension in noconflict mode, right?
Re: Kunena 1.6.3 and Gtranslate 1.5.23
Apr 11, 2011 3:59 pm by Edvard
So jQuery.noconflict() in the jquery-translate.js was removed and it worked?
Re: Kunena 1.6.3 and Gtranslate 1.5.23
Apr 11, 2011 10:58 pm by testk[email protected]
Correct

SIMILAR TOPICS

Gtranslate MultisiteFeb 12, 2019 7:27 amReplies: 1Post by: infact_dat
Gtranslate: Error with numberFeb 20, 2019 1:20 amReplies: 1Post by: infact_dat
GTranslate 3.7.4, Joomla 3.9.3 - doGTranslate is not definedFeb 22, 2019 12:34 pmReplies: 1Post by: oase
Add-on gtranslate no longer worksFeb 2, 2019 6:01 amReplies: 1Post by: DarylDixon
Instragram and Gtranslate...!!!!Dec 19, 2018 11:18 amReplies: 1Post by: zackfernandes

Try GTranslate with a free 15 day trial