Forum Archive - PHP Error in translate.php line 153

PHP Error in translate.php line 153
Feb 20, 2013 7:09 pm by mjbradley85
I am repeatedly getting the following PHP error inside my logs since activating GTranslate Pro. PHP Notice: Undefined index: HTTP_COOKIE in C:\xxx\xxx\gtranslate\translate.php on line 153 But line 153 of that php document is illegible so I'm not sure what the problem may be. I am running IIS7 and the translations do work. But I really need to prevent the error from clogging up my system. Is there a setting I need to adjust or verify? I saw mentioned elsewhere this may be a cookie problem. But could you please be more specific? I have my own VPS and can make any changes if you please let me know what causes this problem. Thanks for your support. Server: IIS 7.5 CMS: Wordpress PHP: 5.3 mbradley at
Re: PHP Error in translate.php line 153
Feb 21, 2013 6:56 am by Yana
Hi, Please check the following variables: $_SERVER["SERVER_PROTOCOL"], $_SERVER["HTTP_COOKIE"] . They should be defined and accessible.
Re: PHP Error in translate.php line 153
Feb 21, 2013 4:45 pm by mjbradley85
Thanks for the reply, but I need a little more information. Where do they need to be defined and accessible? Inside my php.ini or one of my WP config/settings files? Is there a setting or documentation you can point me to? Thanks for your patience. -Matt
Re: PHP Error in translate.php line 153
Feb 22, 2013 1:33 pm by Yana
Hi, You should check it with your hosting provider.
Re: PHP Error in translate.php line 153
Feb 25, 2013 7:11 pm by mjbradley85
Yana, we paid $100+ to purchase the premium version of your plugin. I would really appreciate you could provide some support for this issue. Please help us by sharing where we can locate and define the $_SERVER["SERVER_PROTOCOL"] and $_SERVER["HTTP_COOKIE"] variables. If you provide some documentation, we can likely fix this ourselves. But currently, the plugin is unusable.
Re: PHP Error in translate.php line 153
Feb 26, 2013 10:50 am by Yana
Hi, By default your php error reporting should be set to E_ALL & ~E_NOTICE, which doesn't log notices, probably you have E_ALL .


Gtranslate: Error with numberFeb 20, 2019 1:20 amReplies: 1Post by: infact_dat
Error message and URL problemsFeb 6, 2019 11:16 amReplies: 1Post by: Kidbooo
wordpress amp link not translateDec 31, 2016 10:11 amReplies: 12Post by: besybuy
GT doesn't work...error 404 pageJan 28, 2019 5:36 pmReplies: 1Post by: vincenzodinuzzo
Translate website to any specific language, on page loadJan 19, 2019 6:49 amReplies: 1Post by: Leaon7756

Try GTranslate with a free 15 day trial