Please update to PHP 5.3 or higher standard

Popular automatic website translation tool

Please update to PHP 5.3 or higher standard

Postby globus999 » Tue Dec 31, 2013 8:58 pm

Hi,
As you may know, Joomla is rapidly becoming PHP 5.3 or higher only... leaning towards 5.5.
As it stands right now, most devs of independent plugins/modules don't care much about this issue, but it will become critical soon. For now, most "Strict" errors can be masked but not avoided... for now.

For example, in you latest version of the free implementation, I keep getting the same error:

Only variables should be assigned by reference in /home/freedoma/public_html/s1/j1/modules/mod_gtranslate/tmpl/default.php on line 130
[31-Dec-2013 05:35:09

Tx!
globus999
 
Posts: 2
Joined: Wed Apr 24, 2013 9:39 pm

Re: Please update to PHP 5.3 or higher standard

Postby Edvard » Tue Dec 31, 2013 9:00 pm

Thank you! We will fix the issue in the next version.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Please update to PHP 5.3 or higher standard

Postby sju10544 » Sun Jan 19, 2014 3:19 pm

Hi Edvard,

fighting with the same issues after installing GTranslate on a new server with PHP 5.4, Debian Wheezy (Joomla 2.5.17) after moving my site:

Strict Standards: Only variables should be assigned by reference in /var/www/vhosts/florida-scout.com/htdocs/plugins/system/gtranslate/gtranslate.php on line 90

I know this is "only" a warning and no error, but I'd like to know if there is a newer version (I'm using version Plugin $Rev: 50 $ December 2010 and Modul 3.0.x.32 September 2010) in the "Pro" version right now?

The warnings disappear when error_reporting = E_ERROR | E_CORE_ERROR | E_COMPILE_ERROR, but IMHO a version without having php-warnings would be the better alternative ;-).

Thanks

Jens
sju10544
 
Posts: 5
Joined: Sat Jul 28, 2012 9:19 pm

Re: Please update to PHP 5.3 or higher standard

Postby sju10544 » Wed Jan 22, 2014 4:51 pm

No response?
sju10544
 
Posts: 5
Joined: Sat Jul 28, 2012 9:19 pm

Re: Please update to PHP 5.3 or higher standard

Postby Yana » Wed Jan 22, 2014 6:42 pm

Hi,
Please check the following post
post14332.html?hilit=helper#p14332
Hope this will help you.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4140
Joined: Thu Jan 12, 2012 6:21 pm

Re: Please update to PHP 5.3 or higher standard

Postby sju10544 » Thu Jan 23, 2014 6:02 pm

Hi Yana,

have made all the suggested changes (especially eleminate the & in the default.php). Seems to work, but the "Strict Standards" are only disappear when you "hide" the warnings due to the error-level setting. Seems to be a "normal" behaviour for PHP 5.4.x versions... not sure.

Regards

Jens
sju10544
 
Posts: 5
Joined: Sat Jul 28, 2012 9:19 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux