Problems with JoomSEF after upgrade of Gtranslate

Popular automatic website translation tool

Problems with JoomSEF after upgrade of Gtranslate

Postby Nirmalanow » Wed Mar 23, 2011 8:43 am

Hi Edvard,

As you know, I just updated to the latest version of Gtranslate.

Now I am having problems with my JoomSEF plugin. A bunch of the SEF friendly urls on my site are not working anymore, and when JoomSEF creates a new SEF url, it does not collect the correct real url from my site, so even the newly created SEF urls are not showing up on my site.

I tried uninstalling gtranslate but this did not fix the problem. Is there something that is changed when I installed Gtranslate that could affect JoomSEF? Or is there something about the htaccess file that might be interfering with the operation of JoomSEF?

Specifically, does Gtranslate change the way the real urls are created in my site? The urls that are displaying now do not appear the same as before and so JoomSEF does not recognise them.

For example the following page should have the sef url of endless-satsang.com/advaita-nonduality-oneness.htm but instead it shows up with the url:
endless-satsang.com/index.php?option=com...p;id=64&catid=11

In the JoomSEF URL Manager it lists the real url as:
index.php?option=com_content&catid=11&id=64&view=article&Itemid=6
which is slightly different.

Any of these urls will bring you to the same page, including the sef url.

I also noticed that many of my internal links are now showing the real url. The weird part is that some of the internal links still have the SEF url working. For examples, you can hover the mouse over the various links on my home page. Some of them show up as SEF urls and some of them show up as the non-SEF urls. All of the main menu items still show up as SEF urls. And there are pages that are linked to with SEF urls on my home page that open up with the SEF url when you follow that link. but if you follow a different link on the site to the same page it will show up with a non-SEF url.

Any clues why this is happening?
Nirmalanow
 
Posts: 28
Joined: Sun Jan 02, 2011 8:34 am

Re: Problems with JoomSEF after upgrade of Gtranslate

Postby Nirmalanow » Wed Mar 23, 2011 8:44 am

Here is my current htaccess file in case that helps:

##
# @version $Id: htaccess.txt 9975 2008-01-30 17:02:11Z ircmaxell $
# @package Joomla
# @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


#####################################################
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

## Can be commented out if causes errors, see notes above.
# Options +FollowSymLinks

#
# mod_rewrite in use

RewriteEngine On

# gtranslate config
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/images/stories/pdfs/(.*)$ /images/stories/pdfs/$2 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA]

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

# RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section


########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits
Nirmalanow
 
Posts: 28
Joined: Sun Jan 02, 2011 8:34 am

Re: Problems with JoomSEF after upgrade of Gtranslate

Postby Edvard » Wed Mar 23, 2011 9:25 pm

It is not related to GTranslate.

You can check if you have SEF URLs and Apache mod_rewrite on in global configuration, also make sure the plugin is enabled.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux