Problems With Menu Items and Random 500 Error

Popular automatic website translation tool

Problems With Menu Items and Random 500 Error

Postby PolishedGeek » Fri Dec 02, 2016 3:13 am

Hi,

I have the tool mostly setup and working. It's looking pretty good so far, but I have two problems that maybe you can help with:

One issue involves the menu items not having the "/es/" for Spanish when you click on them. When I inspect the menu items, I see this:

Code: Select all
<li class="mainParentBtn mainMenuParentBtn">
      <span class="s5_level1_span1">
         <span class="s5_level1_span2">
               <a href="/custom-systems">
                   <span onclick="window.document.location.href="/es/custom-systems"">Sistemas</span>
               </a>
               <span class="S5_parent_subtext" onclick="window.document.location.href="/es/custom-systems"">ESG personalizada</span></span></span></li>


So the link should be changing, and it is for the onclick, but not on the href for the a tags. It works just fine for any other link on the site. I saw mention of an "On the Fly" setting in some of the other threads, but I don't see a setting like that in my configuration.

The other problem I have is that I will randomly get the 500 error that suggests the service is being blocked? But I'm not seeing anything in the logs, and I whitelisted the IP address in both the WAF and on the server. So I'm a little confused. Maybe you're seeing something on your end.

You can look the behavior here: http://guardianfall.com/es/

Thanks in advance!

Milton
PolishedGeek
 
Posts: 8
Joined: Sat Nov 26, 2016 6:05 pm
Location: NC, USA & Antigua, Guatemala

Re: Problems With Menu Items and Random 500 Error

Postby Yana » Fri Dec 02, 2016 4:40 pm

Hi,

Please change the links to relative to solve the problem. for example
/custom-systems/custom-fall-protection-systems/custom-anchor-point-systems
should be
./custom-systems/custom-fall-protection-systems/custom-anchor-point-systems

I checked the translated versions and was able to see the pages without errors. Please make sure that your website first request response time. It should be less than 5 sec. You can use https://tools.pingdom.com/ to check it.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4350
Joined: Thu Jan 12, 2012 6:21 pm

Re: Problems With Menu Items and Random 500 Error

Postby PolishedGeek » Fri Dec 02, 2016 11:41 pm

Hi Yana,

Thanks for getting back to me. Unfortunately, these links are not hard-coded (I've actually been working with my client to change all of their links to relative links), so there isn't really anywhere I can "change" the links, they're being generated by the template directly. It's the Shape 5 No1 Shopping template. Are you familiar with that? If you don't have any other suggestions, then I'll start considering trying to move them to the standard Joomla menu module.

Thanks for clarifying. We have some work going to optimize the site. So if I can get it optimized and reduce the page load, the problem should stop? I am seeing that the TTFB is extremely long, but only when I try to go to /es/. I wanted to double-check and make sure we weren't somehow blocking the service on our side.

I'll update if I have anymore questions.

Regards,
Milton
PolishedGeek
 
Posts: 8
Joined: Sat Nov 26, 2016 6:05 pm
Location: NC, USA & Antigua, Guatemala

Re: Problems With Menu Items and Random 500 Error

Postby Edvard » Sun Dec 04, 2016 11:06 am

Hi,

If you provide FTP access we can look into your menu extension and try to fix it.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4349
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Problems With Menu Items and Random 500 Error

Postby PolishedGeek » Mon Dec 05, 2016 9:53 am

Hi Edvard,

No problem. How do you want me to send it? It looks like you don't have PM's enabled.
PolishedGeek
 
Posts: 8
Joined: Sat Nov 26, 2016 6:05 pm
Location: NC, USA & Antigua, Guatemala

Re: Problems With Menu Items and Random 500 Error

Postby Yana » Mon Dec 05, 2016 7:16 pm

Hi,
You can send by email to yana@gtranslate.net.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4350
Joined: Thu Jan 12, 2012 6:21 pm

Re: Problems With Menu Items and Random 500 Error

Postby PolishedGeek » Sat Dec 10, 2016 10:09 pm

Hi,

I'm just checking in to see if you've been getting my email. I'm happy to help if you need anything while troubleshooting, but I haven't heard anything in a couple of days so I wanted to eliminate the possibility that my email hasn't been reaching you. Hope you're enjoying the weekend!

Regards,
Milton
PolishedGeek
 
Posts: 8
Joined: Sat Nov 26, 2016 6:05 pm
Location: NC, USA & Antigua, Guatemala


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest

2GLux
cron