GTranslate for alt= of images attributes not working

Popular automatic website translation tool

GTranslate for alt= of images attributes not working

Postby isa » Wed Jul 02, 2014 6:08 pm

Hello,

How to translate image attributes?
isa
 
Posts: 42
Joined: Tue Sep 17, 2013 6:15 pm

Re: GTranslate for alt= of images attributes not working

Postby Edvard » Thu Jul 03, 2014 2:46 pm

Hi,

Which version of GTranslate are you using?

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate for alt= of images attributes not working

Postby isa » Thu Jul 03, 2014 5:50 pm

its Enterprise
isa
 
Posts: 42
Joined: Tue Sep 17, 2013 6:15 pm

Re: GTranslate for alt= of images attributes not working

Postby isa » Fri Jul 04, 2014 11:11 pm

any help???
isa
 
Posts: 42
Joined: Tue Sep 17, 2013 6:15 pm

Re: GTranslate for alt= of images attributes not working

Postby Yana » Sat Jul 05, 2014 2:37 pm

Hi,

GTranslate Enterprise version translates alt attribute. If you have a problem with the translation please post your website address, so I can check it and assist you.

Thanks!
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: GTranslate for alt= of images attributes not working

Postby isa » Mon Jul 07, 2014 5:14 pm

I send it, via PM
isa
 
Posts: 42
Joined: Tue Sep 17, 2013 6:15 pm

Re: GTranslate for alt= of images attributes not working

Postby isa » Tue Jul 08, 2014 9:04 pm

Results
GTranlate Enterprise not compatible with image attributes, since not supported
isa
 
Posts: 42
Joined: Tue Sep 17, 2013 6:15 pm

Re: GTranslate for alt= of images attributes not working

Postby Yana » Tue Jul 08, 2014 9:11 pm

Hi,
Please try to change alt attribute ti title and it will be translated.
Thanks!
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: GTranslate for alt= of images attributes not working

Postby isa » Tue Jul 08, 2014 9:17 pm

I can't change alt attribute to title since we need them for SEO
we need alt attribute
isa
 
Posts: 42
Joined: Tue Sep 17, 2013 6:15 pm

Re: GTranslate for alt= of images attributes not working

Postby isa » Tue Jul 08, 2014 9:32 pm

Yana wrote:Hi,

GTranslate Enterprise version translates alt attribute. If you have a problem with the translation please post your website address, so I can check it and assist you.

Thanks!


What do you mean by this?
isa
 
Posts: 42
Joined: Tue Sep 17, 2013 6:15 pm

Re: GTranslate for alt= of images attributes not working

Postby Edvard » Wed Jul 09, 2014 7:53 am

Hi,

Sorry, we made a mistake, we do not translate the alt attribute, but the title attribute of the image. So if you care about SEO I would suggest to add another title attribute with the same content as alt.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate for alt= of images attributes not working

Postby isa » Wed Jul 09, 2014 9:34 pm

Here's the problem if you search some relevant keyword in english
google search results showing like this :
Title [English]
http://en.mysite.com (Gtrasnlate Enterprise)
but snippet showing : <img src="http://mysite/logo.gif" alt="My Site Arabian" title="My Site English" >

its getting text from logo alt atribute in Arabic language mysite.com Arabian instead correct en.mysite.com English version
that's showing incorrect search results
it's a huge problem, since google not index title attribute for images its index only alt attributes

With image search, just as with web search, Google's goal is to provide the best and most relevant search results to users. Following the best practices will increase the likelihood that images will be returned in those search results.
Here's more about Image publishing guidelines by Google
https://support.google.com/webmasters/a ... 4016?hl=en
isa
 
Posts: 42
Joined: Tue Sep 17, 2013 6:15 pm

Re: GTranslate for alt= of images attributes not working

Postby Edvard » Thu Jul 10, 2014 7:25 pm

Hi,

That's why I'm suggesting to add title attribute. It is not correct that Google doesn't index title attribute for images.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate for alt= of images attributes not working

Postby isa » Thu Jul 10, 2014 8:03 pm

please provide example code ? how it should work?
isa
 
Posts: 42
Joined: Tue Sep 17, 2013 6:15 pm

Re: GTranslate for alt= of images attributes not working

Postby Edvard » Thu Jul 10, 2014 8:04 pm

Hi,

Here is an example: <img src="..." alt="some text" title="some text" />.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate for alt= of images attributes not working

Postby isa » Thu Jul 10, 2014 8:07 pm

Actually I have the same :|

<img src="..." alt="some text not translated" title="some text translated" />.
google showing this in search results alt="some text not translated"
isa
 
Posts: 42
Joined: Tue Sep 17, 2013 6:15 pm

Re: GTranslate for alt= of images attributes not working

Postby Edvard » Thu Jul 10, 2014 8:22 pm

Have you added the title recently?
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate for alt= of images attributes not working

Postby isa » Thu Jul 10, 2014 8:23 pm

yes, I Have added it recently
isa
 
Posts: 42
Joined: Tue Sep 17, 2013 6:15 pm

Re: GTranslate for alt= of images attributes not working

Postby Edvard » Thu Jul 10, 2014 9:51 pm

It will take time, so Google can index and make changes.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate for alt= of images attributes not working

Postby Terafim » Tue Jul 29, 2014 9:58 am

I always check my alt attributes manually. I like to make sure :D
Terafim
 
Posts: 1
Joined: Tue Jul 29, 2014 9:54 am


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest

2GLux
cron