Translation only works from flags

Popular automatic website translation tool

Translation only works from flags

Postby dapercas » Mon May 04, 2015 10:50 pm

I am an administrator of a website where I have been asked to install GTranslate.

Most of the contents are in Spanish, and only a small percentage are in Catalan.

However, they have asked me the site is displayed by default in Catalan.

Well, if I set GTranslate for the site to be displayed in Catalan, by default, through the "Site Language" parameter, the website still appears in its original language.

However, when I click on one of the flags the translation works perfectly.

What could be happening?

Thank you very much
Posts: 1
Joined: Mon May 04, 2015 9:39 pm

Re: Translation only works from flags

Postby Yana » Tue May 05, 2015 5:37 pm


Can you post your website address? GTranslate doesn't change the original language . If you set the default language to Catalan and open your website it will not change the language. "Site Language" is the source language.
If you have mixed languages content and want to see the translated version isntead of the original, you can use gtranslate Enterprise version. In this case you can host your original website on some domain (for example: and we will host Catalan to the original domain (

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Posts: 4088
Joined: Thu Jan 12, 2012 6:21 pm

  • Related Topics
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests