You don't have appropriate license...

Popular automatic website translation tool

You don't have appropriate license...

Postby natastna2 » Wed Oct 26, 2011 4:32 pm

Hi, I bought Gtranslate Pro for my domain www.smellstoppers.com. I'm using the cached Pro version for most of the pages and for the cart pages I'm using the free on-the-fly version. I keep on hitting the error message: You don't have appropriate license for your www.smellstoppers.com. Please purchase GTranslate Pro license or go back. I have Gtranslate Pro working on another site without these error messages and am not sure what I am doing wrong. Any help would be appreciated.

Regards,
Anthony.
natastna2
 
Posts: 149
Joined: Wed Jan 26, 2011 2:43 am

Re: You don't have appropriate license...

Postby Edvard » Wed Oct 26, 2011 4:53 pm

I cannot experience that error on your site.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: You don't have appropriate license...

Postby natastna2 » Wed Oct 26, 2011 4:59 pm

Hello Edvard, to encounter the error please follow these steps:

go to www.smellstoppers.com and cilck on the japanese flag, then add a product to your cart and you will be redirected back to the English language cart, then when in the cart click on the japanese flag to activate the on-the-fly translation and then click on checkout and the error should appear.
natastna2
 
Posts: 149
Joined: Wed Jan 26, 2011 2:43 am

Re: You don't have appropriate license...

Postby natastna2 » Wed Oct 26, 2011 5:30 pm

You can cause the error simply by visiting the cart and using the flags and then checking out, it doesn't have to be Japanese, it can be anything. I have this method working on another site I've bought Gtranslate Pro for, www.seed-city.com. I'm not sure why it would work on seed-city but not on SmellStoppers.
natastna2
 
Posts: 149
Joined: Wed Jan 26, 2011 2:43 am

Re: You don't have appropriate license...

Postby Edvard » Wed Oct 26, 2011 11:24 pm

When I go to http://www.smellstoppers.com/ja/cart it redirects me to http://www.smellstoppers.com/cart?lang=ja&url=cart .

Why that happens? Did you set a special rewrite rule?
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: You don't have appropriate license...

Postby natastna2 » Thu Oct 27, 2011 1:51 am

Hello Edvard, I just sent you an email in response. Yes, I've set up a load of htaccess rewrites as this is what I had to do previously to avoid any errors. I appreciate that things may have changed but I always hit a blank page when checking out if I'm in a language cart like ja/cart. Hence the rewrites. I emailed you my admin username and pass and will now email you my FTP details if you would be so kind as to take a look. I very much like the idea of not having to do these rewrites and having different languages being able to checkout in their own language areas.
natastna2
 
Posts: 149
Joined: Wed Jan 26, 2011 2:43 am

Re: You don't have appropriate license...

Postby natastna2 » Thu Oct 27, 2011 5:26 pm

Hello Edvard, I will leave it with the problems so you can see what is wrong. If you could please take a look at some point soon I would be grateful. I have emailed you all of my details. Thank you for your time.

Regards,
Anthony.
natastna2
 
Posts: 149
Joined: Wed Jan 26, 2011 2:43 am

Re: You don't have appropriate license...

Postby Edvard » Thu Oct 27, 2011 7:06 pm

OK, I'll look into and let you know.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: You don't have appropriate license...

Postby natastna2 » Thu Oct 27, 2011 8:42 pm

Thanks Edvard, please feel free to remove the htaccess redirects I've created if it helps to diagnose the problem. I guess if I removed the redirects and just went with the Joomla version my only problem would be the blank screen on checkout.
natastna2
 
Posts: 149
Joined: Wed Jan 26, 2011 2:43 am

Re: You don't have appropriate license...

Postby natastna2 » Sun Oct 30, 2011 4:08 pm

Hi Edvard, sorry to pester you but I was hoping you might have some more information as to the problem?
natastna2
 
Posts: 149
Joined: Wed Jan 26, 2011 2:43 am

Re: You don't have appropriate license...

Postby natastna2 » Mon Oct 31, 2011 3:12 am

Hello, I have removed the htaccess redirects and attempted again just to use the Joomla 1.5 version. If I remove all the htaccess redirects I just get a 404 page not found error on all pages. I have no idea how the Joomla 1.5 version is meant to work, the readme makes it sound like the only steps you have to follow are:
installing the plg_translate.zip and enabling the plugin but that just results in 404 page not found errors. I then followed the instructions in the other readme for other sites and it worked but I get blank pages on checkout. If you could please just help me to install the Joomla 1.5 version and get it working then maybe that would solve the problem.
natastna2
 
Posts: 149
Joined: Wed Jan 26, 2011 2:43 am

Re: You don't have appropriate license...

Postby Edvard » Mon Oct 31, 2011 5:45 pm

Do you have some SEF plugin other than the default one?

If you can give temporary admin access we can look into for you.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: You don't have appropriate license...

Postby natastna2 » Mon Oct 31, 2011 5:51 pm

Yes, I am using Artio Joomsef. But I am also using it on the site that works. I have emailed you my admin username and password and FTP details a few days ago. Please let me know if you cannot find them and I will email them again.
natastna2
 
Posts: 149
Joined: Wed Jan 26, 2011 2:43 am

Re: You don't have appropriate license...

Postby Edvard » Mon Oct 31, 2011 5:55 pm

Please use PM button under my name to send the access info.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: You don't have appropriate license...

Postby natastna2 » Mon Oct 31, 2011 6:00 pm

OK, I've PMed you all the relevant information. Thanks.
natastna2
 
Posts: 149
Joined: Wed Jan 26, 2011 2:43 am

Re: You don't have appropriate license...

Postby natastna2 » Tue Nov 01, 2011 6:43 pm

Hello Edvard,

Have you got all the information you require now?

Regards,
Anthony.
natastna2
 
Posts: 149
Joined: Wed Jan 26, 2011 2:43 am

Re: You don't have appropriate license...

Postby Edvard » Wed Nov 02, 2011 2:11 am

Hi,

Please check and let me know. It is OK now.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: You don't have appropriate license...

Postby natastna2 » Wed Nov 02, 2011 2:32 am

Hi Edvard,

Thanks for your time. It does seem to work now. My only worry is that say if you are on the homepage and you click on a language flag you are taken to www.mysite.com/de which is good but if you click on any of the article links at the top of the page, the nose image, the Stop sign or the Smell stopper bags picture you are taken not to www.mysite.com/de/article but www.mysite.com/article. It is the same thing if you are on the front page and click on a language flag then click on the first category picture on the front page, the big one that has The Smell Stopper bag in the bottom left, it takes you correctly to http://www.smellstoppers.com/de/smell-p ... topper-bag

However, click on the next picture along from the homepage and it takes you to:
http://www.smellstoppers.com/heat-seal-bags

Could you please tell me why one of them works properly and one doesn't? Is the difference the link itself or do you think it could be the cached SEF links? Once I've fixed this problem I will be very happy :-)
natastna2
 
Posts: 149
Joined: Wed Jan 26, 2011 2:43 am

Re: You don't have appropriate license...

Postby natastna2 » Wed Nov 02, 2011 2:37 am

There's also still a problem in that no foreign language users can complete the checkout. If they attempt to checkout on the second stage of the checkout they are redirected back to the cart which then says your cart is empty. You can see the problem by checking out, you can use the username tester and password cheese to save time in creating an account. Regards, Anthony.
natastna2
 
Posts: 149
Joined: Wed Jan 26, 2011 2:43 am

Re: You don't have appropriate license...

Postby natastna2 » Wed Nov 02, 2011 6:00 pm

Hi Edvard,

I also get a 500 Internal Server Error when checking out in a foreign language on the first step when I am using Google Chrome, Firefox gets to the second stage and then reverts back to an empty cart.
natastna2
 
Posts: 149
Joined: Wed Jan 26, 2011 2:43 am

Next

  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest

2GLux