Forum Archive - 404 error with gtranslate pro

404 error with gtranslate pro
Aug 11, 2011 4:51 pm by e.ke[email protected]
Hello, i have a problem with gtranslate pro, you can check it on my website : http://www.all-casino-bonus.com When i want to traduct a page i have a 404 error message. My htaccess looks good, gtranslate folder are on root and i think i get mod-rewrite on apache. So please can you help me ! I don't know what to do. Thnaks, best regads
Re: 404 error with gtranslate pro
Aug 11, 2011 6:48 pm by [email protected]
IonCube is loaded OK This is my htaccess Please, help me, thanks, best regards. ## # @version $Id: htaccess.txt 14401 2010-01-26 14:10:00Z louis $ # @package Joomla # @copyright Copyright (C) 2005 - 2010 Open Source Matters. All rights reserved. # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL # Joomla! is Free Software ## ##################################################### # READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE # # The line just below this section: 'Options +FollowSymLinks' may cause problems # with some server configurations. It is required for use of mod_rewrite, but may already # be set by your server administrator in a way that dissallows changing it in # your .htaccess file. If using it causes your server to error out, comment it out (add # to # beginning of line), reload your site in your browser and test your sef url's. If they work, # it has been set by your server administrator and you do not need it set here. # ##################################################### ## Can be commented out if causes errors, see notes above. Options +FollowSymLinks # # mod_rewrite in use RewriteEngine On # gtranslate config RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L] RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L] RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA] ########## Begin - Rewrite rules to block out some common exploits ## If you experience problems on your site block out the operations listed below ## This attempts to block the most common type of exploit `attempts` to Joomla! # ## Deny access to extension xml files (uncomment out to activate) #<Files ~ "\.xml$"> #Order allow,deny #Deny from all #Satisfy all #</Files> ## End of deny access to extension xml files RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR] # Block out any script trying to base64_encode crap to send via URL RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR] # Block out any script that includes a <script> tag in URL RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR] # Block out any script trying to set a PHP GLOBALS variable via URL RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR] # Block out any script trying to modify a _REQUEST variable via URL RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2}) # Send all blocked request to homepage with 403 Forbidden error! RewriteRule ^(.*)$ index.php [F,L] # ########## End - Rewrite rules to block out some common exploits # Uncomment following line if your webserver's URL # is not directly related to physical file paths. # Update Your Joomla! Directory (just / for root) # RewriteBase / ########## Begin - Joomla! core SEF Section # RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_URI} !^/index.php RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC] RewriteRule (.*) index.php RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L] # ########## End - Joomla! core SEF Section
Re: 404 error with gtranslate pro
Aug 12, 2011 9:15 am by [email protected]
I just purchased the pro version and I have exactly the same problem. I have ioncube and curl on my server. I have mod_rewrite in apache active I put the lines in the .htaccess RewriteEngine On and after can be seen. The .htaccess is in the directory "public_html". GTranslate directory inside the folder "public_html". -------------------------------- .htaccess ------------------------------------------------------ ## # @version $Id: htaccess.txt 9975 2008-01-30 17:02:11Z ircmaxell $ # @package Joomla # @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved. # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL # Joomla! is Free Software ## ##################################################### # READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE # # The line just below this section: 'Options +FollowSymLinks' may cause problems # with some server configurations. It is required for use of mod_rewrite, but may already # be set by your server administrator in a way that dissallows changing it in # your .htaccess file. If using it causes your server to error out, comment it out (add # to # beginning of line), reload your site in your browser and test your sef url's. If they work, # it has been set by your server administrator and you do not need it set here. # ##################################################### ## Can be commented out if causes errors, see notes above. Options +FollowSymLinks # # mod_rewrite in use RewriteEngine On # gtranslate config RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L] RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L] RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA] RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA] # Uncomment following line if your webserver's URL # is not directly related to physical file paths. # Update Your Joomla! Directory (just / for root) RewriteBase /
Re: 404 error with gtranslate pro
Aug 12, 2011 10:46 am by [email protected]
Hello, Is solved, the problem is that the .htaccess and directory gTranslate must be within public_html \ midominio.es and not directly into public_html. It would be nice some image in the installation instructions. Especially for Dummies like me. Greetings.
Re: 404 error with gtranslate pro
Aug 12, 2011 10:51 am by [email protected]
Nothing change for me. I had placed .htaccess in public_html folder like gtranslate directory. Gtranslate was working until 302 error ... i had so to install updates. and now, 404 error. (gtranslate worked perfectly before)
Re: 404 error with gtranslate pro
Aug 12, 2011 10:37 pm by Edvard
Hi, Please check the troubleshooting: gtranslate/troubleshooting-gtranslate-pro-t368.html
Re: 404 error with gtranslate pro
Aug 13, 2011 2:09 pm by [email protected]
Hello, thanks for your reply. I've already check your pages 10 times minium and check all i can. All loking's good. Please help me, best regards.
Re: 404 error with gtranslate pro
Aug 14, 2011 6:19 pm by [email protected]
The problem can become about server transfer ? please help me
Re: 404 error with gtranslate pro
Aug 17, 2011 10:09 am by Edvard
Hi, You need to put gtranslate files into your www root directory (public_html). When you access http://domain.com/gtranslate/translate.php?lang=es you should see Spanish version if you have configured it correctly in config.php. If that works, but you still see 404 error when you go to http://domain.com/es/ then you have a mistake with your .htaccess, please check that with your hosting provider.

SIMILAR TOPICS

Gtranslate MultisiteFeb 12, 2019 7:27 amReplies: 1Post by: infact_dat
Gtranslate: Error with numberFeb 20, 2019 1:20 amReplies: 1Post by: infact_dat
GTranslate 3.7.4, Joomla 3.9.3 - doGTranslate is not definedFeb 22, 2019 12:34 pmReplies: 1Post by: oase
Error message and URL problemsFeb 6, 2019 11:16 amReplies: 1Post by: Kidbooo
Add-on gtranslate no longer worksFeb 2, 2019 6:01 amReplies: 1Post by: DarylDixon

Try GTranslate with a free 15 day trial