404 on GTranslate Pro unresolved by "Troubleshouting"

Popular automatic website translation tool

404 on GTranslate Pro unresolved by "Troubleshouting"

Postby orani » Sun Apr 10, 2011 6:28 pm

Hello,

I am in this case: gtranslate/troubleshooting-gtranslate-pro-t368.html#3

But i can't find why it does not work

Thanx for your help
cf. : http://www.aleph-news.net/wp-content/plugins/gtranslate/
Last edited by orani on Mon Apr 11, 2011 1:50 pm, edited 4 times in total.
orani
 
Posts: 11
Joined: Sun Apr 10, 2011 6:25 pm

[FAQ] 404 on GTranslate Pro

Postby orani » Mon Apr 11, 2011 12:45 pm

3. When I select a language I'm being redirected to a URL with the language code, but it gives 404 not found error.
- Make sure that you have uploaded gtranslate folder to your www root folder.


gtranslate forlder is in
Code: Select all
/var/www/html/wp-content/plugins
it contains
Code: Select all
licence.dat


- Make sure that you have .htaccess file and have placed # gtranslate config block to the next line of RewriteEngine On line in it.


Code: Select all
RewriteEngine On
# gtranslate config
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA]


in
Code: Select all
/var/www/html/
/var/html/wp-content/
/var/html/wp-content/plugins

and
Code: Select all
/var/html/wp-content/plugins/gtranslate



- Make sure that you have Apache mod_rewrite or an alternative installed on your server (check with your hosting provider).


Code: Select all
LoadModule proxy_module modules/mod_proxy.so
in my
Code: Select all
/etc/httpd/conf/httpd.conf
file



Could you help ?
The site is http://www.aleph-news.net
orani
 
Posts: 11
Joined: Sun Apr 10, 2011 6:25 pm

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby Edvard » Mon Apr 11, 2011 8:05 pm

gtranslate folder should be uploaded into your www-root folder, in your case it is /var/www/html.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby orani » Tue Apr 12, 2011 5:27 pm

Hello,

Modification done, i have re-install gtranslate pro ine the document root /var/www/html
and installed gtranslate free in the plugin directory; Nothing looks better.

An idea ?
Thanx
ps: where could i find some logs to help ?
orani
 
Posts: 11
Joined: Sun Apr 10, 2011 6:25 pm

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby Edvard » Wed Apr 13, 2011 12:58 pm

Can you post the contents of /var/www/html/.htaccess file?
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby orani » Wed Apr 13, 2011 1:38 pm

Sure,

Code: Select all
RewriteEngine On
# gtranslate config
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA]


Thanx for your help

ps: here the link to phpinfo, http://www.aleph-news.net/gtranslate/info.php
orani
 
Posts: 11
Joined: Sun Apr 10, 2011 6:25 pm

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby Edvard » Wed Apr 13, 2011 3:31 pm

You don't have JSON library installed. You need to upgrade PHP to version 5.2 or install JSON.

But that will not solve the 404 error. I'm not sure that it is your .htaccess please check dot prefix. Also there should be some other RewriteRules for your wordpress.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby orani » Wed Apr 13, 2011 4:19 pm

/etc/httpd/conf/httpd.conf was with
AllowOverride None
changing to All and its ok (blank page now)

Thanx for your help

May be add this in Troubleshouts
orani
 
Posts: 11
Joined: Sun Apr 10, 2011 6:25 pm

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby Edvard » Wed Apr 13, 2011 4:23 pm

Good, now you need to install the missing JSON library or upgrade the PHP.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

GTranslate Pro only one langage !?

Postby orani » Wed Apr 13, 2011 4:42 pm

Not so bad :-)

I am in 4.2 now, but i have still a error,

It looks working only for arab langage !?

example: http://www.aleph-news.net/?p=6102 (source fr)
http://www.aleph-news.net/en/?p=6102 (ko)
http://www.aleph-news.net/ar/?p=6102 (ok)

Thanx
Last edited by orani on Wed Apr 13, 2011 5:39 pm, edited 2 times in total.
orani
 
Posts: 11
Joined: Sun Apr 10, 2011 6:25 pm

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby Edvard » Wed Apr 13, 2011 4:44 pm

You have forced it to be compiled with --disable-json.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby orani » Thu Apr 14, 2011 5:24 pm

Hello,

This is a precompiled version. The
Code: Select all
--disable-json
compilation directive is only to not embeded de librairy. json is well integrated as loadable module (cf. http://www.aleph-news.net/gtranslate/info.php)

As a proof, the
Code: Select all
--without-mysql
is present too.

... :-(

Test the site, you gonna see some strange stuff, only menu is translated !
http://www.aleph-news.net
orani
 
Posts: 11
Joined: Sun Apr 10, 2011 6:25 pm

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby Edvard » Thu Apr 14, 2011 5:32 pm

Not sure what you did, but now it is OK. Currently you have your API key daily limit exceeded. I already can see some parts of the page are translated into English: http://www.aleph-news.net/en/

BTW. Upgrade to v3.1415.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby orani » Thu Apr 14, 2011 5:56 pm

Thanx a lots for your help !
orani
 
Posts: 11
Joined: Sun Apr 10, 2011 6:25 pm

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby orani » Fri Apr 15, 2011 4:39 pm

HEllo Edvard,

The cache is not updated since 04/14: http://www.aleph-news.net/gtranslate/cache/en/?C=M;O=D

Any idea ?

The ages aren't translated anymore ?

Thx


--- here is the debug.txt generated by http://www.aleph-news.net/ to http://www.aleph-news.net/en/?p=7842----------
* About to connect() to www.aleph-news.net port 80
* Trying 88.191.139.208... * connected
* Connected to www.aleph-news.net (88.191.139.208) port 80
> GET /?category_name=syrie HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Host: www.aleph-news.net
Accept: */*
Cookie: __utma=242541650.812617264.1302111644.1302676595.1302783433.8; __utmz=242541650.1302111644.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); wp-settings-1=m0%3Do%26m9%3Do%26m1%3Do%26m2%3Do%26m4%3Do%26m5%3Do%26m8%3Do%26m7%3Do%26m6%3Do%26editor%3Dtinymce%26m10%3Do%26widgets_access%3Doff%26m3%3Do%26align%3Dleft%26imgsize%3Dmedium; wp-settings-time-1=1302894065; __utmc=242541650; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_94c51b75ac78c4e7eb34395e0fde53ee=admin%7C1302981371%7Cb4ccb82530be48fd4622a1a422f82d5b

< HTTP/1.1 200 OK
< Date: Fri, 15 Apr 2011 19:37:23 GMT
< Server: Apache/2.2.3 (CentOS)
< X-Powered-By: PHP/5.2.10
< X-Pingback: http://www.aleph-news.net/xmlrpc.php
< Expires: Wed, 11 Jan 1984 05:00:00 GMT
< Last-Modified: Fri, 15 Apr 2011 19:37:24 GMT
< Cache-Control: no-cache, must-revalidate, max-age=0
< Pragma: no-cache
< Connection: close
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=UTF-8
* Closing connection #0
* About to connect() to www.aleph-news.net port 80
* Trying 88.191.139.208... * connected
* Connected to www.aleph-news.net (88.191.139.208) port 80
> GET /?p=7842 HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Host: www.aleph-news.net
Accept: */*
Cookie: __utma=242541650.812617264.1302111644.1302676595.1302783433.8; __utmz=242541650.1302111644.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); wp-settings-1=m0%3Do%26m9%3Do%26m1%3Do%26m2%3Do%26m4%3Do%26m5%3Do%26m8%3Do%26m7%3Do%26m6%3Do%26editor%3Dtinymce%26m10%3Do%26widgets_access%3Doff%26m3%3Do%26align%3Dleft%26imgsize%3Dmedium; wp-settings-time-1=1302894065; __utmc=242541650; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_94c51b75ac78c4e7eb34395e0fde53ee=admin%7C1302981371%7Cb4ccb82530be48fd4622a1a422f82d5b

< HTTP/1.1 200 OK
< Date: Fri, 15 Apr 2011 19:37:31 GMT
< Server: Apache/2.2.3 (CentOS)
< X-Powered-By: PHP/5.2.10
< X-Pingback: http://www.aleph-news.net/xmlrpc.php
< Expires: Wed, 11 Jan 1984 05:00:00 GMT
< Last-Modified: Fri, 15 Apr 2011 19:37:31 GMT
< Cache-Control: no-cache, must-revalidate, max-age=0
< Pragma: no-cache
< Connection: close
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=UTF-8
* Closing connection #0
* About to connect() to www.aleph-news.net port 80
* Trying 88.191.139.208... * connected
* Connected to www.aleph-news.net (88.191.139.208) port 80
> GET /?p=7842 HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Host: www.aleph-news.net
Accept: */*
Cookie: __utma=242541650.812617264.1302111644.1302676595.1302783433.8; __utmz=242541650.1302111644.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); wp-settings-1=m0%3Do%26m9%3Do%26m1%3Do%26m2%3Do%26m4%3Do%26m5%3Do%26m8%3Do%26m7%3Do%26m6%3Do%26editor%3Dtinymce%26m10%3Do%26widgets_access%3Doff%26m3%3Do%26align%3Dleft%26imgsize%3Dmedium; wp-settings-time-1=1302894065; __utmc=242541650; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_94c51b75ac78c4e7eb34395e0fde53ee=admin%7C1302981371%7Cb4ccb82530be48fd4622a1a422f82d5b

< HTTP/1.1 200 OK
< Date: Fri, 15 Apr 2011 19:37:35 GMT
< Server: Apache/2.2.3 (CentOS)
< X-Powered-By: PHP/5.2.10
< X-Pingback: http://www.aleph-news.net/xmlrpc.php
< Expires: Wed, 11 Jan 1984 05:00:00 GMT
< Last-Modified: Fri, 15 Apr 2011 19:37:36 GMT
< Cache-Control: no-cache, must-revalidate, max-age=0
< Pragma: no-cache
< Connection: close
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=UTF-8
* Closing connection #0
* About to connect() to www.aleph-news.net port 80
* Trying 88.191.139.208... * connected
* Connected to www.aleph-news.net (88.191.139.208) port 80
> GET /?tag=otan HTTP/1.1
User-Agent: Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)
Host: www.aleph-news.net
Accept: */*
Cookie:

< HTTP/1.1 200 OK
< Date: Fri, 15 Apr 2011 19:38:16 GMT
< Server: Apache/2.2.3 (CentOS)
< X-Powered-By: PHP/5.2.10
< X-Pingback: http://www.aleph-news.net/xmlrpc.php
< Connection: close
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=UTF-8
* Closing connection #0
orani
 
Posts: 11
Joined: Sun Apr 10, 2011 6:25 pm

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby Edvard » Sat Apr 16, 2011 12:16 am

Hi,

I can see that your cache is growing. If you want you can disable some of the languages you don't need to be translated and indexed to save bandwidth.

To do that you need to replace ([a-z]{2}) with (en|ru|it|fr|de|...) with the language codes you want to be translated.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby orani » Sat Apr 16, 2011 2:32 am

in the rewrite rules ? like this ?

Code: Select all
RewriteRule ^(en|ar|fa|tr|zh-CN|zh-TW)/(en|ar|fa|tr|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^(en|ar|fa|tr|zh-CN|zh-TW)/(en|ar|fa|tr|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteRule ^(en|ar|fa|tr|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA]
RewriteRule ^(en|ar|fa|tr|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA]
orani
 
Posts: 11
Joined: Sun Apr 10, 2011 6:25 pm

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby Edvard » Mon Apr 18, 2011 2:57 pm

Correct.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: 404 on GTranslate Pro unresolved by "Troubleshouting"

Postby orani » Fri Apr 22, 2011 12:54 am

Oki, thanx for help ...

Sometime the google service looks not so stable ... but with patience it will works fine :-)
orani
 
Posts: 11
Joined: Sun Apr 10, 2011 6:25 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux
cron