[Solved] BING translation problem

Popular automatic website translation tool

[Solved] BING translation problem

Postby [email protected] » Fri Dec 14, 2012 2:24 pm

We are using BING for over a year through "define('USE_BING_TRANSLATOR', true)". Since our website is in 15 languages, when a new content is added, we use ?force_translation=1 to have everything translated right away. This worked fine until yesterday. Now it is super slow and only translating parts sometime. In some cases it doesn't translate at all. Don't understand what is happening, is it our website, BING or GTranslate problem? Anyone else experiencing the same problems?
[email protected]
 
Posts: 48
Joined: Thu Apr 21, 2011 9:22 pm

Re: BING translation problem

Postby Yana » Fri Dec 14, 2012 4:11 pm

Hi,
Please enable the gtranslate debug mode and check. /gtranslate/debug.txt file. Make sure that you didn't exceed the limit. Also please check gtranslate cache folders permissions (should be 777).
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm

Re: BING translation problem

Postby [email protected] » Fri Dec 14, 2012 8:41 pm

Thank You for support. Cache folder is 777. So, here is debug.txt:

* About to connect() to www.dreamingcroatia.com port 80 (#0)
* Trying 174.132.158.218...
* connected
* Connected to www.dreamingcroatia.com (174.132.158.218) port 80 (#0)
> GET /component/realtyna/?SortDir=2&limit=5&filterresults=1&view=propertylisting&tpl=c21&filter_order=building_name&start=710 HTTP/1.1
User-Agent: Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)
Host: www.dreamingcroatia.com
Accept: */*
Cookie:

< HTTP/1.1 200 OK
< Date: Fri, 14 Dec 2012 16:39:01 GMT
< Server: Apache
< P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
< Expires: Mon, 1 Jan 2001 00:00:00 GMT
< Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
< Pragma: no-cache
< Set-Cookie: 585c7d8b1d98d676915a830a5d9fc8a7=23b7d6c0e81c69cae62a3486e8efb51b; path=/
< Last-Modified: Fri, 14 Dec 2012 16:39:02 GMT
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=utf-8
<
* Connection #0 to host www.dreamingcroatia.com left intact
* Closing connection #0
* About to connect() to dreamingcroatia.com port 80 (#0)
* Trying 174.132.158.218...
* connected
* Connected to dreamingcroatia.com (174.132.158.218) port 80 (#0)
> GET /12-rpl-apartment-67.html?Sort=&SortDir=2&limit=15&limitstart=360&option=com_realtyna&task=&filterresults=1&view=propertylisting&tpl=c21&controller=&filter_order=building_name&filter_order_Dir= HTTP/1.1
User-Agent: Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)
Host: dreamingcroatia.com
Accept: */*
Cookie:

< HTTP/1.1 200 OK
< Date: Fri, 14 Dec 2012 16:39:08 GMT
< Server: Apache
< P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
< Expires: Mon, 1 Jan 2001 00:00:00 GMT
< Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
< Pragma: no-cache
< Set-Cookie: 585c7d8b1d98d676915a830a5d9fc8a7=031b37843f91d5e6855f384263f5ff9f; path=/
< Last-Modified: Fri, 14 Dec 2012 16:39:09 GMT
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=utf-8
<
* Connection #0 to host dreamingcroatia.com left intact
* Closing connection #0
softtranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>161B06184FA0D266E2254EEFB5A8B1B455FA5199</ns1:appId><ns1:text>Land Plot, in Croatia, Splitsko-Dalmatinska, Kastela, on the th Floor The Price is : 120000 €&#13;
</ns1:text><ns1:from>en</ns1:from><ns1:to>de</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response:

Exception: SoapFault Object
(
[message:protected] => Could not connect to host
[string:private] =>
[code:protected] => 0
[file:protected] => /home/dreaming/public_html/gtranslate/translate.php
[line:protected] => 101
[trace:private] => Array
(
[0] => Array
(
[function] => __doRequest
[class] => SoapClient
[type] => ->
[args] => Array
(
[0] => <?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>161B06184FA0D266E2254EEFB5A8B1B455FA5199</ns1:appId><ns1:text> | building-permit-land-plot-sale | Croatia | Kastela | real estate</ns1:text><ns1:from>en</ns1:from><ns1:to>de</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

[1] => http://api.microsofttranslator.com/V2/soap.svc
[2] => http://api.microsofttranslator.com/V2/L ... /Translate
[3] => 1
[4] => 0
)

)

[1] => Array
(
[file] => /home/dreaming/public_html/gtranslate/translate.php
[line] => 101
[function] => __call
[class] => SoapClient
[type] => ->
[args] => Array
(
[0] => Translate
[1] => Array
(
[0] => Array
(
[appId] => 161B06184FA0D266E2254EEFB5A8B1B455FA5199
[text] => | building-permit-land-plot-sale | Croatia | Kastela | real estate
[from] => en
[to] => de
)

)

)

)

[2] => Array
(
[file] => /home/dreaming/public_html/gtranslate/translate.php
[line] => 209
[function] => get_translation
)

[3] => Array
(
[file] => /home/dreaming/public_html/gtranslate/translate.php
[line] => 264
[function] => gtranslate
)

[4] => Array
(
[file] => /home/dreaming/public_html/gtranslate/translate.php
[line] => 588
[function] => translate
[args] => Array
(
[0] => Array
(
[appId] => 161B06184FA0D266E2254EEFB5A8B1B455FA5199
[text] => | building-permit-land-plot-sale | Croatia | Kastela | real estate
[from] => en
[to] => de
)

)

)

[5] => Array
(
[file] => /home/dreaming/public_html/gtranslate/translate.php
[line] => 601
[function] => outertext
[class] => simple_html_dom_node
[type] => ->
)

[6] => Array
(
[file] => /home/dreaming/public_html/gtranslate/translate.php
[line] => 601
[function] => outertext
[class] => simple_html_dom_node
[type] => ->
)

[7] => Array
(
[file] => /home/dreaming/public_html/gtranslate/translate.php
[line] => 601
[function] => outertext
[class] => simple_html_dom_node
[type] => ->
)

[8] => Array
(
[file] => /home/dreaming/public_html/gtranslate/translate.php
[line] => 578
[function] => outertext
[class] => simple_html_dom_node
[type] => ->
)

[9] => Array
(
[file] => /home/dreaming/public_html/gtranslate/translate.php
[line] => 976
[function] => innertext
[class] => simple_html_dom_node
[type] => ->
)

[10] => Array
(
[file] => /home/dreaming/public_html/gtranslate/translate.php
[line] => 418
[function] => save
[class] => simple_html_dom
[type] => ->
)

)

[faultstring] => Could not connect to host
[faultcode] => HTTP
)

Request:
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>161B06184FA0D266E2254EEFB5A8B1B455FA5199</ns1:appId><ns1:text> | building-permit-land-plot-sale | Croatia | Kastela | real estate</ns1:text><ns1:from>en</ns1:from><ns1:to>de</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response:

* About to connect() to www.dreamingcroatia.com port 80 (#0)
* Trying 174.132.158.218...
* connected
* Connected to www.dreamingcroatia.com (174.132.158.218) port 80 (#0)
> GET /realtyna/Kastela/Croatia/building-permit-land-plot-sale/-903.html HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.97 Safari/537.11
Host: www.dreamingcroatia.com
Accept: */*
Cookie: 585c7d8b1d98d676915a830a5d9fc8a7=1227066f6b80923e04ced8b90942abbf; 451928ceccde5222a4242f62decf9604=ff83c7ba433cb3da68382fae49c4e1f2; __utma=99337547.6521301.1348427907.1355486069.1355502511.158; __utmb=99337547.14.10.1355502511; __utmc=99337547; __utmz=99337547.1349634083.41.2.utmcsr=google|utmccn=(organic)|utmcmd=organic|utmctr=(not%20provided)

< HTTP/1.1 200 OK
< Date: Fri, 14 Dec 2012 16:39:28 GMT
< Server: Apache
< P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
< Expires: Mon, 1 Jan 2001 00:00:00 GMT
< Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
< Pragma: no-cache
< Last-Modified: Fri, 14 Dec 2012 16:39:30 GMT
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=utf-8
<
* Connection #0 to host www.dreamingcroatia.com left intact
* Closing connection #0
[email protected]
 
Posts: 48
Joined: Thu Apr 21, 2011 9:22 pm


Re: BING translation problem

Postby Yana » Sun Dec 16, 2012 2:47 am

Hi,
You need to update the plugin. What is your email address?
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm

Re: BING translation problem

Postby [email protected] » Sun Dec 16, 2012 9:27 pm

[email protected]
 
Posts: 48
Joined: Thu Apr 21, 2011 9:22 pm

Re: BING translation problem

Postby Yana » Mon Dec 17, 2012 2:19 am

Hi,
Just sent the latest version. Please update the plugin and let me know if you have any questions.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm


Re: BING translation problem

Postby Yana » Mon Dec 17, 2012 8:41 pm

Hi,
If you can send me access info I can check the settings.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm


Re: BING translation problem

Postby Yana » Tue Dec 18, 2012 1:02 am

HI,
Can you please send FTP access also? I should check the settings.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm



Re: BING translation problem

Postby Yana » Wed Dec 19, 2012 2:00 am

Hi,
I can seee "Could not connect to host" in the debug.txt . It cannot connect to Bing. Please ask your hosting provider to fix the issue or use google instead of Bing. Also you can use GTranslate Enterprise service.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm


Re: BING translation problem

Postby Yana » Wed Dec 19, 2012 11:34 pm

HI,
API key is an optional feature and it is commercial. You can remove it.
GTranslate Enterprise will work properly. By the time enerything will be translated and cached.
You can change memory limit in php.ini file.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm


Re: [Solved] BING translation problem

Postby Edvard » Fri Dec 21, 2012 2:16 pm

Thanks for your patience with us!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux
cron