changing language 2 times gives a double prefix in the URL.

Popular automatic website translation tool

changing language 2 times gives a double prefix in the URL.

Postby ricardo » Thu Jan 29, 2015 11:06 am

I have installed Gtranslate pro. and the module for choosing the language.

After choosing one language from the module it offers the translated page, so far no problem, but as soon as I choose another language it changes back to the first one: I also see " .... /de/en ... " in the URL

see here http://dagboekvaneenhoerenloper.com/de/ ... al-van-eva
ricardo
 
Posts: 4
Joined: Mon Jan 26, 2015 10:31 am

Re: changing language 2 times gives a double prefix in the U

Postby Yana » Thu Jan 29, 2015 1:46 pm

Hi,
I'm getting the following error "The web service to this account has been limited temporarily!"
Please let me know as soon as the issue is fixed, so I can check your website.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: changing language 2 times gives a double prefix in the U

Postby ricardo » Thu Jan 29, 2015 10:52 pm

Hi Yana, that has to do with my first problem. Since i have Gtranslate Pro my site uses way too much CPU (Allowed Quota: 300000 CPU seconds/mo
Your Current Usage: 448922.56 CPU seconds/mo) in only half a month
So they suspended the site until Febr. 1.

I desperate need to know how I can lower the amount of cpu. I reduced to only 10 languages, many of the cache folders seem to be filled up (in every language folder is about 5000 files , 300 kb) My site has around 250 articles.
and appx 300 visitors a day.
Furthermore it seems that there is an enormous amount of cpu if I login to the site (backend or frontend)

Can you tell me how to solve the cpu issue so I can fix that as soon as the site is back.
ricardo
 
Posts: 4
Joined: Mon Jan 26, 2015 10:31 am

Re: changing language 2 times gives a double prefix in the U

Postby Yana » Fri Jan 30, 2015 6:14 pm

Hi,

Here are the steps that can help you to reduce the number of the files in the cache.
1. You can disable some unnecessary languages by redirecting to the homepage . Here is an example of .htaccess rule.

RewriteEngine On
RewriteRule ^(af|ar|az)/(.*)$ /$2 [R=301,L]

2. If you have dynamic texts (dynamic date-times, counters etc.) in your pages try to wrap them with class="notranslate".

Also, you can use GTranslate Enterprise service, which is a translation delivery network and it will keep the cache in our cloud TDN.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest

2GLux