Default Language comes after form submittion

Popular automatic website translation tool

Default Language comes after form submittion

Postby kamlesh.tasol » Mon Jul 08, 2013 8:05 am

Hello,

Site is buit in Joomla 1.7 with SH404SEF enabled. I am using Gtranslate Pro and translations are working OK.
But, I noticed one problem with Gtranslate, it does not keeps the language chosen before form submission in next page.It gets default English language in page comes after form submits.

Can you please help me?
kamlesh.tasol
 
Posts: 16
Joined: Mon Mar 26, 2012 9:27 am

Re: Default Language comes after form submittion

Postby Yana » Mon Jul 08, 2013 10:15 am

Hi,
The plugin sets a session variable to keep the selected language even if the language code is missing from the URL. That happens if you have GTranslate Pro plugin for Joomla installed instead of Pro version installed for general websites. Please try to install the system plugin version. You can find the documentation here https://gtranslate.io/docs
Please let me know if you have any questions.
Thanks!
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: Default Language comes after form submittion

Postby kamlesh.tasol » Mon Jul 08, 2013 11:00 am

Hello,
Thank you for your kind reply.
I can see Gtranslate Pro System plugin is intalled in my site and configured as mentioned for "GTranslate Pro Joomla Plugin installation".
But, I found that "Gtranslate" folder at the root of my sever. I think that is for Gtranslate General Installtion.
Can you please guide me what I have to do now ?
kamlesh.tasol
 
Posts: 16
Joined: Mon Mar 26, 2012 9:27 am

Re: Default Language comes after form submittion

Postby Yana » Mon Jul 08, 2013 1:35 pm

Hi,
It seems you installed both versions at the same time. Please uninstall the general version. For that you will need to remove gtranslate rewrite rules from .htaccess file and delete gtranslate folder which is in the root directory. For the system plugin there is no need to add redirection rules.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: Default Language comes after form submittion

Postby kamlesh.tasol » Mon Jul 08, 2013 2:03 pm

Hello,

I renamed that "gtranslate" folder to "gtranslate_" which is at the root of server.
Also, Removed those 5 lines for gtranslate from .htaccess file placed on root.
Now, I am getting 404 page when I am selecting another language. :cry:
kamlesh.tasol
 
Posts: 16
Joined: Mon Mar 26, 2012 9:27 am

Re: Default Language comes after form submittion

Postby Yana » Mon Jul 08, 2013 2:21 pm

If you can send me ftp access info and backend admin username /password I can check the settings.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: Default Language comes after form submittion

Postby kamlesh.tasol » Mon Jul 08, 2013 2:28 pm

Hello Yana,

Those 404 pages I was getting because SEF and Url rewritting from config was disabled. I was not aware of this, since SH404SEF was elabled, I thought enbling it from Joomla Config will not required.
But, Since, I enabled both options from Joomla Config, I am getting the language which I selected before the submitting the form

Thank you very very much for your kind support to solve this glitch done by me. :D

Now, The other one problem I notice is "Gtranslate Dropdown Module" does not keeps selected the new changed language in dropdown.It only shows "Select Language" selected regalrless of choose any langauge.
kamlesh.tasol
 
Posts: 16
Joined: Mon Mar 26, 2012 9:27 am

Re: Default Language comes after form submittion

Postby Yana » Mon Jul 08, 2013 2:46 pm

Hi,
Thank you for the information! Please check the following post

show-current-lang-instead-select-language-t2874.html#p11812
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: Default Language comes after form submittion

Postby kamlesh.tasol » Mon Jul 08, 2013 3:20 pm

Hello Yana,

Thank you for your help and solving my all issues.
kamlesh.tasol
 
Posts: 16
Joined: Mon Mar 26, 2012 9:27 am

Re: Default Language comes after form submittion

Postby Yana » Tue Jul 09, 2013 1:55 pm

Hi,
You're welcome!
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest

2GLux