Default language not used on home URL after translation

Popular automatic website translation tool

Default language not used on home URL after translation

Postby furnivat » Thu Sep 25, 2014 2:18 pm

Hello, I am on Joomla 2.5 with GTranslate Pro (the latest version), JoomSEF and a component called Chameleon. I think the plugins are in the right order because everything seems to be working.

I have a site where the default language is English, so pages on are in English.
I have a problem that if I go to the content is correctly translated to French, for example, however if I then manually type into the address bar and visit the site's homepage that way the content appears in French. The only way I can get it to revert to English is by using the GTranslate language select module and choosing English from the drop-down or going to (which redirects to with English text on the homepage).

Is this normal behaviour? Is there any way of setting a cookie or session variable to force English if the URL does not contain a 2 letter language code? I have a Joomla plugin called Chameleon on my site which can manually set cookies or session variables; could I perhaps use that to force English on the homepage of the site?
Posts: 21
Joined: Sun Dec 26, 2010 7:11 pm

Re: Default language not used on home URL after translation

Postby Edvard » Thu Sep 25, 2014 2:29 pm


It is a normal behavior. If you want to force English when there is no language code you may disable the GTranslate plugin and install general version which is described in the GTranslate Pro documentation.

Thank you!

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Site Admin
Posts: 4150
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

  • Related Topics
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests