Forum Archive - error 500

error 500
Jun 17, 2011 10:20 am by [email protected]
Well, I've followed, may bad, your instructions and tryed with this url: http://soropositivo.org/es/ In the beggining gives a 404 error. I made a mistake in .http... Second the page opens, however, without translaction. So I went into module administration, enableded redirec and translation pro. Now it gives 500 error and I can't go further. Please, if you think that I'm unable to install this, I humbly ask you to install it to me Thanks. Kindly regards Claudio
Re: error 500
Jun 17, 2011 10:35 am by Edvard
Hi, please check the troubleshooting and let me know if you are unable to fix it: gtranslate/troubleshooting-gtranslate-pro-t368.html#4
Re: error 500
Jun 17, 2011 1:37 pm by [email protected]
HI, I was working on this for the last hours and my support told me I should change php to DSO as follows; 'Virtual directory' is a feature that PHP supports in IIS only. In Apache, you can use this functionality in a limited level using 'mod_rewrite' and '.htaccess' files. For this, PHP must be setup as a DSO. Please refer the link given below: --------- http://forums.cpanel.net/f5/virtual-dir ... 32661.html --------- Currently, PHP is configued as 'suPHP'. =========== [email protected] [~]# /usr/local/cpanel/bin/rebuild_phpconf --current Available handlers: suphp dso cgi none DEFAULT PHP: 5 PHP4 SAPI: none PHP5 SAPI: suphp SUEXEC: enabled [email protected] [~]# =========== You can change this to DSO from WHM: ---------- >> Main >> Service Configuration >> Configure PHP and SuExec Unfortunatelly all my websites, including all for my costumers stops to work and I couldn't go further. I know we may find a solution, but I guess I'll need a bigger apporach of you If you wish to check in my server, just let me know a safe way to send you the credentials Best regards Claudio
Re: error 500
Jun 17, 2011 2:12 pm by [email protected]
I went further In fact only one website was affected I change permissions in a folder and now it works with DSo So I could move on and set up DSO as default. Now, IE, I go to http://soropositivo.org/es or otherwise and I get this error? Lots of it:Warning: file_put_contents(cache/limit.txt) [function.file-put-contents]: failed to open stream: Permission denied in /home/soroposi/public_html/gtranslate/translate.php on line 167 After the warning websites opens without translation. Thinking could be a permission issue I went into gtranslate folder and look aroeund Iven the cache folder is with 755 permissions and, I believe, I can't go further. I need, and now it seems so serious, your help :) Thanks in adavance Best regards Claudio
Re: error 500
Jun 17, 2011 2:40 pm by [email protected]
Surpriselly I Went further. Reading your FAQ I find out I would have an API Key to translate the texts, and discover more, I have a limited 100.000 characters to be translated for free! Well it remais the Damned permission issue, as you can see here www.soropositivo.org/ar/ ou www.soropositivo.org/es/ You know your system better tahn me and, of course, with one sight you will solve this. No, I quit. Thanks in advance Best regards Claudio
Re: error 500
Jun 17, 2011 3:09 pm by [email protected]
instead to give up I went further I discover a file named limit.txt I change its permissions to 755, 775, 777 and in all of them the warning stops but page is not translated. i compared the local folder with web folde and saw that limit.txt exists onluy in webfolder So I deleted limit.txt and try once. The warning is there and there is no translation at all. I surrender. I'll wait for you Best regards :x
Re: error 500
Jun 17, 2011 3:41 pm by [email protected]
Just updating I set dubug true and find out this curl_setopt(): supplied argument is not a valid File-Handle resource Is getting complicate
Re: error 500
Jun 17, 2011 5:12 pm by [email protected]
After centurys I read your readme with major attention and have solved the permissions issue. Unhappily, the system is not translating. I'm updating you step by step because I'd like to give you shortcuts, in order to avoid you gime some instruction that I really has done here. AS far as I can see I'll see your answer oly tomorrow, what is sad, because I very ansious ro publish this innovations to the world. By the way, I working on it. regards Claudio
Re: error 500
Jun 17, 2011 5:23 pm by [email protected]
I created debug txt, set permissions in 666 as I saw in somewhere here. It appears blank. However, remais these four lines with warnings; Warning: fopen(debug.txt) [function.fopen]: failed to open stream: Permission denied in /home/soroposi/public_html/gtranslate/translate.php on line 60 Warning: curl_setopt(): supplied argument is not a valid File-Handle resource in /home/soroposi/public_html/gtranslate/translate.php on line 73 Warning: curl_setopt(): supplied argument is not a valid File-Handle resource in /home/soroposi/public_html/gtranslate/translate.php on line 122 Warning: fwrite(): supplied argument is not a valid stream resource in /home/soroposi/public_html/gtranslate/translate.php on line 133 Cannot translate: AIDS, HPV, HIV, sexualidade,DST And remains a page that it's not translated. I did, including a delete gtranslate folder and reuploaded everything to avoid permissions erros I could be made in this frame time. I'll look foward these erros ate web, but I'm still standing you
Re: error 500
Jun 17, 2011 5:41 pm by [email protected]
I disabled debug, set limit.txt's permissions to 777 and there is no more warning or error. But it remains without a solution. I'm working on thins for seven hours and you can wonder how this is important to me. I'll look around your FAQ. I'm still standing]regards
Re: error 500
Jun 17, 2011 6:05 pm by [email protected]
AS far as I can see is everything ok. It's obvious that not. My last movement was to check API Key and it is correct. But there is this issues Debug is empty Limit.txt is empty. The folders I use to test, as ar and es ou en are empty. And tehere is no translations. I promissed to someone that this would be easy and faster (after to test your free versio), now I'm in a reaaly bad situation here, working for hour, updating you at each little movement without any update from you. Tied...
Re: error 500
Jun 17, 2011 7:43 pm by [email protected]
I was researching you in your website. I discover you are a very buzy person and I would like to apologize with you for my last post. You are a serious person and don't deserve this kind of insult. I've sended to you an e-mail with my credentials in ftp and site adm. I leave the apikey in config.php. Thinking I've reachead my limit in API I get a new one in other ID, just to tests. In my last movement I went into cpanel to see if could exist some diffrence between what I see and the true thing (cable modem cache's issues) and I find out this, in limit.txt 1308339290 I have no idea what it means Now, I'll try to sleep a lithle while, about 1 or 2 hours Regards
Re: error 500
Jun 17, 2011 8:27 pm by [email protected]
I can't fall in sleep. I've been reseaching in your forum, but anything I try is useless. By the way, I'm only taking a look, because I decided to await your update. But I saw somewhere that Google APi is to limiteted and I must agree. 100.000 char per dai and it ends with 20 or 25 pages, I need more. Could you teach me about the difference between google and bing, in terms of chars limits? And could you make one favor and give me the directions to BINGĀ“s API? Or a negotiation channel with google. My web site is a non-profit service, witha really true .org extension and it has no revenue, I can't spend more resources that I already expeded... Anyway, I'm giving my shot
Re: error 500
Jun 18, 2011 7:22 am by [email protected]
Hi, greetings I'm looking around and I see some pages are partially translated but when you click in a link in AF, by exameple, rthe home page is translated, but the internal pages dont. I checked out the api and is not completely used. Could you guide me?
Re: error 500
Jun 18, 2011 11:18 am by [email protected]
Hello! It's allmost working It translates the first page but when you follow a link opens a page in portuguese, the main language you may see it in soropositivo.org/es An gives in a blank page when acees to soropositivo.org/ar Regards
Re: error 500
Jun 20, 2011 12:01 pm by Edvard
Hi, Sorry for my late response I was out for a weekend. It seems that you finally were able to get translations. Now I don't see that it works on your site. It only shows 404 error page. After installation it will not translate everything you have on your site, since there are daily limitations, but it will translate everything over time starting from the popular pages.

SIMILAR TOPICS

Gtranslate: Error with numberFeb 20, 2019 1:20 amReplies: 1Post by: infact_dat
Error message and URL problemsFeb 6, 2019 11:16 amReplies: 1Post by: Kidbooo
GT doesn't work...error 404 pageJan 28, 2019 5:36 pmReplies: 1Post by: vincenzodinuzzo
Nginx 502 ErrorJan 11, 2019 2:15 pmReplies: 1Post by: mightyfineprint
Error message on click on the widgetJan 6, 2019 9:52 pmReplies: 1Post by: jmric68

Try GTranslate with a free 15 day trial