Fail on Edit Translation

Popular automatic website translation tool

Fail on Edit Translation

Postby miamiman » Tue May 31, 2011 8:22 pm

Have been using Gtranslate for a while now. Everything fine.

But today, when I went to manually edit a page [?language_edit=1], I get a "fail" error although the username and password are correct?

Using latest Chrome and Firefox.

Any idea?
miamiman
 
Posts: 55
Joined: Mon Mar 07, 2011 10:36 pm

Re: Fail on Edit Translation

Postby Janz » Thu Jun 02, 2011 8:59 pm

Hi,

I have exactly the same problem.
What is the solution to that please?
Thanks
Janz
 
Posts: 11
Joined: Thu Jun 02, 2011 8:39 pm

Re: Fail on Edit Translation

Postby Janz » Thu Jun 02, 2011 9:14 pm

I also find this errors:
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 1.1.4322; .NET CLR 3.5.30729; .NET CLR 3.0.30729; InfoPath.2; .NET4.0C; .NET4.0E)
Timestamp: Thu, 2 Jun 2011 17:13:39 UTC


Message: 'document.getElementsByName(...).0.innerHTML' is null or not an object
Line: 1503
Char: 206
Code: 0
URI: http://www.mydomain.com/cs/?language_edit=1
Janz
 
Posts: 11
Joined: Thu Jun 02, 2011 8:39 pm

Re: Fail on Edit Translation

Postby Edvard » Fri Jun 03, 2011 12:09 pm

Try to use Firefox for editing and make sure that you enter a correct username and password as defined in gtranslate/config.php file.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4179
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Fail on Edit Translation

Postby Janz » Fri Jun 03, 2011 4:16 pm

Hi,
I tried the Firefox, IE, Opera and Safari and all the same! :(
Password is ok.
Any other ideas please?
Thanks
Janz
 
Posts: 11
Joined: Thu Jun 02, 2011 8:39 pm

Re: Fail on Edit Translation

Postby Edvard » Fri Jun 03, 2011 4:29 pm

What is the same? You see javascript errors or it shows fail after you make the manual translation, enter your login and password and hit save?
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4179
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Fail on Edit Translation

Postby miamiman » Fri Jun 03, 2011 4:46 pm

I too am having the same problem and have tried with FF/IE/CHROME.

Username/Password are correct re: config. file.
Cache file set to 777.

I don't see any errors besides saying "fail" on editing.

Surely, this is javascript conflict error? Which one? Page shows no errors.

Help.
miamiman
 
Posts: 55
Joined: Mon Mar 07, 2011 10:36 pm

Re: Fail on Edit Translation

Postby Edvard » Fri Jun 03, 2011 4:51 pm

If you see fail, it is not a javascript conflict. It is because you enter a wrong user/pass or the language folder is not writable. gtranslate/cache/XX folders should have 777 permission.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4179
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Fail on Edit Translation

Postby miamiman » Fri Jun 03, 2011 5:10 pm

Edvard,

I have checked (and rechecked).

1. Config file username/password are correct.
2. .gtranslate/cache/XX are all set to 777.

And am still getting "fail" on FF/IE/CHROME when editing.

Please advise.
miamiman
 
Posts: 55
Joined: Mon Mar 07, 2011 10:36 pm

Re: Fail on Edit Translation

Postby Edvard » Fri Jun 03, 2011 5:11 pm

Can you post your config.php file here? I have doubts that you did something wrong in it when defining the username and password.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4179
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Fail on Edit Translation

Postby Janz » Fri Jun 03, 2011 5:21 pm

Hi,
I check the Chmods, and they are the same. All I get on any browser is "Fail" error.
Thanks

Here is the config:

<?php
define('API_KEY', 'AIzaSyAcWjmSzgG7sU5ry7NSCKe2lBPkDeZczVw'); // You need to get your Google Translate API key from https://code.google.com/apis/console/?api=translate
define('MAIN_LANG', 'en'); // en, ar, bg, hr, cn, ct, cs, da, et, tl, fi, fr, gl, el, iw, hi, es, nl, id, ja, ca, ko, lt, lv, mt, de, no, pt, ru, ro, sr, sk, sl, sv, th, tr, uk, hu, vi, it, pl, sq
define('AUTO_DETECT_LANG', false); // set to true if you have mixed language content
define('CACHE_TIME', 365*24*60*60); // 1 year by default, no need to decrease
define('LICENSE', 'license.dat');
define('SSL_VERIFY_PEER', true); // disable if you get CA certificate error and cannot reconfigure your server to solve the issue
define('DEBUG', false); // turn on for debug mode

// username and password to edit translations, please change for security reasons,
// this is not your google login/pass, you need to think something new
define('TestingUser', 'user');
define('TestingPass', 'pass');
Janz
 
Posts: 11
Joined: Thu Jun 02, 2011 8:39 pm

Re: Fail on Edit Translation

Postby miamiman » Fri Jun 03, 2011 5:25 pm

Here goes:

Just changed the api/user/password.

All looks correct

=====
define('API_KEY', 'googleapitemp'); // You need to get your Google Translate API key from https://code.google.com/apis/console/?api=translate
define('MAIN_LANG', 'es'); // en, ar, bg, hr, cn, ct, cs, da, et, tl, fi, fr, gl, el, iw, hi, es, nl, id, ja, ca, ko, lt, lv, mt, de, no, pt, ru, ro, sr, sk, sl, sv, th, tr, uk, hu, vi, it, pl, sq
define('AUTO_DETECT_LANG', false); // set to true if you have mixed language content
define('CACHE_TIME', 365*24*60*60); // 1 year by default, no need to decrease
define('LICENSE', 'license.dat');
define('SSL_VERIFY_PEER', true); // disable if you get CA certificate error and cannot reconfigure your server to solve the issue
define('DEBUG', false); // turn on for debug mode

// username and password to edit translations, please change for security reasons,
// this is not your google login/pass, you need to think something new
define('USER', 'usertemp');
define('PASS', 'userpass');
=====
miamiman
 
Posts: 55
Joined: Mon Mar 07, 2011 10:36 pm

Re: Fail on Edit Translation

Postby Janz » Fri Jun 03, 2011 6:13 pm

Unfortunately, I still have the Fail message ;(
Janz
 
Posts: 11
Joined: Thu Jun 02, 2011 8:39 pm

Re: Fail on Edit Translation

Postby Edvard » Mon Jun 06, 2011 10:57 am

You have a wrong config.php.

Instead of

define('TestingUser', 'user');
define('TestingPass', 'pass');

you should have this:

define('USER', 'TestingUser');
define('PASS', 'TestingPass');
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4179
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Fail on Edit Translation

Postby Janz » Mon Jun 06, 2011 2:27 pm

YES!
Funny how such a small thing could make a mess ;)

Anyway.

Thanks Edvard!
Janz
 
Posts: 11
Joined: Thu Jun 02, 2011 8:39 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux