First Language Stuck, and doesn't switch back

Popular automatic website translation tool

First Language Stuck, and doesn't switch back

Postby vasco4style » Sat Jun 01, 2013 12:31 pm

Hi everyone,

I have gone through the forum here and couldn't find the solution.

I've been having a trouble with switching languages. The main language is English but if I switch to for example to Spanish then browse through the website, all the pages are translated to Spanish but when I switch back to another language that page gets translated to the new language but if I click on any link will switch back to Spanish.
Any Idea?

I use GTranslate Pro on Joomla 2.5

You can see here:
http://bestarter.com
vasco4style
 
Posts: 6
Joined: Sat Jun 01, 2013 12:22 pm

Re: First Language Stuck, and doesn't switch back

Postby Yana » Sun Jun 02, 2013 1:27 am

Hi,
Please try to disable the cache for GTranslate module and change GTranslate system plugin and cache plugin order.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: First Language Stuck, and doesn't switch back

Postby vasco4style » Sun Jun 02, 2013 2:02 am

thanks for the reply Yana,

I have set the cache in GTranslate module to "no cache"
I have System - Language Filter plugin disabled
I have System - Language Code plugin disabled
I already have the cache - system plugin disabled, although I have the System - GTranslate plugin enabled of course and comes first in order - before cache - system plugin.

why would a two languages aliases show up in the same link like:
http://www.bestarter.com/fr/ar/seo/youtube-on-google


Also, I have put these lines in the .htaccess as described:
# gtranslate config RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L] RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L] RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA] RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA]


do I have to change anything here or leave it as it is?
vasco4style
 
Posts: 6
Joined: Sat Jun 01, 2013 12:22 pm

Re: First Language Stuck, and doesn't switch back

Postby Seagaard » Sun Jun 02, 2013 6:42 pm

I have the same problem at http://hoofcleaner.com. If you browse through the languages and menu then it fails after SoMe browsing.
Seagaard
 
Posts: 4
Joined: Sun Jun 02, 2013 6:23 pm

Re: First Language Stuck, and doesn't switch back

Postby Seagaard » Sun Jun 02, 2013 7:33 pm

A follow up: i have now found out that the problem is when I switch back to the main languages which is Danish. After i switch back the menu are like /ru/hoofcleaner or /de/hoofcleaner etc.
Seagaard
 
Posts: 4
Joined: Sun Jun 02, 2013 6:23 pm

Re: First Language Stuck, and doesn't switch back

Postby vasco4style » Sun Jun 02, 2013 8:47 pm

hi seagaard,
how did you manage to fix the issue?
vasco4style
 
Posts: 6
Joined: Sat Jun 01, 2013 12:22 pm

Re: First Language Stuck, and doesn't switch back

Postby Seagaard » Sun Jun 02, 2013 10:07 pm

I didnt solve it. It is still a problem tomgangen back to the default language.
Seagaard
 
Posts: 4
Joined: Sun Jun 02, 2013 6:23 pm

Re: First Language Stuck, and doesn't switch back

Postby Yana » Mon Jun 03, 2013 4:28 pm

Dear Seagaard,
Please try to disable joomla system cache and check again.

Dear Vasco4style, please try to uninstall language code and language filter plugins.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: First Language Stuck, and doesn't switch back

Postby Seagaard » Mon Jun 03, 2013 5:10 pm

Hi!

That seems to solve the problem. A weird way to solve this issue - to disable the cache. But it looks like the page loads faster than ever ;-)
Seagaard
 
Posts: 4
Joined: Sun Jun 02, 2013 6:23 pm

Re: First Language Stuck, and doesn't switch back

Postby Yana » Mon Jun 03, 2013 6:29 pm

Thank you for the information. :)
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: First Language Stuck, and doesn't switch back

Postby vasco4style » Tue Jun 04, 2013 11:38 am

Is it safe to uninstall the System - Language Code?? It's system plugin
Also System - Language Filter is Protected and I can't uninstall it.

Do you have other ideas?
vasco4style
 
Posts: 6
Joined: Sat Jun 01, 2013 12:22 pm

Re: First Language Stuck, and doesn't switch back

Postby Yana » Tue Jun 04, 2013 2:26 pm

Dear Vasco4style,

There is a conflict with GTranslate and System - Language Code, Language Filter plugins. You can disable them.
Also you need to make sure that your menu items and content items are using the Language: All .
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: First Language Stuck, and doesn't switch back

Postby vasco4style » Tue Jun 04, 2013 5:55 pm

Both of them are disabled from the beginning, also all the menu items set Languages: All
I'll PM you with the access so you can test by yourself.
vasco4style
 
Posts: 6
Joined: Sat Jun 01, 2013 12:22 pm

Re: First Language Stuck, and doesn't switch back

Postby Yana » Wed Jun 05, 2013 12:21 pm

Hi,
It seems the problem is related to the trailing slash. I added the following rules to your .htaccess file. Please check it and let me know if the problem persists

RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} !index.php
RewriteCond %{REQUEST_URI} !(.*)/$
RewriteRule ^(.*)$ http://yourdomain.com/$1/ [L,R=301]
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: First Language Stuck, and doesn't switch back

Postby vasco4style » Wed Jun 05, 2013 1:09 pm

The problem still not fixed. It seems the Spanish language is on all the pages even the website language is set to English!!!

Can you test it please.
vasco4style
 
Posts: 6
Joined: Sat Jun 01, 2013 12:22 pm

Re: First Language Stuck, and doesn't switch back

Postby Yana » Wed Jun 05, 2013 5:52 pm

Hi,
I disabled the cache and checked again. It is working properly.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux