GTranslate in Joomla Gives Blank Page

Popular automatic website translation tool

GTranslate in Joomla Gives Blank Page

Postby Jarrod » Mon Feb 14, 2011 8:02 pm

Trying to use GTranslate pro. I have installed all necessary PHP packages and they are working. I have SEF and mod_rewrite running on Joomla. I am running several sites on this server, so my directory structure looks like this.

/var/www/Example/ which is pointed at http://www.example.com (obviously a different name, though).

Right now I only have spanish and english enabled, but whenever I try to change language it directs to www.example.com/es/ and shows a blank white screen. No errors, no nothing. Anything I'm missing here?

My .htaccess file looks like this.

Code: Select all
##  Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

RewriteEngine On


# gtranslate config
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA]


RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
RewriteRule ^(.*)$ index.php [F,L]
RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section
Jarrod
 
Posts: 1
Joined: Mon Feb 14, 2011 7:50 pm

Re: GTranslate in Joomla Gives Blank Page

Postby Edvard » Tue Feb 15, 2011 2:43 pm

Hi,

I suspect that you don't have ionCube library installed and your php errors are off.
Try to read the php error log to find out the reason.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4349
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate in Joomla Gives Blank Page

Postby [email protected] » Thu Mar 17, 2011 7:19 pm

Hi Edvard,

I have the same problem...I bought today Pro, did everything by manual and after click on flag displays blank page. This is the url: http://eshop.numizmatikamch.sk .

I installed ionCube (screenshot from phpinfo.php - I hope it is ok. http://cl.ly/1a2o1A2i0l2z2T28383C )

PHP errors are turned on, but the php error log is empty ( http://cl.ly/102O2m0H3K2x421u1b0z )..

Please help, I searched all the forum but no result except this one thread.

PHP version 5.3.3
Mod_rewrite in joomla = on
SEF = on

Thanks
[email protected]
 
Posts: 10
Joined: Thu Mar 17, 2011 7:08 pm

Re: GTranslate in Joomla Gives Blank Page

Postby Edvard » Thu Mar 17, 2011 7:30 pm

I can see display_errors is Off.

Can you upload info.php file from the product package into the gtranslate folder?
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4349
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate in Joomla Gives Blank Page

Postby [email protected] » Thu Mar 17, 2011 7:46 pm

OK, uploaded...

I turned on "display errors" for a while...when click on flag, this error appears: Fatal error: Call to undefined function curl_init() in C:\wamp\www\eshop\gtranslate\translate.php on line 64
[email protected]
 
Posts: 10
Joined: Thu Mar 17, 2011 7:08 pm

Re: GTranslate in Joomla Gives Blank Page

Postby Edvard » Thu Mar 17, 2011 8:50 pm

OK, now you need to ask your hosting provider to install cURL library for you.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4349
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate in Joomla Gives Blank Page

Postby [email protected] » Thu Mar 17, 2011 9:05 pm

Thank you very much...i found cURL in WAMP, so I turned it on...some progress happened, blank page is no more problem. Now the page refreshes after flag click, but no translation...still in slovak. If you have some idea what's the problem, please let me know...
[email protected]
 
Posts: 10
Joined: Thu Mar 17, 2011 7:08 pm

Re: GTranslate in Joomla Gives Blank Page

Postby Edvard » Thu Mar 17, 2011 9:12 pm

Good, now you need to configure the SSL certificate, here is the cURL error log:

* About to connect() to www.googleapis.com port 443 (#0)
* Trying 74.125.77.95... * connected
* Connected to www.googleapis.com (74.125.77.95) port 443 (#0)
* SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
* Closing connection #0
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4349
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate in Joomla Gives Blank Page

Postby [email protected] » Fri Mar 18, 2011 1:19 am

Thank you for your help...

I tried to generate new api translate key, checked the config.php, but everything looks right (of course except the translation). Have you meant something else with "ssl certificate"?
[email protected]
 
Posts: 10
Joined: Thu Mar 17, 2011 7:08 pm

Re: GTranslate in Joomla Gives Blank Page

Postby Edvard » Fri Mar 18, 2011 2:10 am

It is related to the cURL library which is not correctly configured. Please consult with your hosting provider.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4349
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate in Joomla Gives Blank Page

Postby [email protected] » Wed Mar 23, 2011 12:57 pm

Hello Edvard,
I tried to config curl library...now I checked the apache_error.log and I found one line repeating every few seconds:

[Wed Mar 23 09:31:30 2011] [error] [client 66.249.66.147] PHP Notice: Undefined variable: protocol in C:\\wamp\\www\\eshop\\gtranslate\\translate.php on line 216

translate.php is not readeable for me, so I hope you can help me.

Error related to curl appeared last on March 17th:
[Thu Mar 17 14:32:35 2011] [error] [client 192.168.88.38] PHP Fatal error: Call to undefined function curl_init() in C:\\wamp\\www\\eshop\\gtranslate\\translate.php on line 64, referer: http://eshop.numizmatikamch.sk/

Could you please help me, what is this problem?

Thank you
[email protected]
 
Posts: 10
Joined: Thu Mar 17, 2011 7:08 pm

Re: GTranslate in Joomla Gives Blank Page

Postby Edvard » Wed Mar 23, 2011 9:20 pm

$protocol variable is defined before that line where it gives notice:
Code: Select all
$protocol = preg_match('/https/i', $_SERVER['SERVER_PROTOCOL']) ? 'https' : 'http';


Make sure that $_SERVER['SERVER_PROTOCOL'] variable is accessible.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4349
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate in Joomla Gives Blank Page

Postby [email protected] » Fri Mar 25, 2011 1:03 am

Thank you Edvard for your help. I talked with one friend of mine (web admin) and he tried to help me, but no success. He advised me to send you my php.ini. Could you please check it? I think there is something wrong (many things are disabled and I dont know what gtranslate needs to function correctly):
http://cl.ly/3W2L452o3S2c343o2v0q

Thank you very much
Andrej
[email protected]
 
Posts: 10
Joined: Thu Mar 17, 2011 7:08 pm

Re: GTranslate in Joomla Gives Blank Page

Postby Edvard » Fri Mar 25, 2011 12:41 pm

You can do this for now:

error_reporting = E_ALL & ~E_NOTICE ; will not log notices
instead of
error_reporting = E_ALL

in your php.ini
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4349
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate in Joomla Gives Blank Page

Postby [email protected] » Fri Mar 25, 2011 2:20 pm

OK, I changed it, but it seems that nothing happened. Still the same apache errors and every second appear new one (still the line 216 in translate.php). Should be something wrong in another file than php.ini?
[email protected]
 
Posts: 10
Joined: Thu Mar 17, 2011 7:08 pm

Re: GTranslate in Joomla Gives Blank Page

Postby Edvard » Fri Mar 25, 2011 2:37 pm

Make sure that you have restarted the server.

After you suppress notices the error log will not grow.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4349
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate in Joomla Gives Blank Page

Postby [email protected] » Tue Apr 05, 2011 11:48 pm

Hello Edvard,

errors are now ok, but translator still doesnt work. Have you some idea, what else could help? I use wampserver (apache) with default settings and I am worry that that's the problem. Is there some special setting in php.ini or somewhere else?

Thanks
[email protected]
 
Posts: 10
Joined: Thu Mar 17, 2011 7:08 pm

Re: GTranslate in Joomla Gives Blank Page

Postby Edvard » Wed Apr 06, 2011 12:11 am

Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4349
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: GTranslate in Joomla Gives Blank Page

Postby [email protected] » Wed Apr 06, 2011 12:46 am

Thank you, I found this problem in gtranslate/debug.txt:
"routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
* Closing connection #0

Response:
* About to connect() to www.googleapis.com port 443 (#0)
* Trying 74.125.77.95... * connected
* Connected to www.googleapis.com (74.125.77.95) port 443 (#0)
* SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL "

How can I solve this?

Thank you
Andrej
[email protected]
 
Posts: 10
Joined: Thu Mar 17, 2011 7:08 pm

Re: GTranslate in Joomla Gives Blank Page

Postby [email protected] » Wed Apr 06, 2011 12:49 am

I'm sorry, now I found next in the thread that I have to contact my hosting provider...I will try it, hope we can solve it.
[email protected]
 
Posts: 10
Joined: Thu Mar 17, 2011 7:08 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest

2GLux
cron