Highly increased load on website from 51.255.131.149

Popular automatic website translation tool

Highly increased load on website from 51.255.131.149

Postby Ant_Z » Wed Feb 20, 2019 12:29 am

Dear friends,
I'm using your engine for some years and everything worked fine for now.
For two weeks now i have Highly increased load on my website from this IP 51.255.131.149, which supposed to be connected to your translation engine.
It consumes now all resources of my hosting plan - site is down with errors 502, 503, etc. I haven't changed any settings of my website or htaccess or domain settings.

What has happened and what can i do to return everything to normal state? In order to have my site online i need to add this IP 51.255.131.149 to Blacklist - but it will stop translation engine.

№ IP Apache NGINX CPU, %
1 51.255.131.149 17624 20580 233,9642

Website https://baker-group.net/
Dedicated IP: 185.124.10.42

htaccess config:
Code: Select all
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ https://$1.baker-group.net/$2 [R=301,L,QSA]
# gtranslate config
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteRule ^(af|sq|am|ar|hy|az|eu|be|bn|bs|bg|ca|ceb|ny|zh-CN|zh-TW|co|hr|cs|da|nl|en|eo|et|tl|fi|fr|fy|gl|ka|de|el|gu|ht|ha|haw|iw|hi|hmn|hu|is|ig|id|ga|it|ja|jw|kn|kk|km|ko|ku|ky|lo|la|lv|lt|lb|mk|mg|ms|ml|mt|mi|mr|mn|my|ne|no|ps|fa|pl|pt|pa|ro|ru|sm|gd|sr|st|sn|sd|si|sk|sl|so|es|su|sw|sv|tg|ta|te|th|tr|uk|ur|uz|vi|cy|xh|yi|yo|zu)/(af|sq|am|ar|hy|az|eu|be|bn|bs|bg|ca|ceb|ny|zh-CN|zh-TW|co|hr|cs|da|nl|en|eo|et|tl|fi|fr|fy|gl|ka|de|el|gu|ht|ha|haw|iw|hi|hmn|hu|is|ig|id|ga|it|ja|jw|kn|kk|km|ko|ku|ky|lo|la|lv|lt|lb|mk|mg|ms|ml|mt|mi|mr|mn|my|ne|no|ps|fa|pl|pt|pa|ro|ru|sm|gd|sr|st|sn|sd|si|sk|sl|so|es|su|sw|sv|tg|ta|te|th|tr|uk|ur|uz|vi|cy|xh|yi|yo|zu)/(.*)$ /$1/$3 [R=301,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(af|sq|am|ar|hy|az|eu|be|bn|bs|bg|ca|ceb|ny|zh-CN|zh-TW|co|hr|cs|da|nl|en|eo|et|tl|fi|fr|fy|gl|ka|de|el|gu|ht|ha|haw|iw|hi|hmn|hu|is|ig|id|ga|it|ja|jw|kn|kk|km|ko|ku|ky|lo|la|lv|lt|lb|mk|mg|ms|ml|mt|mi|mr|mn|my|ne|no|ps|fa|pl|pt|pa|ro|ru|sm|gd|sr|st|sn|sd|si|sk|sl|so|es|su|sw|sv|tg|ta|te|th|tr|uk|ur|uz|vi|cy|xh|yi|yo|zu)/(.*)$ /gtranslate/gtranslate.php?glang=$1&gurl=$2 [L,QSA]
RewriteRule ^(af|sq|am|ar|hy|az|eu|be|bn|bs|bg|ca|ceb|ny|zh-CN|zh-TW|co|hr|cs|da|nl|en|eo|et|tl|fi|fr|fy|gl|ka|de|el|gu|ht|ha|haw|iw|hi|hmn|hu|is|ig|id|ga|it|ja|jw|kn|kk|km|ko|ku|ky|lo|la|lv|lt|lb|mk|mg|ms|ml|mt|mi|mr|mn|my|ne|no|ps|fa|pl|pt|pa|ro|ru|sm|gd|sr|st|sn|sd|si|sk|sl|so|es|su|sw|sv|tg|ta|te|th|tr|uk|ur|uz|vi|cy|xh|yi|yo|zu)$ /$1/ [R=301,L]
#RewriteRule ^(af|sq|am|ar|hy|az|eu|be|bn|bs|bg|ca|ceb|ny|zh-CN|zh-TW|co|hr|cs|da|nl|en|eo|et|tl|fi|fr|fy|gl|ka|de|el|gu|ht|ha|haw|iw|hi|hmn|hu|is|ig|id|ga|it|ja|jw|kn|kk|km|ko|ku|ky|lo|la|lv|lt|lb|mk|mg|ms|ml|mt|mi|mr|mn|my|ne|no|ps|fa|pl|pt|pa|ro|ru|sm|gd|sr|st|sn|sd|si|sk|sl|so|es|su|sw|sv|tg|ta|te|th|tr|uk|ur|uz|vi|cy|xh|yi|yo|zu)/(.*)$ https://$1.baker-group.net/$2 [R=301,L]


Look forward to see your answer.
Ant_Z
 
Posts: 11
Joined: Mon Oct 22, 2012 5:19 pm

Re: Highly increased load on website from 51.255.131.149

Postby Yana » Wed Feb 27, 2019 3:45 pm

Let me explain how GTranslate functions, so you can understand what is going on.

After you activate GTranslate on your website you will have more pages than before. For example if you enable 5 languages you will have 5 times more pages than before. Search engines and different bots will start to access the new pages for discovery, indexing or any other purposes.

When someone or something accesses a translated page we will need to have the original page content, to deliver the translated version, so we access your original page from our server, we also tell your server the real visitor IP address in X-Real-IP request header, so you can decide to let them in or not. To do this our server IP addresses must be white-listed always, so we can provide translations.

Having more pages will of course increase the server resources usage including traffic and CPU. However, you can decrease the usage of resources by enabling caching, which can be disabled by the following response headers by your website:

Cache-Control: no-cache
When you allow caching of your original pages, our server will store your original page on our server for some time, so we do not have to access your original page every time: it will reduce the resource usage dramatically. You can check how our caching system works, for more technical details:

How caching works in GTranslate network?

You can go even further and use sub-domains instead of sub-directories for translated pages, this will help you to save resources as well, since with sub-domains the request for translated version will be directed to our server and can be served without any access to your original server, while with sub-directories the request for translated version goes to your server initially then it is being re-routed to our server.

Having this you need to take the following steps to solve the issue:

White-list our IP address mentioned in your firewall block list
(optional) Enable caching to save resources
(optional) Use sub-domains instead of sub-directories
Please check and feel free to contact us if you have further questions.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4547
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests