(SOLVED)Main language English, every link reverts to Chinese

Popular automatic website translation tool

(SOLVED)Main language English, every link reverts to Chinese

Postby Ameson » Sat May 04, 2013 4:59 am

Using pro version, URL http://www.china.jobsafe.org

I have my site set with the main language as English. However, every time I go to my site and try to click a link, it automatically reverts to Chinese.

Settings in the plugin:
Detect main language: no
Detect user language: no
(toggling these settings to 'yes' has no effect)
Debug mode: none
Site language: English

Settings in module:
Operate with GTranslate Pro version: on
Translation method: redirect
Site language: English

EDIT: it seems that the issue has to do with my main menu. Clicking non-menu links (I am using Jreviews) seems to work fine.
Ameson
 
Posts: 5
Joined: Thu May 02, 2013 8:04 am

Re: (SOLVED)Main language English, every link reverts to Chi

Postby Ameson » Sat May 04, 2013 5:17 am

If anyone else has this problem, the solution is to make sure that all of your menu items are set to language 'ALL'.
Ameson
 
Posts: 5
Joined: Thu May 02, 2013 8:04 am

Re: (SOLVED)Main language English, every link reverts to Chi

Postby Yana » Sun May 05, 2013 12:37 am

Hi,
Thank you for the information.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux
cron