Not all URLs re-write and get a 404 when they do

Popular automatic website translation tool

Not all URLs re-write and get a 404 when they do

Postby [email protected] » Thu May 05, 2011 6:32 pm

Hi
I've just installed GTranslate pro on to my website I am having the problem that only some of the URLs on my (wordpress) site get re-written, and when they do, I get a 404.

I have gone through the trouble shooting guide, I have ioncube, curl and json the gtranslate folder is in public_html on my server - but still no luck.

I have disabled w3cache, just in case that was interfering + have stripped back my htaccess to the bare bones:
Code: Select all
Options +FollowSymLinks

# gtranslate config
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA]
</IfModule>
# gtranslate config

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
      
# Externally redirect the non www hostname to the www hostname
RewriteCond %{HTTP_HOST} ^lcd-enclosure\.com [NC]
RewriteRule (.*) http://www.lcd-enclosure.com/$1 [R=301,L]
#


Any help greatly appreciated

Thanks
Dave
[email protected]
 
Posts: 5
Joined: Thu May 05, 2011 6:07 pm

Re: Not all URLs re-write and get a 404 when they do

Postby [email protected] » Fri May 06, 2011 12:44 pm

I have also logged in to the translate api console - and it looks like there has been no requests made to the api which is maybe why the pages are empty- I have got a standard api key and have checked that it is correct in the config file - do I need an OAuth account too?
[email protected]
 
Posts: 5
Joined: Thu May 05, 2011 6:07 pm

Re: Not all URLs re-write and get a 404 when they do

Postby Edvard » Fri May 06, 2011 1:55 pm

Hi,

Not sure what you did, but seems that it works: http://www.lcd-enclosure.com/ru/ for Russian.

You just need to enable the language selector and configure appropriately to work with the Pro.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4348
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Not all URLs re-write and get a 404 when they do

Postby [email protected] » Fri May 06, 2011 2:26 pm

Hmmm - I'm not sure what I did either!! But it seems to be working fine now. Perhaps I made too many changes to htaccess too fast or there is some sort of lag writing the cached content to the server??

Thanks anyway!

Dave
[email protected]
 
Posts: 5
Joined: Thu May 05, 2011 6:07 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux
cron