[Solved] Pro version doesn't work and urls wrong

Popular automatic website translation tool

[Solved] Pro version doesn't work and urls wrong

Postby derekK » Mon Jul 04, 2011 11:57 pm

Hi, bought the pro version today. Installed on the server and followed all your instructions. The problem is that when I turn the free version (which works fine on the fly btw) to Pro and redirect, the urls generated are the wrong way round! As far as I can see it should read domain/blog/lang but when i have installed per your instructions in the root, it reads domain/lang/blog and there is no content (not surprisingly). I have been through troubleshooting and api code is correct etc. Does this actually work? So many people seem to be having a problem.

Like most blogs appended to 'proper' websites the blog is located at domain/blog/ . Is that the problem?

Thanks
derekK
 
Posts: 7
Joined: Mon Jul 04, 2011 11:49 pm

Re: Pro version doesn't work and urls wrong

Postby derekK » Tue Jul 05, 2011 7:08 pm

Is it possible to get the pro version to work so that it affects only the wordpress blog directory?

i.e domain/blog/language

It must not affect domain/x where x is any other directory. (domain/language/x) At present it will affect the whole site due to the changes you require made to the .htaccess file. This rewrites other directories outside of the blog with professionally translated material on and stops it working.

If this is not possible could we get a refund as this is not any use to us? No mention of changes to site wide .htaccess file was made prior to purchase. Perhaps you should make this clear to buyers in future or ,if it is possible, provide a help file which allows for people who have a website with a blog as a subdirectory. I saw another post from a person with the same problem but you just told him to install in the root.

Thank you
derekK
 
Posts: 7
Joined: Mon Jul 04, 2011 11:49 pm

Re: Pro version doesn't work and urls wrong

Postby derekK » Wed Jul 06, 2011 1:53 am

Edvard,

This is largely solved. I realised that we had a number of directories which had 2 letters like /js and of course these were being overwritten by the standard .htaccess. I fixed this with a RewriteCond statement for all the affected directories and it all seems to be working now.

Thanks
derekK
 
Posts: 7
Joined: Mon Jul 04, 2011 11:49 pm

Re: Pro version doesn't work and urls wrong

Postby Edvard » Thu Jul 07, 2011 2:45 pm

Good to hear that and sorry for my late response.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: [Solved] Pro version doesn't work and urls wrong

Postby derekK » Thu Jul 07, 2011 6:26 pm

Hi Edvard,

No problem, I learned a bit about mod_rewrite. :)

I solved the other problem of stopping the rest of the site adding the language folder prefix by adding another rule removing it from specific root files. i.e. rather than domain/fr/index.php it falls back to domain/index.php. This means the only directory that is affected by the translator is now blog/.

:?:
I wonder if there is a more elegant solution? Set a rule that includes just the blog directory (or any specific set of directories or files) explicitly rather than removing everything else as I am doing now. I couldn't find the correct syntax to make that work.

Thanks
Derek
Derek
derekK
 
Posts: 7
Joined: Mon Jul 04, 2011 11:49 pm

Re: [Solved] Pro version doesn't work and urls wrong

Postby Edvard » Fri Jul 08, 2011 11:23 pm

So you want to translate only blog? If the answer is yes, you can do this:

Code: Select all
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/blog/(.*)$ /gtranslate/translate.php?lang=$1&url=blog/$2 [L,QSA]


Or may be use RewriteCond
Code: Select all
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteCond %{REQUEST_URI} ^(.*)blog(.*)$
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA]
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: [Solved] Pro version doesn't work and urls wrong

Postby derekK » Sat Jul 09, 2011 3:48 am

Hi Edvard,

Thanks. That's great. I'll try that in the morning.

Much appreciated

Derek
derekK
 
Posts: 7
Joined: Mon Jul 04, 2011 11:49 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux
cron