Pro version installation problem

Popular automatic website translation tool

Pro version installation problem

Postby Seadog » Wed Aug 03, 2011 6:31 pm

Hi, I've been running the free version for a while and decided to upgrade to Pro. So I ordered and have installed but I cannot get it to work correctly.
If I change the module to operate using the Pro version and select a different language from the front end it just waits and waits until it eventually times out - I then cannot get the site to load in the browser until I clear the browser cache.
I have tried the french translation but nothing appears in the gtranslate\cache\fr folder. I have also set the debug on, it's created a debug.txt file but nothing is in it.
If you go to www.vecstar.com you'll see what I mean.
Shall I email you some FTP details and Joomla admin login for you to have a look?

Many thanks,
Kieron
Seadog
 
Posts: 18
Joined: Wed Aug 03, 2011 6:12 pm

Re: Pro version installation problem

Postby Seadog » Wed Aug 03, 2011 6:43 pm

Just a quick update - I've changed it to use the Bing Translate service and, while it's not working properly, it has started writing to the debug.txt file (below) and has created a few entries in the \fr folder - but it still just hangs. And when I open a different browser and select Italian nothing gets written to the \it folder....


* About to connect() to www.vecstar.com port 80 (#0)
* Trying 92.48.75.4... * connected
* Connected to www.vecstar.com (92.48.75.4) port 80 (#0)
> GET / HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.0; rv:5.0) Gecko/20100101 Firefox/5.0
Host: www.vecstar.com
Accept: */*
Cookie: PHPSESSID=3868756223ea611b319d9c17419a5047; 05bbd3c856677b7965e9aeb00dd87ec6=b2d885b151d0adef6d2cc13cd567fd3a; __utma=260632330.1913137423.1312381441.1312381441.1312381441.1; __utmb=260632330.1.10.1312381441; __utmc=260632330; __utmz=260632330.1312381441.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); JASLIDESHOWPLAY=play

< HTTP/1.1 500 Internal Server Error
< Date: Wed, 03 Aug 2011 14:19:18 GMT
< Server: Apache
< Content-Length: 660
< Connection: close
< Content-Type: text/html; charset=iso-8859-1
<
* Closing connection #0
* About to connect() to www.vecstar.com port 80 (#0)
* Trying 92.48.75.4... * connected
* Connected to www.vecstar.com (92.48.75.4) port 80 (#0)
> GET / HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.0; rv:5.0) Gecko/20100101 Firefox/5.0
Host: www.vecstar.com
Accept: */*
Cookie: PHPSESSID=3868756223ea611b319d9c17419a5047; 05bbd3c856677b7965e9aeb00dd87ec6=b2d885b151d0adef6d2cc13cd567fd3a; __utma=260632330.1913137423.1312381441.1312381441.1312381441.1; __utmb=260632330.1.10.1312381441; __utmc=260632330; __utmz=260632330.1312381441.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); JASLIDESHOWPLAY=play

< HTTP/1.1 200 OK
< Date: Wed, 03 Aug 2011 14:34:18 GMT
< Server: Apache
< P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
< Expires: Mon, 1 Jan 2001 00:00:00 GMT
< Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
< Pragma: no-cache
< Last-Modified: Wed, 03 Aug 2011 14:34:18 GMT
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=utf-8
<
* Connection #0 to host www.vecstar.com left intact
* Closing connection #0
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 383


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>English</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 221
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63641
Date: Wed, 03 Aug 2011 14:34:17 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>Anglais</TranslateResult></TranslateResponse></s:Body></s:Envelope>
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 396


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>Chinese (Simplified)</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 234
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63737
Date: Wed, 03 Aug 2011 14:34:17 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>Chinois (simplifié)</TranslateResult></TranslateResponse></s:Body></s:Envelope>
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 397


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>Chinese (Traditional)</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 236
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63641
Date: Wed, 03 Aug 2011 14:34:18 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>Chinois (traditionnel)</TranslateResult></TranslateResponse></s:Body></s:Envelope>
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 382


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>French</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 223
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63835
Date: Wed, 03 Aug 2011 14:34:17 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>Français</TranslateResult></TranslateResponse></s:Body></s:Envelope>
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 382


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>German</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 222
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63835
Date: Wed, 03 Aug 2011 14:34:18 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>Allemand</TranslateResult></TranslateResponse></s:Body></s:Envelope>
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 383


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>Italian</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 221
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63743
Date: Wed, 03 Aug 2011 14:34:18 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>Italien</TranslateResult></TranslateResponse></s:Body></s:Envelope>
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 386


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>Portuguese</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 223
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63644
Date: Wed, 03 Aug 2011 14:34:18 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>Portugais</TranslateResult></TranslateResponse></s:Body></s:Envelope>
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 383


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>Russian</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 219
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63641
Date: Wed, 03 Aug 2011 14:34:19 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>Russe</TranslateResult></TranslateResponse></s:Body></s:Envelope>
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 383


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>Spanish</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 222
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63737
Date: Wed, 03 Aug 2011 14:34:19 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>Espagnol</TranslateResult></TranslateResponse></s:Body></s:Envelope>
* About to connect() to www.vecstar.com port 80 (#0)
* Trying 92.48.75.4... * connected
* Connected to www.vecstar.com (92.48.75.4) port 80 (#0)
> GET /index.php HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.0; rv:5.0) Gecko/20100101 Firefox/5.0
Host: www.vecstar.com
Accept: */*
Cookie: PHPSESSID=d71dcce14e9bdfe3a1ca8a6528385735; 05bbd3c856677b7965e9aeb00dd87ec6=b7100d5cabd6e9442d73fd9a599f10b0; __utma=260632330.1047814745.1312381470.1312381470.1312381470.1; __utmb=260632330.1.10.1312381470; __utmc=260632330; __utmz=260632330.1312381470.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); JASLIDESHOWPLAY=play

< HTTP/1.1 500 Internal Server Error
< Date: Wed, 03 Aug 2011 14:19:48 GMT
< Server: Apache
< Content-Length: 660
< Connection: close
< Content-Type: text/html; charset=iso-8859-1
<
* Closing connection #0
* About to connect() to www.vecstar.com port 80 (#0)
* Trying 92.48.75.4... * connected
* Connected to www.vecstar.com (92.48.75.4) port 80 (#0)
> GET /index.php HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.0; rv:5.0) Gecko/20100101 Firefox/5.0
Host: www.vecstar.com
Accept: */*
Cookie: PHPSESSID=1e8744b505dd4e90ce6371e868f75441; 05bbd3c856677b7965e9aeb00dd87ec6=f3d9cb9ed22eca7d9c40571d0276eb66; __utma=260632330.1153123025.1312381510.1312381510.1312381510.1; __utmb=260632330.1.10.1312381510; __utmc=260632330; __utmz=260632330.1312381510.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); JASLIDESHOWPLAY=play

< HTTP/1.1 500 Internal Server Error
< Date: Wed, 03 Aug 2011 14:20:30 GMT
< Server: Apache
< Content-Length: 660
< Connection: close
< Content-Type: text/html; charset=iso-8859-1
<
* Closing connection #0
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 401


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>500 Internal Server Error</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 243
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63835
Date: Wed, 03 Aug 2011 14:35:30 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>Erreur de serveur interne 500</TranslateResult></TranslateResponse></s:Body></s:Envelope>
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 397


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>Internal Server Error</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 239
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63743
Date: Wed, 03 Aug 2011 14:35:30 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>Erreur de serveur interne</TranslateResult></TranslateResponse></s:Body></s:Envelope>
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 477


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 332
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63643
Date: Wed, 03 Aug 2011 14:35:30 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>Le serveur a rencontré une erreur interne ou une mauvaise configuration et était incapable de remplir votre demande.</TranslateResult></TranslateResponse></s:Body></s:Envelope>
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 552


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>Please contact the server administrator,
[email protected] and inform them of the time the error occurred,
and anything you might have done that may have
caused the error.</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 402
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63743
Date: Wed, 03 Aug 2011 14:35:32 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>Veuillez contacter l'administrateur du serveur, [email protected] et l'informer de l'époque l'erreur s'est produite et tout ce qui vous aurait pu faire que peut avoir causé l'erreur.</TranslateResult></TranslateResponse></s:Body></s:Envelope>
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 451


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>More information about this error may be available
in the server error log.</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 316
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63743
Date: Wed, 03 Aug 2011 14:35:33 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>Plus d'informations sur cette erreur peuvent être disponibles dans le journal des erreurs de serveur.</TranslateResult></TranslateResponse></s:Body></s:Envelope>
Request: POST /V2/soap.svc HTTP/1.1
Host: api.microsofttranslator.com
Connection: Keep-Alive
User-Agent: PHP-SOAP/5.2.9
Content-Type: text/xml; charset=utf-8
SOAPAction: "http://api.microsofttranslator.com/V2/LanguageService/Translate"
Content-Length: 487


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.microsofttranslator.com/V2"><SOAP-ENV:Body><ns1:Translate><ns1:appId>30C9E3F80984CEDDFB46A355406CF1713EAC5A17</ns1:appId><ns1:text>Additionally, a 404 Not Found
error was encountered while trying to use an ErrorDocument to handle the request.</ns1:text><ns1:from>en</ns1:from><ns1:to>fr</ns1:to></ns1:Translate></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response: HTTP/1.1 200 OK
Content-Length: 332
Content-Type: text/xml; charset=utf-8
X-MS-Trans-Info: s=63835
Date: Wed, 03 Aug 2011 14:35:34 GMT

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><TranslateResponse xmlns="http://api.microsofttranslator.com/V2"><TranslateResult>En outre, une erreur 404 introuvable a été rencontré en tentant d'utiliser un ErrorDocument pour gérer la demande.</TranslateResult></TranslateResponse></s:Body></s:Envelope>
* About to connect() to www.vecstar.com port 80 (#0)
* Trying 92.48.75.4... * connected
* Connected to www.vecstar.com (92.48.75.4) port 80 (#0)
> GET /index.php HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.0; rv:5.0) Gecko/20100101 Firefox/5.0
Host: www.vecstar.com
Accept: */*
Cookie: PHPSESSID=f253e1a38b323015604197fdd6a5ecec; 05bbd3c856677b7965e9aeb00dd87ec6=657c0369054f0f16ae868f790da61a25; __utma=260632330.81987647.1312381538.1312381538.1312381538.1; __utmb=260632330.3.10.1312381538; __utmc=260632330; __utmz=260632330.1312381538.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); JASLIDESHOWPLAY=play; googtrans=/en/pt; googtrans=/en/pt; glang=it

< HTTP/1.1 500 Internal Server Error
< Date: Wed, 03 Aug 2011 14:22:11 GMT
< Server: Apache
< Content-Length: 660
< Connection: close
< Content-Type: text/html; charset=iso-8859-1
<
* Closing connection #0
* About to connect() to www.vecstar.com port 80 (#0)
* Trying 92.48.75.4... * connected
* Connected to www.vecstar.com (92.48.75.4) port 80 (#0)
> GET /index.php HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.0; rv:5.0) Gecko/20100101 Firefox/5.0
Host: www.vecstar.com
Accept: */*
Cookie: PHPSESSID=6f6ef9f10ff6056f7182449f9416288c; 05bbd3c856677b7965e9aeb00dd87ec6=0810406d8f5396e36bcb414b2a46b80b; __utma=260632330.151343035.1312381655.1312381655.1312381655.1; __utmb=260632330.4.10.1312381655; __utmc=260632330; __utmz=260632330.1312381655.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); JASLIDESHOWPLAY=play; glang=en

< HTTP/1.1 500 Internal Server Error
< Date: Wed, 03 Aug 2011 14:23:57 GMT
< Server: Apache
< Content-Length: 660
< Connection: close
< Content-Type: text/html; charset=iso-8859-1
<
* Closing connection #0
Seadog
 
Posts: 18
Joined: Wed Aug 03, 2011 6:12 pm

Re: Pro version installation problem

Postby Edvard » Wed Aug 03, 2011 7:38 pm

Hi,

You need to show this debug log to your hosting company and ask the reason for "HTTP/1.1 500 Internal Server Error"...

When your server connects to the same server, it responds with 500 Server error. That is the reason you wait for a long time.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Pro version installation problem

Postby Seadog » Thu Aug 04, 2011 1:03 am

Hi Edvard, mentioned this to my host (Eukhost) who have sent this:

I checked a bit more into this and it actually gives the 500 error when the translational is complete and that is what is showing up in the logs. I kept the window open in firefox and I saw the 500 error http://www.vecstar.com/zh-TW/index.php . Are you sure the permissions are correct on the plugin folder ? Can you double check from joomla - system information that all permissions are correct on the joomla installation. Usually 500 errors with Joomla are for permissions not being proper.

Does that shed any light on the issue?

Thanks again,
Kieron
Seadog
 
Posts: 18
Joined: Wed Aug 03, 2011 6:12 pm

Re: Pro version installation problem

Postby Edvard » Thu Aug 04, 2011 2:17 pm

No, they are wrong. Here what you should ask:

I'm using PHP cURL on my vecstar.com to connect to the same server, but for some reason it gives me 500 Server Error. Please find my log below:

* About to connect() to www.vecstar.com port 80 (#0)
* Trying 92.48.75.4... * connected
* Connected to www.vecstar.com (92.48.75.4) port 80 (#0)
> GET /index.php HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.0; rv:5.0) Gecko/20100101 Firefox/5.0
Host: www.vecstar.com
Accept: */*
Cookie: PHPSESSID=6f6ef9f10ff6056f7182449f9416288c; 05bbd3c856677b7965e9aeb00dd87ec6=0810406d8f5396e36bcb414b2a46b80b; __utma=260632330.151343035.1312381655.1312381655.1312381655.1; __utmb=260632330.4.10.1312381655; __utmc=260632330; __utmz=260632330.1312381655.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); JASLIDESHOWPLAY=play; glang=en

< HTTP/1.1 500 Internal Server Error
< Date: Wed, 03 Aug 2011 14:23:57 GMT
< Server: Apache
< Content-Length: 660
< Connection: close
< Content-Type: text/html; charset=iso-8859-1
<
* Closing connection #0
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Pro version installation problem

Postby Seadog » Thu Aug 04, 2011 2:51 pm

Thanks again Edvald - have sent that to the hosting company. It's nothing to do with it trying to write back to www.vecstar.com rather then vecstar.com is it?
Seadog
 
Posts: 18
Joined: Wed Aug 03, 2011 6:12 pm

Re: Pro version installation problem

Postby Edvard » Thu Aug 04, 2011 2:54 pm

www.vecstar.com and vecstar.com are identical.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Pro version installation problem

Postby Seadog » Fri Aug 05, 2011 2:15 am

I know - just a stab in the dark (wasn't sure if you'd licensed it to vecstar.com but the request was www....).
Anyway, it's still not working correctly but there are quite a few 200 Success messages (ironically translations of the errors):

* About to connect() to www.googleapis.com port 443 (#0)
* Trying 74.125.77.95... * connected
* Connected to www.googleapis.com (74.125.77.95) port 443 (#0)
* successfully set certificate verify locations:
* CAfile: /etc/pki/tls/certs/ca-bundle.crt
CApath: none
* SSL connection using RC4-SHA
* Server certificate:
* subject: C=US; ST=California; L=Mountain View; O=Google Inc; CN=*.googleapis.com
* start date: 2011-07-27 10:12:08 GMT
* expire date: 2012-07-27 10:22:08 GMT
* subjectAltName: www.googleapis.com matched
* issuer: C=US; O=Google Inc; CN=Google Internet Authority
* SSL certificate verify ok.
> POST /language/translate/v2 HTTP/1.1
Host: www.googleapis.com
Accept: */*
X-HTTP-Method-Override: GET
Content-Length: 107
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 200 OK
< Cache-Control: no-cache, no-store, max-age=0, must-revalidate
< Pragma: no-cache
< Expires: Fri, 01 Jan 1990 00:00:00 GMT
< Date: Thu, 04 Aug 2011 19:37:00 GMT
< ETag: "UKKx3QYmJHPmWR1jVp-MkNwHPYc/Zi_WAovacz5FF3tGpBrbGX5z4mI"
< Content-Type: application/json; charset=UTF-8
< X-Content-Type-Options: nosniff
< X-Frame-Options: SAMEORIGIN
< X-XSS-Protection: 1; mode=block
< Server: GSE
< Transfer-Encoding: chunked
<
* Connection #0 to host www.googleapis.com left intact
* Closing connection #0
Request: key=AIzaSyAB4GfFQmAb7km2XXkzV9HfoGVjvVX3PYU&q=Internal+Server+Error&userip=46.208.72.81&source=en&target=it

Response: {
"data": {
"translations": [
{
"translatedText": "Errore del server interno"
}
]
}
}

* About to connect() to www.googleapis.com port 443 (#0)
* Trying 74.125.77.95... * connected
* Connected to www.googleapis.com (74.125.77.95) port 443 (#0)
* successfully set certificate verify locations:
* CAfile: /etc/pki/tls/certs/ca-bundle.crt
CApath: none
* SSL connection using RC4-SHA
* Server certificate:
* subject: C=US; ST=California; L=Mountain View; O=Google Inc; CN=*.googleapis.com
* start date: 2011-07-27 10:12:08 GMT
* expire date: 2012-07-27 10:22:08 GMT
* subjectAltName: www.googleapis.com matched
* issuer: C=US; O=Google Inc; CN=Google Internet Authority
* SSL certificate verify ok.
> POST /language/translate/v2 HTTP/1.1
Host: www.googleapis.com
Accept: */*
X-HTTP-Method-Override: GET
Content-Length: 191
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 200 OK
< Cache-Control: no-cache, no-store, max-age=0, must-revalidate
< Pragma: no-cache
< Expires: Fri, 01 Jan 1990 00:00:00 GMT
< Date: Thu, 04 Aug 2011 19:37:00 GMT
< ETag: "UKKx3QYmJHPmWR1jVp-MkNwHPYc/2auzDOEvTOZUi5v3B2OGNEs3-pY"
< Content-Type: application/json; charset=UTF-8
< X-Content-Type-Options: nosniff
< X-Frame-Options: SAMEORIGIN
< X-XSS-Protection: 1; mode=block
< Server: GSE
< Transfer-Encoding: chunked
<
* Connection #0 to host www.googleapis.com left intact
* Closing connection #0
Request: key=AIzaSyAB4GfFQmAb7km2XXkzV9HfoGVjvVX3PYU&q=The+server+encountered+an+internal+error+or%0Amisconfiguration+and+was+unable+to+complete%0Ayour+request.&userip=46.208.72.81&source=en&target=it

Response: {
"data": {
"translations": [
{
"translatedText": "Il server ha rilevato un errore interno o di errori di configurazione e non è riuscito a completare la richiesta."
}
]
}
}
Seadog
 
Posts: 18
Joined: Wed Aug 03, 2011 6:12 pm

Re: Pro version installation problem

Postby Seadog » Fri Aug 05, 2011 2:27 am

I set the follow location option to true in the config.php and it still times out but gives this message:

Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /home/vecstar/public_html/gtranslate/translate.php on line 70
Seadog
 
Posts: 18
Joined: Wed Aug 03, 2011 6:12 pm

Re: Pro version installation problem

Postby Seadog » Fri Aug 05, 2011 2:33 am

I've set the follow location back to false and set the ssl verify peer to false...I've actually now got a translated page: http://vecstar.com/fr/installation-services.html but it's still timing out when I try a different page or language.
Seadog
 
Posts: 18
Joined: Wed Aug 03, 2011 6:12 pm

Re: Pro version installation problem

Postby Edvard » Fri Aug 05, 2011 3:10 pm

Yes, I was able to see it too, so it is definitely not a translator problem. What the support said about the issue?
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Pro version installation problem

Postby Seadog » Fri Aug 05, 2011 6:40 pm

They're still looking into it Advard - will let you know what they say.

Thanks,
Kieron
Seadog
 
Posts: 18
Joined: Wed Aug 03, 2011 6:12 pm

Re: Pro version installation problem

Postby Seadog » Mon Aug 08, 2011 12:23 am

had a reply from them, not sure it helps though:

"I have checked logs under debug.txt its very difficult for us to tell you the exact reason for it.
The script is taking too long to run and that might be the reason why you are getting those 500 errors."
Seadog
 
Posts: 18
Joined: Wed Aug 03, 2011 6:12 pm

Re: Pro version installation problem

Postby Edvard » Wed Aug 10, 2011 1:38 am

Well they actually don't need to look into debug.txt file. They need to create a sample script which uses cURL to get contents from the same server. Here is an example:

Code: Select all
<?php
$ch = curl_init();
curl_setopt($ch, CURLOPT_URL, "http://vecstar.com/");
curl_setopt($ch, CURLOPT_HEADER, false);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
$result = curl_exec($ch);
curl_close($ch);

echo $result;
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Pro version installation problem

Postby Seadog » Wed Aug 10, 2011 1:36 pm

Hi Edvard,

I've created that script: http://www.vecstar.com/curltest.php which returns back the main page, is this supposed to happen?

Thanks,
Kieron
Seadog
 
Posts: 18
Joined: Wed Aug 03, 2011 6:12 pm

Re: Pro version installation problem

Postby Seadog » Wed Aug 10, 2011 2:01 pm

Don't know if this sheds any more light, but just noticed an error_log in the gtranslate folder with the following listed 4 times :

[04-Aug-2011 23:17:55] PHP Warning: curl_setopt() [<a href='function.curl-setopt'>function.curl-setopt</a>]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /home/vecstar/public_html/gtranslate/translate.php on line 70
Seadog
 
Posts: 18
Joined: Wed Aug 03, 2011 6:12 pm

Re: Pro version installation problem

Postby Edvard » Wed Aug 10, 2011 8:57 pm

You need to deactivate Follow Location from gtranslate/config.php in that case.

Can you try this one with some more options?

Code: Select all
<?php
$ch = curl_init();
curl_setopt($ch, CURLOPT_URL, "http://vecstar.com/");
curl_setopt($ch, CURLOPT_COOKIE, $_SERVER['HTTP_COOKIE']);
curl_setopt($ch, CURLOPT_USERAGENT, $_SERVER['HTTP_USER_AGENT']);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
$result = curl_exec($ch);
curl_close($ch);

echo $result;


You should see the home page if it is OK.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Pro version installation problem

Postby Seadog » Thu Aug 11, 2011 11:41 am

Thanks Edvald, follow location is already set to false.

Created the new curl test file and uploaded - this version seems to time out...http://www.vecstar.com/curl_test_2.php

Thanks,
Kieron
Seadog
 
Posts: 18
Joined: Wed Aug 03, 2011 6:12 pm

Re: Pro version installation problem

Postby Seadog » Thu Aug 11, 2011 12:22 pm

Just carried out some more testing, it seems it's the curl_setopt($ch, CURLOPT_COOKIE, $_SERVER['HTTP_COOKIE']); command that's causing the problem (which makes sense as once the server's returned a 500 error I cannot access from my browser until I delete the cookies.

Thanks,
Kieron
Seadog
 
Posts: 18
Joined: Wed Aug 03, 2011 6:12 pm

Re: Pro version installation problem

Postby Seadog » Thu Aug 11, 2011 11:15 pm

Hi Edvard, just had a reply from my hosts:


Dear Kieron

I have created the same script on server with following code in it and its working fine.
----------------
curl_setopt($ch, CURLOPT_COOKIE, $_SERVER['HTTP_COOKIE']);
----------------
You can verify it with the header information at http://www.vecstar.com/curl_test_4.php

Does this help? I need to get this sorted asap as my customer's concerned that visitors are getting timeouts.

Thanks,
Kieron
Seadog
 
Posts: 18
Joined: Wed Aug 03, 2011 6:12 pm

Next

  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux