problem in Pro installation

Popular automatic website translation tool

problem in Pro installation

Postby amir00251 » Wed Sep 07, 2011 5:16 am

Hello,

I have isntalled the Pro version and I get error when I choose a language and blank page:

Not Found

The requested URL /af/chelmsford/index.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.



The reason maybe as follows:

I Intend to have multiple sites on the same domain, current I work on development site

domain.com/chelmsford

and domina.com is empty.

When I was asked to give the domain, I just gave it as domain.com but as I mentioned my site is on domain.com/chelmsford.

I have followed all steps:

I have gtranslate foler under public_html and have followed all the steps, most probably right.

When I click on a language, in my address bar I get

http://www.domin.com/af/chelmsford/index.php

which looks wrong! What I am doing wrong? Also later on when I had multisites under same domain and with domain directories, say

domain.com/xxx
domain.com/uuu

can I set for language to be placed in the subdomain of the each site something like

en.domain.com/xxx
ar.domain.com/xxx
...
en.domain.com/uuu
....
amir00251
 
Posts: 9
Joined: Wed Sep 07, 2011 5:08 am

Re: problem in Pro installation

Postby Edvard » Wed Sep 07, 2011 2:53 pm

Hi,

Did you create/modify .htaccess file in your public_html folder or just inside your sub-folder? As mentioned in the readme you need to install it in www root (public_html) and don't change anything in your other sub-folders...

The subdomain language feature is not available yet.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: problem in Pro installation

Postby amir00251 » Wed Sep 07, 2011 4:36 pm

Hello Thanks for reply.

I now get

Internal server error

The server encountered an internal error....
Please contact the server administrator....
More information about .....
Additionally, a 500 Internal Server Error was ecountered while trying to use an ErrorDocument to handle the request


I have to say I do not have any .htaccess file in my public_folder at all. What I did I copied the same .htaccess file from subfolder into public_folder. The requested code has been added to that file.

On the multisite issue, can I use Pro version with multisites, having somthig like

domain.com/xxx/ar
domain.com/xxx/ar
...
domain.com/uuu/ar
....

Is there anything I should do apart from installing Gtranslate on all Joomla websites?
amir00251
 
Posts: 9
Joined: Wed Sep 07, 2011 5:08 am

Re: problem in Pro installation

Postby Edvard » Fri Sep 09, 2011 12:54 am

You don't need to copy the file from the sub-folder. You need to create a new one:

Code: Select all
RewriteEngine On
# gtranslate config
...
...
...
...
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: problem in Pro installation

Postby amir00251 » Fri Sep 09, 2011 4:23 am

Hello,

I did make changes but I still got the URL wrong with white page.

As I had explained before, my joomla site is installed at

public_folder/domain.com/chelmsford

What I did I copied both Gtranslate folder and .htaccess file from public_folder to public_folder/domain.com

After doing this, I now get right URL but problem is that the page is not translated and stays in original language.

I read the troubleshooting section and created a debug file, I will send this file by email so that you could check. I think the API is right and I have not exceeded the daily limit.
amir00251
 
Posts: 9
Joined: Wed Sep 07, 2011 5:08 am

Re: problem in Pro installation

Postby Edvard » Mon Sep 12, 2011 7:52 pm

OK, when you go to http://domain.com/es/chelmsford for Spanish do you see the original version of your site?

Can you check the source code of that page and see if you can find GTranslate signature in the end of the HTML code?

If you see it then enable the debug mode in the config.php file and delete limit.txt file from the gtranslate/cache folder and refresh the same page.

After that post the debug.txt file here.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: problem in Pro installation

Postby amir00251 » Mon Sep 12, 2011 9:56 pm

Hello,

Yes I did found the signature and below is the debug.txt


* About to connect() to http://www.domain.com port 80 (#0)
* Trying 69.175.72.218... * connected
* Connected to http://www.domain.com (69.175.72.218) port 80 (#0)
> GET /chelmsford/index.php HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Host: http://www.domain.com
Accept: */*
Cookie: 8a16fead0f4c45d9de445a83e08c62ce=019a9f79628dc08e9c8194fa6b4b03a8; jpanesliders_panel-sliders=0; jpanesliders_position-icon=0; ja_portfolio_tpl=ja_portfolio; trcusr=193; cltid=873; js_vsid=914; jpanetabs_content-pane=0; jpanetabs_config-tabs-com_akeeba_configuration=0; jpanesliders_permissions-sliderscom_akeeba=0; jpanetabs_config-tabs-com_jevlocations_configuration=0; jpanesliders_permissions-sliderscom_jevlocations=0; jpanetabs_jevent=0; jpanesliders_plugin-sliders-10308=0; jpanesliders_plugin-sliders-10185=0; febc4e8c91f4f9be8f36c60195a23020=a0fe248fbaaa5613f1eb734621af688b

< HTTP/1.1 200 OK
< Date: Mon, 12 Sep 2011 17:54:01 GMT
< Server: Apache
< X-Powered-By: PHP/5.2.17
< P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
< Expires:
< Cache-Control: no-cache
< Pragma: no-cache
< Set-Cookie: cltid=873; expires=Tue, 19-Jan-2038 03:14:07 GMT; path=/
< Set-Cookie: js_vsid=914; expires=Mon, 12-Sep-2011 21:54:02 GMT; path=/
< Set-Cookie: referrerid=4E30339CD5AD9; expires=Wed, 12-Oct-2011 17:54:03 GMT
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=utf-8
<
* Connection #0 to host http://www.domain.com left intact
* Closing connection #0
* About to connect() to http://www.googleapis.com port 443 (#0)
* Trying 209.85.225.95... * connected
* Connected to http://www.googleapis.com (209.85.225.95) port 443 (#0)
* successfully set certificate verify locations:
* CAfile: /etc/pki/tls/certs/ca-bundle.crt
CApath: none
* SSL connection using RC4-SHA
* Server certificate:
* subject: C=US; ST=California; L=Mountain View; O=Google Inc; CN=*.googleapis.com
* start date: 2011-08-12 03:49:13 GMT
* expire date: 2012-08-12 03:59:13 GMT
* subjectAltName: http://www.googleapis.com matched
* issuer: C=US; O=Google Inc; CN=Google Internet Authority
* SSL certificate verify ok.
> POST /language/translate/v2 HTTP/1.1
Host: http://www.googleapis.com
Accept: */*
X-HTTP-Method-Override: GET
Content-Length: 133
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 403 Forbidden
< Content-Type: application/json; charset=UTF-8
< Date: Mon, 12 Sep 2011 17:54:04 GMT
< Expires: Mon, 12 Sep 2011 17:54:04 GMT
< Cache-Control: private, max-age=0
< X-Content-Type-Options: nosniff
< X-Frame-Options: SAMEORIGIN
< X-XSS-Protection: 1; mode=block
< Server: GSE
< Transfer-Encoding: chunked
<
* Connection #0 to host http://www.googleapis.com left intact
* Closing connection #0
Request: key=AIzaSyC5M9YXbrtdb6CpA-ur3pnvjXZkFH_ib3M&q=Domain+Chelmsford%2C+Latest+Activity+and+Points&userip=82.45.85.54&source=en&target=es

Response: {
"error": {
"errors": [
{
"domain": "usageLimits",
"reason": "dailyLimitExceeded",
"message": "Daily Limit Exceeded"
}
],
"code": 403,
"message": "Daily Limit Exceeded"
}
}


my site is a development site and I am sure there is not daily limit exceed unless whole site is more than daily limit ?!
amir00251
 
Posts: 9
Joined: Wed Sep 07, 2011 5:08 am

Re: problem in Pro installation

Postby Edvard » Tue Sep 13, 2011 4:40 pm

You can check your API key usage on https://code.google.com/apis/console/

If you see that it doesn't give you daily 100.000 translation limit. Then you can switch to Bing. You can find how to do that from config.php file.

If you want to use Google without API, you can use this rewrite rules instead:

Code: Select all
# gtranslate config
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2&force_no_api=1 [L,QSA]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1&force_no_api=1 [L,QSA]
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: problem in Pro installation

Postby amir00251 » Wed Sep 14, 2011 5:07 pm

Hi, Is there a legal problem if someone not uses Google API.

This is working good in my site.
amir00251
 
Posts: 9
Joined: Wed Sep 07, 2011 5:08 am

Re: problem in Pro installation

Postby amir00251 » Sat Sep 24, 2011 3:02 am

Hello, apart from not yet getting a reply on legality of not using Google API,

I have discovered that in CB registration page, when I use Gtranslate, I get a blank page. The URL is right and so far it only happens in this page. Any why this is? I turned the debug on but have not been able to find an error, even in error log file.

I get below in Debug.txt for that specific page:


* About to connect() to www.domain.com port 80 (#0)
* Trying 69.175.72.218... * connected
* Connected to www.domain.com (69.175.72.218) port 80 (#0)
> GET /chelmsford/community/community/events/day.listevents/2011/10/29/137?force_no_api=1 HTTP/1.1
User-Agent: Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)
Host: www.domain.com
Accept: */*
Cookie:

< HTTP/1.1 200 OK
< Date: Sat, 24 Sep 2011 10:36:13 GMT
< Server: Apache
< X-Powered-By: PHP/5.2.17
< P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
< Expires:
< Cache-Control: no-cache
< Pragma: no-cache
< Set-Cookie: 12127e2d52245fb5befa72e2056c5632=a2e5f78c60eeb6781460c31023002341; path=/
< Set-Cookie: ja_portfolio_tpl=ja_portfolio; expires=Thu, 13-Sep-2012 10:36:14 GMT; path=/
< Set-Cookie: trcusr=%24%24; expires=Tue, 19-Jan-2038 03:14:07 GMT; path=/
< Set-Cookie: cltid=867; expires=Tue, 19-Jan-2038 03:14:07 GMT; path=/
< Set-Cookie: js_vsid=920; expires=Sat, 24-Sep-2011 18:36:14 GMT; path=/
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=utf-8
<
* Connection #0 to host www.domain.com left intact
* Closing connection #0
* About to connect() to translate.google.com port 80 (#0)
* Trying 74.125.225.43... * connected
* Connected to translate.google.com (74.125.225.43) port 80 (#0)
> GET /translate_a/t?client=a&text=Saturday%2C+29+October+2011&tl=id&sl=en HTTP/1.1
User-Agent: Mozilla/5.0
Host: translate.google.com
Accept: */*

< HTTP/1.1 200 OK
< Date: Sat, 24 Sep 2011 10:36:15 GMT
< Expires: Sat, 24 Sep 2011 10:36:15 GMT
< Cache-Control: private, max-age=600
< Pragma: no-cache
< Content-Type: text/javascript; charset=UTF-8
< Content-Language: id
< Set-Cookie: PREF=ID=1561e4a98a5ce0ab:TM=1316860575:LM=1316860575:S=dlWT2T_f8G3DwrcO; expires=Mon, 23-Sep-2013 10:36:15 GMT; path=/; domain=.google.com
< X-Content-Type-Options: nosniff
< Content-Disposition: attachment
< Server: HTTP server (unknown)
< X-XSS-Protection: 1; mode=block
< Transfer-Encoding: chunked
<
* Connection #0 to host translate.google.com left intact
* Closing connection #0
Request: client=a&text=Saturday%2C+29+October+2011&tl=id&sl=en

Response: {"sentences":[{"trans":"Sabtu, 29 Oktober, 2011","orig":"Saturday, 29 October 2011","translit":"","src_translit":""}],"src":"en","server_time":43}
* About to connect() to www.domain.com port 80 (#0)
* Trying 69.175.72.218... * connected
* Connected to www.domain.com (69.175.72.218) port 80 (#0)
> GET /chelmsford/component/comprofiler/registers?force_no_api=1 HTTP/1.1
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Host: www.domain.com
Accept: */*
Cookie: ja_portfolio_tpl=ja_portfolio; trcusr=194; cltid=881; 127594b952c9605e46d778435227d5a0=cd704473d2401d30a3910c80bb2c9493; jpanesliders_panel-sliders=0; jpanesliders_position-icon=0; js_vsid=1006; 12127e2d52245fb5befa72e2056c5632=de01b8ee49d907c7dfd8ead8db52faa8

< HTTP/1.1 303 See other
< Date: Sat, 24 Sep 2011 10:36:23 GMT
< Server: Apache
< X-Powered-By: PHP/5.2.17
< Location: http://www.domain.com/chelmsford/index. ... =subscribe
< Content-Length: 0
< Content-Type: text/html; charset=utf-8
<
* Connection #0 to host www.domain.com left intact
* Closing connection #0
amir00251
 
Posts: 9
Joined: Wed Sep 07, 2011 5:08 am

Re: problem in Pro installation

Postby Edvard » Sun Sep 25, 2011 2:30 pm

Hi, Is there a legal problem if someone not uses Google API.

There is no such experience.

You can try to enable follow location option in gtranslate/config.php and it will be fixed.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest

2GLux
cron