Problem user password editing with gtranslate pro

Popular automatic website translation tool

Problem user password editing with gtranslate pro

Postby autogest » Thu May 09, 2013 4:22 pm

Hello.
I installed the pro version in joomla with the 'general' installation. When I try to edit some text, I can not access the username and password which I have set in config.php.

Thanks.
autogest
 
Posts: 5
Joined: Thu May 09, 2013 4:14 pm

Re: Problem user password editing with gtranslate pro

Postby Yana » Thu May 09, 2013 7:28 pm

Hi,
Please read this post post4644.html?hilit=http_authorization#p4644
Also you can try to install the system plugin version. If you have a problem with the installation I can install it for you.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm

Re: Problem user password editing with gtranslate pro

Postby autogest » Fri May 10, 2013 4:14 pm

Hi Yana.
I made ​​the changes and still not working.
I have Joomla installed in a subdirectory (mydomain.com/folder).
I moved .htaccess and robots.txt the joomla folder to the root folder.
I created the file sitemap.txt.
Are these files correct?

http://www.bio-purh2o.com/files/configphp.txt (/gtranslate/config.php)
http://www.bio-purh2o.com/files/edit_translationphp.txt (/gtranslate/edit_translation.php)
http://www.bio-purh2o.com/files/htaccess.txt (/.htaccess)
http://www.bio-purh2o.com/files/robots.txt (/robots.txt)
http://www.bio-purh2o.com/files/sitemap.txt (/sitemap.txt)

Thanks.
A greating.
autogest
 
Posts: 5
Joined: Thu May 09, 2013 4:14 pm

Re: Problem user password editing with gtranslate pro

Postby autogest » Fri May 10, 2013 8:26 pm

if install the plugin, work perfectly, but the url correct is domain/folder/en/article and de flags and menu buttons are domain/en/folder/article
autogest
 
Posts: 5
Joined: Thu May 09, 2013 4:14 pm

Re: Problem user password editing with gtranslate pro

Postby Yana » Mon May 13, 2013 1:59 am

Hi,
If your website is in the subfolder you need to use general version. I checked edit_translation. It is correct.
It seems that your server doesn't populate $_SERVER['PHP_AUTH_USER'] variable. Please contact your hosting provider and ask them to fix the issue.
http://php.net/manual/en/features.http-auth.php

Also you can try to add this line in your .htaccess file
SetEnvIfNoCase Authorization "Basic ([a-z0-9=]+)" REDIRECT_REMOTE_AUTHORIZATION=$1
As a temporary solution you can modify the php code (gtranslate/edit_translation.php file) and disable authentication while editing.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux
cron