Problem with automatic language change

Popular automatic website translation tool

Problem with automatic language change

Postby Nikolas » Sat Nov 17, 2012 12:52 pm

Hello

I have the following problem.
I have two languages on my site but I have some problems.
For instance my default language is swedish I choose to translate the content to english and everything turn to english which is good. When I choose to turn the language to swedish again the content remains english.
Sometimes when I visit the different sections in default swedish language the language turns automatically to english without any action from me.

Why does this happen? Is there any solution to this?


Thanks in advance

/Nikolas
Nikolas
 
Posts: 41
Joined: Tue Dec 06, 2011 1:04 am

Re: Problem with automatic language change

Postby Yana » Sun Nov 18, 2012 2:01 am

Hi,
If you have enabled joomla cache try to disable it.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4133
Joined: Thu Jan 12, 2012 6:21 pm

Re: Problem with automatic language change

Postby Nikolas » Wed Dec 19, 2012 1:01 am

Hi Yana

I love this plugin so much but although I disabled joomla system cache and I don't have any 3rd cache the problem still exists.

example:
http://www.mysite.se/sv/en

My default language is Swedish , then I choose English to see the content in English
If I decide to turn back to swedish language nothing happens. The language stays in english and regardless of how many times I push the swedish flag nothing happens.

The plugin is wonderful but there must be a solution for everyone with this specific problem.


Regards

Nikolas
Nikolas
 
Posts: 41
Joined: Tue Dec 06, 2011 1:04 am

Re: Problem with automatic language change

Postby Nikolas » Wed Dec 19, 2012 9:10 pm

I read somewhere in the forum about this:

To put this in htaccess . Should I try this ? Can this be the solution to the problem?

RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
Nikolas
 
Posts: 41
Joined: Tue Dec 06, 2011 1:04 am

Re: Problem with automatic language change

Postby Yana » Wed Dec 19, 2012 11:25 pm

Hi,
Have you installed the "language filter" and "language code" plugins? If yes, please disable. There is a conflict with gtranslate pro and "language filter" , "language code" plugins .
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4133
Joined: Thu Jan 12, 2012 6:21 pm

Re: Problem with automatic language change

Postby Nikolas » Thu Dec 20, 2012 12:21 am

Hi,

Ok thanks I will try and find out. I think these options are enabled so I will disable them at once. Thank you for your support :).

Regards
Nikolas
 
Posts: 41
Joined: Tue Dec 06, 2011 1:04 am

Re: Problem with automatic language change

Postby Yana » Thu Dec 20, 2012 1:27 am

Hi,
Please let me know if the problem persists.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4133
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux