Problem with installation GtraslatePro

Popular automatic website translation tool

Problem with installation GtraslatePro

Postby chat4dream » Tue Mar 01, 2011 9:24 pm

hi, i have buy gtranslate pro but i have 3 problem:

1) Edit /gtranslate/config.php file to add your API key and username/password need for editing translations

this is my file config.php

<?php
define('API_KEY', 'https://www.googleapis.com/language/translate/v2?key=........lYtMlCzwT2C_k8oYZ_jeq5wgeYap_g&q=flowers&source=en&target=fr&callback=handleResponse'); // You need to get your Google Translate API key from https://code.google.com/apis/console/?api=translate
define('MAIN_LANG', 'en'); // en, ar, bg, hr, cn, ct, cs, da, et, tl, fi, fr, gl, el, iw, hi, es, nl, id, ja, ca, ko, lt, lv, mt, de, no, pt, ru, ro, sr, sk, sl, sv, th, tr, uk, hu, vi, it, pl, sq
define('CACHE_TIME', 365*24*60*60); // 1 year
define('LICENSE', 'license.dat');

// username and password to edit translations, please change for security reasons
define('USER', 'user');
define('PASS', 'pass');

what user and pass i must use? i must use the user and pass for found the api google or write the user and pass of administrator web site? I have to invent or devise the user is that the pass?
I misspelled the Google API in the right place?


2) I put the permissions to 777 but if I go in
http://www.chat4dream.com/gtranslate/config.php or other file always gives me 500 internal server error why?!


3) it's correct my .htaccess?

##
# @version $Id: htaccess.txt 13415 2009-11-03 15:53:25Z ian $
# @package Joomla
# @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


#####################################################
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

## Can be commented out if causes errors, see notes above.
# Options +FollowSymLinks

#
# mod_rewrite in use

RewriteEngine On
# gtranslate config
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA]

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
## Deny access to extension xml files (uncomment out to activate)
#<Files ~ "\.xml$">
#Order allow,deny
#Deny from all
#Satisfy all
#</Files>
## End of deny access to extension xml files
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section
chat4dream
 
Posts: 1
Joined: Tue Mar 01, 2011 9:05 pm

Re: Problem with installation GtraslatePro

Postby Edvard » Wed Mar 02, 2011 1:44 pm

Hi,

Your API key is not an URL: https://www.googleapis.com/language/tra ... leResponse

it is ........lYtMlCzwT2C_k8oYZ_jeq5wgeYap_g

Please fix that in the config.php.

You need to think a username and password for your own, nobody else should know them. You will use it when manually editing the translations.

Also, you shouldn't change the permissions for the files. Only folder permissions should be changed.
That is the reason you get 500 server error.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4179
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux
cron