Problem with login after installing Gt Pro

Popular automatic website translation tool

Problem with login after installing Gt Pro

Postby trotsak » Tue Mar 20, 2012 5:16 am

Debug - http://goo.gl/fHZJB

Drupal 7, http://pen4pals.com/

When I uncomment

#RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
#RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA]
#RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA]

and checked "Redirect" in gtranslate - I cannot correct logout and then I cannot login.

When I try login I get error 301 (Moved)

Now I try uncomment "RewriteRule.." checked Pro and Redirect, when I choose language I get same page.
In error log I get "Warning: Invalid argument supplied for foreach() in form_type_checkboxes_value() (line 2251 of /home/interper/public_html/PEN4PALS.COM/includes/form.inc)."

Site is living so I have no many opportunity for test your application for users cannot login to site.
trotsak
 
Posts: 51
Joined: Tue Mar 20, 2012 5:08 am

Re: Problem with login after installing Gt Pro

Postby Yana » Tue Mar 20, 2012 3:42 pm

Hi,
The plugin installed.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: Problem with login after installing Gt Pro

Postby trotsak » Tue Mar 20, 2012 5:40 pm

o, Yana, it's better. Write me what have you done in details for I have know all things doing with my site.

1. But not all languages works - arabic - no arabic letters (instead english letter reverse), dont translate az, basque, ga, tl, yi and etc. example http://pen4pals.com/tl

2.Also dont translate main content: "Dear Visitor, We are glad to say to you "Hi!" at our pen4pals language exchange service!....", http://pen4pals.com/be/en/content/happy ... ay-everett "Everett! Happy Birthday to you! May God continue to bless "

But http://pen4pals.com/cs/en/content/happy ... ay-everett translated all content

3.you wrote it will translate meta tag, but http://pen4pals.com/be/content/happy-birthday-everett

<meta name="keywords" content="happy birthday" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="/en/content/happy-birthday-everett" />
<link rel="shortlink" href="/en/node/41" />
<meta name="description" content="wishing happy birthday" />
<meta property="og:title" content="Happy Birthday, Everett!" />
<title>Happy Birthday, Everett! | pen4pals international language exchange service</title>


4.Also you wrote about seo friendly url but how google detect so language - http://pen4pals.com/nl/en

if it likes http://pen4pals.com/nl

5. Also as not all content is translated I get duplicate content and get kick up from Google.
trotsak
 
Posts: 51
Joined: Tue Mar 20, 2012 5:08 am

Re: Problem with login after installing Gt Pro

Postby Yana » Wed Mar 21, 2012 1:58 am

Hi,
I have changed #gtranslate config lines. Please check your .htaccess file.
If you want something to be translated instantly and don't want to wait, you can add
?force_translation=1 parameter to the end of the URL.
Ex: http://pen4pals.com/nl/content/happy-bi ... nslation=1
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="/en/content/happy-birthday-everett" />
<link rel="shortlink" href="/en/node/41" />
<meta name="description" content="желающие С Днем Рождения" />
<meta property="og:title" content="Happy Birthday, Everett!" />
<title>С Днем Рождения, Everett! | Pen4pals международный язык обменный сервис</title>

I'm getting SEO friendly URLs http://pen4pals.com/nl/content/happy-birthday-everett
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: Problem with login after installing Gt Pro

Postby trotsak » Wed Mar 21, 2012 5:12 am

thank you Yana,

1.but why does not translate main content, example - http://pen4pals.com/ar/en "Dear..., We are glad to say to you "Hi!" at our pen4pals language exchange service..."

but http://pen4pals.com/az - all OK.

2.How about correct sharing in social net - I have tried to share pen4pals.com/az at StumblU, Facebook but they transform link in http://pen4pals.com/en/home
trotsak
 
Posts: 51
Joined: Tue Mar 20, 2012 5:08 am

Re: Problem with login after installing Gt Pro

Postby Yana » Wed Mar 21, 2012 2:31 pm

Hi,
1.Please add ?force_translation=1 parameter to the end of the URL.
2. You can wrap it with class="notranslate"
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: Problem with login after installing Gt Pro

Postby trotsak » Wed Mar 21, 2012 2:56 pm

Yana wrote:Hi,
1.Please add ?force_translation=1 parameter to the end of the URL.
2. You can wrap it with class="notranslate"


1.Very good, but how do it? Manually add ?force_translation=1 for every page?
2.How wrap?
trotsak
 
Posts: 51
Joined: Tue Mar 20, 2012 5:08 am

Re: Problem with login after installing Gt Pro

Postby Yana » Wed Mar 21, 2012 9:26 pm

Hi,
You can make the force_translation option permanent if you are having trouble on all pages of your site. You can replace lang=$1 with lang=$1&force_translation=1 in the .htaccess

class="notranslate" attribute works with any tag. Here is an example:
<div class="notranslate">
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: Problem with login after installing Gt Pro

Postby trotsak » Thu Mar 22, 2012 6:43 am

1. I've corrected. Is it correct?
RewriteRule ^(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2&force_translation=1 [L,QSA]
RewriteRule ^(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)$ /gtranslate/translate.php?lang=$1&force_translation=1 [L,QSA]


2. I tried to have url as http://pen4pals.com/af, now I have http://pen4pals.com/af/en.

I turn off multilungual support, English is as default lang, but when I tried to login I got Permanent Moved error again. I add manually /en and reset options.
So how correct this error that I have seo friendly url ~ http://pen4pals.com/af?

3. Also I note that my redirect dont work (~ /forum-> forum/node9)

4. Yana, I am not so smart as you. How and where add this <div class="notranslate"> in drupal 7?

5. When I am on http://pen4pals.com/ja (see Japanese text) and when I press Stumble Upon, Facebook buttons, in Facebook's, StumbleUpon's page I see not Japanese http://pen4pals.com/ja but
Code: Select all
Free learning of any foreign language with native speakers in our language service.
http://pen4pals.com/en/home

Learn foreign language with native speakers.
trotsak
 
Posts: 51
Joined: Tue Mar 20, 2012 5:08 am

Re: Problem with login after installing Gt Pro

Postby Yana » Thu Mar 22, 2012 4:19 pm

Please copy this lines to your .htaccess


Code: Select all
# gtranslate config
RewriteRule ^(en|af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)/(en|af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^(en|af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)/(en|af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)$ /$1/ [R=301,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(en|af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)/(.*)$ /gtranslate/translate.php?lang=$1&force_translation=1&url=$2 [L,QSA]
RewriteRule ^(en|af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)$ /gtranslate/translate.php?lang=$1&force_translation=1 [L,QSA]
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: Problem with login after installing Gt Pro

Postby trotsak » Thu Mar 22, 2012 6:03 pm

Yana wrote:Please copy this lines to your .htaccess


Code: Select all
# gtranslate config
RewriteRule ^(en|af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)/(en|af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^(en|af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)/(en|af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)$ /$1/ [R=301,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(en|af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)/(.*)$ /gtranslate/translate.php?lang=$1&force_translation=1&url=$2 [L,QSA]
RewriteRule ^(en|af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)$ /gtranslate/translate.php?lang=$1&force_translation=1 [L,QSA]


dont work, when i login I get url http://pen4pals.com/home/?force_transla ... on=node/11

and error -
Code: Select all
Moved Permanently

The document has moved here.
trotsak
 
Posts: 51
Joined: Tue Mar 20, 2012 5:08 am

Re: Problem with login after installing Gt Pro

Postby Yana » Thu Mar 22, 2012 6:18 pm

Please remove english language code:

Code: Select all
# gtranslate config
RewriteRule ^(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)/(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)/(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)$ /$1/ [R=301,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)/(.*)$ /gtranslate/translate.php?lang=$1&force_translation=1&url=$2 [L,QSA]
RewriteRule ^(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi)$ /gtranslate/translate.php?lang=$1&force_translation=1 [L,QSA]
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: Problem with login after installing Gt Pro

Postby trotsak » Sat Mar 24, 2012 3:44 pm

trotsak wrote:5. When I am on http://pen4pals.com/ja (see Japanese text) and when I press Stumble Upon, Facebook buttons, in Facebook's, StumbleUpon's page I see not Japanese http://pen4pals.com/ja but
Code: Select all
Free learning of any foreign language with native speakers in our language service.
http://pen4pals.com/en/home

Learn foreign language with native speakers.


Do you have solution for that problem?
trotsak
 
Posts: 51
Joined: Tue Mar 20, 2012 5:08 am

Re: Problem with login after installing Gt Pro

Postby Edvard » Mon Mar 26, 2012 6:36 pm

Hi,

You use <meta property="og:site_name"> and <meta property="og:title"> which define the title and description for Facebook to use, however they are not being translated. If you don't use them, Facebook will use your page title and description instead, which are translated.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4179
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Problem with login after installing Gt Pro

Postby trotsak » Mon Mar 26, 2012 7:22 pm

Edvard wrote:Hi,

You use <meta property="og:site_name"> and <meta property="og:title"> which define the title and description for Facebook to use, however they are not being translated. If you don't use them, Facebook will use your page title and description instead, which are translated.


Спасибо, Эдвард, за интересную информацию.
trotsak
 
Posts: 51
Joined: Tue Mar 20, 2012 5:08 am


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest

2GLux
cron