Afrikaans shows up instead of English

Popular automatic website translation tool

Afrikaans shows up instead of English

Postby dmmontana » Thu Sep 19, 2013 8:06 pm

Joomla 2.5
GTranslate 3.0.x.32

My site is in English. In the GTranslate module, I have selected to show Spanish and English in a dropdown menu. The translation method is "On Fly." Analytics is turned off. I'm not using flags.

If I click on English in the dropdown when the site is already displaying in English, the site translates to Afrikaans, which is set to "no" in the module.

The only way to get back to English then is to select Spanish and then Ingles.

I tried changing the translation method to Google Default but then the translation module doesn't show up at all in IE8.

Can you help with this issue?

Thank you.
Denise Montana
dmmontana
 
Posts: 4
Joined: Thu Sep 19, 2013 7:56 pm

Re: Afrikaans shows up instead of English

Postby dmmontana » Thu Sep 19, 2013 8:08 pm

I just see that someone else reported this issue in May, 2013: english-site-translates-afrikaans-when-usa-flag-chosen-t3007.html. You requested his site's web address. My site can be found at http://166.78.22.222.
dmmontana
 
Posts: 4
Joined: Thu Sep 19, 2013 7:56 pm

Re: Afrikaans shows up instead of English

Postby Yana » Fri Sep 20, 2013 4:27 pm

Hi,
Just have checked your website and can see the Spanish version of your website. Please try to clear the browser cache and check again .
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4140
Joined: Thu Jan 12, 2012 6:21 pm

Re: Afrikaans shows up instead of English

Postby dmmontana » Fri Sep 20, 2013 10:20 pm

Thanks but the issue doesn't have anything to do with being able to see the Spanish translation. That part works fine.

To replicate the problem, while you're on the English version of the site please go to the GTranslate module at the bottom of the page and click on English. You will see that when you do that, the site translates to Afrikaans instead of staying in English.
dmmontana
 
Posts: 4
Joined: Thu Sep 19, 2013 7:56 pm

Re: Afrikaans shows up instead of English

Postby dmmontana » Fri Oct 11, 2013 9:27 pm

I'm still hoping for a reply/resolution on this. Please follow the steps above to replicate the problem on my site: http://166.78.22.222.

Thank you.
dmmontana
 
Posts: 4
Joined: Thu Sep 19, 2013 7:56 pm

Re: Afrikaans shows up instead of English

Postby Yana » Sat Oct 12, 2013 5:58 pm

Hi,
Just have checked and cannot see any problem. The GTranslate is working properly. If the language is English , it is inactive in the dropdown list.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4140
Joined: Thu Jan 12, 2012 6:21 pm

Re: Afrikaans shows up instead of English

Postby tdfoxdale » Tue Dec 10, 2013 10:37 pm

We are having the same problem. Upon hitting the site, the language is English. If, under the GTranslate dropdown, English is chosen, the page is translated to Afrikaans. One then has to chose Spanish, and then Ingles to get back to English. Our URL is:

http://www.rfsd.k12.co.us/

Thanks,

Tim
tdfoxdale
 
Posts: 3
Joined: Tue Dec 10, 2013 10:30 pm

Re: Afrikaans shows up instead of English

Postby Yana » Wed Dec 11, 2013 8:27 pm

Dear Tim,
Please try to change the translation method to "Redirect" .
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4140
Joined: Thu Jan 12, 2012 6:21 pm

Re: Afrikaans shows up instead of English

Postby tdfoxdale » Wed Dec 11, 2013 10:12 pm

Yep, that helped. Thank you! Is this a workaround for a bug (that may, at some point be fixed), or a "feature"? :D

Thanks again, for you quick and helpful response.

Tim
tdfoxdale
 
Posts: 3
Joined: Tue Dec 10, 2013 10:30 pm

Re: Afrikaans shows up instead of English

Postby Yana » Thu Dec 12, 2013 12:25 am

You're welcome!
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4140
Joined: Thu Jan 12, 2012 6:21 pm

Re: Afrikaans shows up instead of English

Postby cwjs » Thu Dec 12, 2013 6:15 pm

HI,

I have the same problem, but if I change the translation method to redirect it breaks the civic cookie contol api, as the address bar now reads http://translate.googleusercontent.com/ ... FllvT_sYqg

Whilst this is a way around the problem it is not a fix

Regars

Clive
cwjs
 
Posts: 1
Joined: Thu Dec 12, 2013 6:08 pm

Re: Afrikaans shows up instead of English

Postby tdfoxdale » Thu Dec 12, 2013 8:10 pm

Thanks again, Yana. When we used "Redirect" we lost a lot of styling, so we opted to hack the dropdown menu and commented out the "Select Language" option. Now, the page starts with "English" selected in the dropdown menu, and the only items in the menu are "English" and "Spanish". Seems to work well.

Tim
tdfoxdale
 
Posts: 3
Joined: Tue Dec 10, 2013 10:30 pm

Re: Afrikaans shows up instead of English

Postby jasons » Wed Oct 22, 2014 11:36 pm

tdfoxdale - Would you mind telling me where to go to comment out the "Select language" option? I would like to try this route out and see if it works for my site.
jasons
 
Posts: 13
Joined: Wed Oct 22, 2014 10:35 pm

Re: Afrikaans shows up instead of English

Postby Yana » Thu Oct 23, 2014 2:50 pm

Hi,
It is in the source code of the GTranslate free module. If you are using joomla module it should be in \modules\mod_gtranslate\tmpl\default.php file.
For wordpress it is in the /wp-content/plugins/gtranslate/gtranslate.php file
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4140
Joined: Thu Jan 12, 2012 6:21 pm

Re: Afrikaans shows up instead of English

Postby jasons » Thu Oct 23, 2014 8:28 pm

Thank you Yana! I am using joomla and that did the trick.
jasons
 
Posts: 13
Joined: Wed Oct 22, 2014 10:35 pm

Re: Afrikaans shows up instead of English

Postby Yana » Fri Oct 24, 2014 11:43 am

You're welcome!
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4140
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux
cron