[Solved] Blank Page on my Test Environment

Popular automatic website translation tool

[Solved] Blank Page on my Test Environment

Postby showlib » Thu Dec 26, 2013 9:36 pm

Hi,

I've a blank page after selecting a country.

My config.php is well configured with
define('SSL_VERIFY_PEER', false); // disable if you get CA certificate error and cannot reconfigure your server to solve the issue
define('FOLLOW_LOCATION', true); // if your site have redirects for some URLs and for that reason you see blank pages, you need to enable this feature

The debug.txt shows :
cat debug.txt
* About to connect() to test.showlib.com port 80 (#0)
* Trying 172.16.0.21...
* connected
* Connected to test.showlib.com (172.16.0.21) port 80 (#0)
> GET /temp_user_end.php?fname=Thibaut HTTP/1.1
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.73.11 (KHTML, like Gecko) Version/6.1.1 Safari/537.73.11
Host: test.showlib.com
Accept: */*
Cookie: SESSa4c72380e40468e34aa288e20559b308=LXdg2GKB3BEsPFtYA09_mjyYVX_tapT4OdURRCQRt_M; PHPSESSID=pj47attpnip95f9uld0bdvrbc6

* HTTP 1.0, assume close after body
< HTTP/1.0 302 Found
< Location: https://test.showlib.com/temp_user_end. ... %3dThibaut
< Content-Type: text/html
< Content-Length: 180
<
* Closing connection #0
* Issue another request to this URL: 'https://test.showlib.com/temp_user_end.php?fname%3dThibaut'
* About to connect() to test.showlib.com port 443 (#0)
* Trying 172.16.0.21...
* connected
* Connected to test.showlib.com (172.16.0.21) port 443 (#0)
* successfully set certificate verify locations:
* CAfile: none
CApath: /etc/ssl/certs
* SSL certificate problem: self signed certificate
* Closing connection #0

I have pound SSL proxy activated and a self signed certificate because it's e test environment

Do you have an idea ?

Thanks
showlib
 
Posts: 25
Joined: Fri Dec 20, 2013 2:39 pm

Re: Blank Page on my Test Environment

Postby Edvard » Fri Dec 27, 2013 7:18 pm

Hi,

Are you redirecting http to https?

Thank you!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Blank Page on my Test Environment

Postby showlib » Fri Dec 27, 2013 7:35 pm

yes pound redirect http to https, th site is entire https
showlib
 
Posts: 25
Joined: Fri Dec 20, 2013 2:39 pm

Re: Blank Page on my Test Environment

Postby Edvard » Fri Dec 27, 2013 7:37 pm

Hi,

Please add this line in gtranslate/config.php file, so it will look like as follows:

<?php

$_SERVER['SERVER_PROTOCOL'] = 'HTTPS/1.1';
...
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Blank Page on my Test Environment

Postby showlib » Fri Dec 27, 2013 8:09 pm

Thnaks,

When I click to a flag, nothing append :

$ cat debug.txt
* About to connect() to test.showlib.com port 443 (#0)
* Trying 172.16.0.21...
* connected
* Connected to test.showlib.com (172.16.0.21) port 443 (#0)
* successfully set certificate verify locations:
* CAfile: none
CApath: /etc/ssl/certs
* SSL certificate problem: self signed certificate
* Closing connection #0

Always a problem of certificate…

$ cat config.php
<?php
define('MAIN_LANG', 'fr'); // Main language code: en, ar, bg, hr, cn, ct, cs, da, et, tl, fi, fr, gl, el, iw, hi, es, nl, id, ja, ca, ko, lt, lv, mt, de, no, pt, ru, ro, sr, sk, sl, sv, th, tr, uk, hu, vi, it, pl, sq

define('API_KEY', 'INSERT-YOUR-KEY'); // You can get your Google Translate API key from https://code.google.com/apis/console/?api=translate
define('AUTO_DETECT_LANG', false); // set to true if you have mixed language content, works with Google only
define('CACHE_TIME', 365*24*60*60); // 1 year by default, no need to decrease
define('LICENSE', 'license.dat');
define('SSL_VERIFY_PEER', false); // disable if you get CA certificate error and cannot reconfigure your server to solve the issue
define('FOLLOW_LOCATION', true); // if your site have redirects for some URLs and for that reason you see blank pages, you need to enable this feature
define('USE_BING_TRANSLATOR', false); // Enable it to use Bing Translotor instead of Google Translate
define('BING_API_KEY', ''); // If the option above is enabled you need to get your Bing API key from http://www.bing.com/developers/createapp.aspx (PHP SOAP client is required)
define('DEBUG', true); // turn on for debug mode
$_SERVER['SERVER_PROTOCOL'] = 'HTTPS/1.1';

// username and password to edit translations, please change for security reasons,
// this is not your google login/pass, you need to think something new
define('USER', 'xxxxx');
define('PASS', 'xxxxx');
$

The SSL_VERIFY_PEER' don't work ?

Thanks
showlib
 
Posts: 25
Joined: Fri Dec 20, 2013 2:39 pm

Re: Blank Page on my Test Environment

Postby showlib » Fri Dec 27, 2013 9:31 pm

Perhaps we need to configure 'allow_self_signed' in your code ??
showlib
 
Posts: 25
Joined: Fri Dec 20, 2013 2:39 pm

Re: Blank Page on my Test Environment

Postby Edvard » Fri Dec 27, 2013 10:24 pm

Just fix the issue with your certificate.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Blank Page on my Test Environment

Postby showlib » Fri Dec 27, 2013 10:40 pm

Hi Edvard,

does it mean the Gtranslate doesn't work with self-signed certificate ?

thanks for your reply
showlib
 
Posts: 25
Joined: Fri Dec 20, 2013 2:39 pm

Re: Blank Page on my Test Environment

Postby Edvard » Fri Dec 27, 2013 11:43 pm

As I can see CAfile is set to none, you need to specify a correct file.

In any case you are not going to use self signed certificate on your production site, so I would suggest using GTranslate on you production directly.

Thank you!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Blank Page on my Test Environment

Postby showlib » Mon Dec 30, 2013 12:45 pm

Hi,

In fact I think the problem is due to Curl version :
Curl: SSL certificate problem, verify that the CA cert is OK

There's quite a lot of post on the net on this subject.

The solution is to launch Curl with -k option in order to disable the test certificate.

How can we do this ?

Thanks a lot for your feedback
showlib
 
Posts: 25
Joined: Fri Dec 20, 2013 2:39 pm

Re: Blank Page on my Test Environment

Postby Edvard » Mon Dec 30, 2013 8:36 pm

Hi,

We have created an option for your case which is SSL_VERIFY_PEER. If you disable it and have a correct self signed certificate for your host then it will be OK. You will need to make sure that your self signed certificate is correct for your host. You may create another one from the beginning. It need to be solved by your hostmaster.

Thank you!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Blank Page on my Test Environment

Postby showlib » Tue Dec 31, 2013 4:52 pm

Hi Edvard,

My admin re-installed the certificate as CA and it works.
Thanks for your time.

We're now continuing our debug phase with the drupal module.

Happy new year
showlib
 
Posts: 25
Joined: Fri Dec 20, 2013 2:39 pm

Re: Blank Page on my Test Environment

Postby Edvard » Tue Dec 31, 2013 4:53 pm

Good to hear that! Happy new year!

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux