Forum Archive - Can't uncheck "Load jQuery library"

Can't uncheck "Load jQuery library"
Apr 25, 2011 6:32 am by dosboy
Just as the subject says - when I uncheck "Load jQuery library" in the GTranslate admin page (because I'm already loading the latest version as one of the first items in my <head> section) and hit Save, it remains checked, and my site ends up loading jQuery twice. This seems like a bug, but maybe I'm overlooking something. This is under WordPress 3.1.1.
Re: Can't uncheck "Load jQuery library"
Apr 25, 2011 9:37 am by [email protected]
Have the same issue here :roll:
Re: Can't uncheck "Load jQuery library"
Apr 25, 2011 9:20 pm by greg9885
Yep, same here!! What's up with this?
Re: Can't uncheck "Load jQuery library"
Apr 26, 2011 11:35 am by Edvard
Thinks for the issue report, will be fixed in the next 1.0.18 version.
Re: Can't uncheck "Load jQuery library"
Apr 26, 2011 7:15 pm by dosboy
Just updated to the latest version (Edvard - you're on the ball man). Unchecking include jQuery works now, but the translation fails when I include (prior to any GTranslate JS) jQuery 1.5.2 from Google CDN. It just doesn't do anything. I'm assuming getting it from Google isn't the issue, but it seems like there's a compatibility problem between GTranslate and jQuery 1.5.2 (or perhaps 1.5.x). Anyway, I'm not really using any JS on my site right now so I'm happy to include the 1.4.4 version, but it's probably worth looking into. FYI, I do get the following message in my JS Console when I click a translate flag: Uncaught TypeError: Object function (a,b){return new d.fn.init(a,b,g)} has no method 'cookie' doGTranslate (anonymous function) This is on Chrome 12.0.742.5 dev on a Mac.
Re: Can't uncheck "Load jQuery library"
Apr 27, 2011 9:15 am by Edvard
Hi, Never tried it with the jQuery 1.5, the default WP jQuery is version 1.4.4... Make sure that you load it before the jquery-translate.js file. Since if you load it after, it will create a new jQuery object and jQuery.cookie will not be defined...
Re: Can't uncheck "Load jQuery library"
Apr 27, 2011 12:18 pm by dosboy
Hi Edvard. I am loading jQuery 1.5.2 prior to (before) the GTranslate JS. But I still get that error. Again, not a huge deal, but something you might want to be aware of.


Highly increased load on website from 19, 2019 8:29 pmReplies: 1Post by: Ant_Z
Translate website to any specific language, on page loadJan 19, 2019 6:49 amReplies: 1Post by: Leaon7756
Is it possible to unhook Gtranslate's CSS (ie. not load it)?Nov 23, 2018 4:01 pmReplies: 1Post by: oxygensmith
How to add rel="nofollow" to GTranslate links ?Sep 19, 2018 10:10 amReplies: 5Post by: agatti
<html dir="ltr" lang="no" prefix="og:">Dec 19, 2017 7:35 amReplies: 2Post by: besybuy

Try GTranslate with a free 15 day trial