Languages won't change

Popular automatic website translation tool

Languages won't change

Postby MarkLingard » Mon Jun 23, 2014 12:37 pm

Hi, I have installed the Pro version. Once the languages change, they won't change back. Even if I close the website and clear the history etc, it stays on the new language (which I think is Serbian?). I need the default language to be English, which in Joomla's settings it says it is. Is there another setting I need to change somewhere?
MarkLingard
 
Posts: 5
Joined: Mon Jun 23, 2014 12:34 pm

Re: Languages won't change

Postby Edvard » Mon Jun 23, 2014 12:38 pm

Hi,

What is your website address?
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Languages won't change

Postby MarkLingard » Mon Jun 23, 2014 12:42 pm

Website is www.sirane.com. Thanks
MarkLingard
 
Posts: 5
Joined: Mon Jun 23, 2014 12:34 pm

Re: Languages won't change

Postby Edvard » Mon Jun 23, 2014 12:52 pm

Hi,

Do you have any redirect in .htaccess which redirects http://www.sirane.com/en/ to http://www.sirane.com/ ?

Do you have any other language plugins enabled besides GTranslate?

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Languages won't change

Postby MarkLingard » Mon Jun 23, 2014 12:56 pm

Yes, we had some previous plug-ins for French, Spanish, German, Turkish and Italian. Do these need disabling or removing? Not sure on redirects
MarkLingard
 
Posts: 5
Joined: Mon Jun 23, 2014 12:34 pm

Re: Languages won't change

Postby Edvard » Mon Jun 23, 2014 12:57 pm

Yes, please disable or remove.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Languages won't change

Postby MarkLingard » Mon Jun 23, 2014 1:01 pm

Okay, all other language plug-ins are disabled. What next?... thanks
MarkLingard
 
Posts: 5
Joined: Mon Jun 23, 2014 12:34 pm

Re: Languages won't change

Postby Edvard » Mon Jun 23, 2014 1:04 pm

Can you post the contents of your .htaccess file?
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Languages won't change

Postby MarkLingard » Mon Jun 23, 2014 1:12 pm

Hope it helps.....

##
# @version $Id: htaccess.txt 21101 2011-04-07 15:47:33Z dextercowley $
# @package Joomla
# @copyright Copyright (C) 2005 - 2011 Open Source Matters. All rights reserved.
# @license GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
##

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

## Mod_rewrite in use.

RewriteEngine On

########## Redirect non-www to www
RewriteCond %{HTTP_HOST} !^(http:\/\/)?([a-z0-9\-]+\.)sirane\.com
RewriteRule (.*) http://www.sirane.com/$1 [R=301,L]
########## end of non-www to www

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block out any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the request is for something within the component folder,
# or for the site root, or for an extensionless URL, or the
# requested URL ends with one of the listed extensions
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.
MarkLingard
 
Posts: 5
Joined: Mon Jun 23, 2014 12:34 pm


Re: Languages won't change

Postby Edvard » Mon Jun 23, 2014 1:38 pm

Thanks! I have checked and can see that you have System - Language Filter enabled. It need to be disabled, so you can go back to original language.

When I disable it some modules and articles do not get published, probably because you did not assign them to all languages. So, I would suggest you to assign all modules and articles to all languages and disable the mentioned plugin, so GTranslate can function correctly.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux