Page not found when using the language flag

Popular automatic website translation tool

Page not found when using the language flag

Postby aerfun » Wed Jan 23, 2013 7:11 pm

Hi,

I'm not sure that this is the right place for posting a support question... If not, please let me know about the procedure.

I purchased and installed the gtranslate PRO version on my website: http://www.paris-balloon.com/index.php. The translation seems to work fine as I can access translated pages using the following syntax: ex for spanish language: http://www.paris-balloon.com/es/

However, I get "Page not found" when I try to access the translated pages directly from my English home page using the little flags. In fact, the flag redirect to http://www.paris-balloon.com/es/index.php which doesn't exist.

I checked my configuration many times, but did'nt find the solution. Can you please help me ?

Thanks

Eric

http://www.paris-balloon.com/robots.txt
http://www.paris-balloon.com/sitemap.txt
http://www.paris-balloon.com/gtranslate/info.php
aerfun
 
Posts: 7
Joined: Wed Jan 23, 2013 6:28 pm

Re: Page not found when using the language flag

Postby Yana » Thu Jan 24, 2013 12:58 am

Dear Eric,
Please try to disable "Add suffix to URLs " option on the Global Configuration page.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: Page not found when using the language flag

Postby aerfun » Thu Jan 24, 2013 1:54 am

Hi Yana,

Thanks for your quick reply. Unfortunately, "Add suffix to URLs " option was already disabled on the Global Configuration page. However, I just noticed that the flags work fine (no index.php suffix) once I switch to another language. It doesn't work when I am in the english native system.

Best regards

Eric
aerfun
 
Posts: 7
Joined: Wed Jan 23, 2013 6:28 pm

Re: Page not found when using the language flag

Postby Yana » Thu Jan 24, 2013 9:23 pm

Dear Eric,
I'm getting redirected to http://www.paris-balloon.com/index.php when I try to open http://www.paris-balloon.com

Please check your .htaccess and remove the redirection and it should work properly.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: Page not found when using the language flag

Postby aerfun » Fri Jan 25, 2013 12:59 pm

Hi Yana,

I did a test with removing the redirection line in .htaccess and nothing has changed, except that http://www.paris-balloon.com/index.html goes to 404 error page.

This redirection applies only for index.html link:
RedirectPermanent /index.html http://www.paris-balloon.com/index.php
I need this redirection working as many SEO external links still goes to index.html.

I think that one solution is in getting rid of index.php in the home Path but I don't see how to do it. Do you want me to send you a copy of my .htaccess file ?

Best regards

Eric
aerfun
 
Posts: 7
Joined: Wed Jan 23, 2013 6:28 pm

Re: Page not found when using the language flag

Postby Yana » Fri Jan 25, 2013 6:22 pm

Hi,
Please try this rule.

RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\.php\ HTTP/
RewriteRule ^index\.php$ http://paris-balloon.com/ [R=301,L]
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: Page not found when using the language flag

Postby aerfun » Fri Jan 25, 2013 8:02 pm

Hi Yana,

I tried this rule, but I get the following error message: "The page is not redirecting properly"
whatever the link is http://www.paris-balloon.com/index.php or http://www.paris-balloon.com/

Regards

Eric
aerfun
 
Posts: 7
Joined: Wed Jan 23, 2013 6:28 pm

Re: Page not found when using the language flag

Postby Yana » Sun Jan 27, 2013 5:15 pm

Dear Eric,
Please remove the following line and it will work properly.
RedirectPermanent /index.html http://www.paris-balloon.com/index.php

Also you can install the GTrtanslate Pro general instead of the joomla system plugin.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: Page not found when using the language flag

Postby aerfun » Mon Jan 28, 2013 12:41 pm

Hi Yana,

we are running in loop !

I already did this test on Jan, 25th and nothing changed. Again, I have removed the RedirectPermanent line in .htaccess and you can check by yourself that it doesn't help. Furthermore, I'm already using Gtranslate Pro (purchased on Jan, 23rd).

It's a real problem for me if customers get "404 error" each time they switch language from home page.

Regards

Eric
aerfun
 
Posts: 7
Joined: Wed Jan 23, 2013 6:28 pm

Re: Page not found when using the language flag

Postby Yana » Mon Jan 28, 2013 9:56 pm

Hi,
Please send me FTP access info and joomla backend admin username /password and I'll install the GTranslate Pro general.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: Page not found when using the language flag

Postby aerfun » Tue Jan 29, 2013 12:02 am

Hi Yana,

can you please give me your email address in order for me to send you login/password info ? Is there a difference between Gtranslate Pro and GTranslate Pro general ?

regards

Eric
aerfun
 
Posts: 7
Joined: Wed Jan 23, 2013 6:28 pm

Re: Page not found when using the language flag

Postby Yana » Tue Jan 29, 2013 2:06 am

Hi,
Please check your PM.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: Page not found when using the language flag

Postby aerfun » Tue Jan 29, 2013 2:09 am

Is there a difference between Gtranslate Pro and GTranslate Pro general ?
aerfun
 
Posts: 7
Joined: Wed Jan 23, 2013 6:28 pm

Re: Page not found when using the language flag

Postby Yana » Tue Jan 29, 2013 12:03 pm

Hi,
The General version is for all platforms not only for Joomla. The only difference is the installation process.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux