PHP strict standards errors / PHP 7 Compatability question

Popular automatic website translation tool

PHP strict standards errors / PHP 7 Compatability question

Postby furnivat » Thu Oct 06, 2016 2:53 pm

I am using the Pro version on Joomla 3.6.2, on a server running PHP 5.6.

I wanted to let you know that there are two Strict Standard warnings in the source code of my website from the GTranslate module.

Code: Select all
Strict Standards: Non-static method modGTranslateHelper::getParams() should not be called statically in /home/my_website/public_html_dev/modules/mod_gtranslate/mod_gtranslate.php on line 13
Strict Standards: Only variables should be assigned by reference in /home/my_website/public_html_dev/modules/mod_gtranslate/tmpl/default.php on line 130


Will GTranslate for Joomla be made compatible with PHP 7 soon please? PHP 7 offers large speed increases and I would like to upgrade to it. Thanks :)
furnivat
 
Posts: 24
Joined: Sun Dec 26, 2010 7:11 pm

Re: PHP strict standards errors / PHP 7 Compatability questi

Postby Edvard » Fri Oct 07, 2016 1:23 pm

Yes, it is compatible. You should not worry about the strict standard warning message.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4349
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest

2GLux