PHP 5.4 + wordpress plugin

Popular automatic website translation tool

PHP 5.4 + wordpress plugin

Postby 1m5FDMR2D4al » Thu Nov 17, 2011 1:24 am

On PHP 5.3 wordpress plugin v1.30 worked like a charm.
On PHP 5.4 when 'm trying to activate plugin it says:
Плагин не был активирован, потому что он вызвал фатальную ошибку.
Fatal error: Call-time pass-by-reference has been removed in <...>/wp-content/plugins/gtranslate/gtranslate.php on line 46

And second problem is - ioncube site is currently offline, so I don't even have a chance to find ioncube loader for pro version. Do ioncube loader 5.4 even exists?
1m5FDMR2D4al
 
Posts: 15
Joined: Sun Sep 18, 2011 12:57 pm

Re: PHP 5.4 + wordpress plugin

Postby 1m5FDMR2D4al » Thu Nov 17, 2011 2:36 pm

And seems like replacing obsolette & $data with just $data in gtranslate.php makes script work fine.
The only problem left is unreachable ioncube site.
1m5FDMR2D4al
 
Posts: 15
Joined: Sun Sep 18, 2011 12:57 pm

Re: PHP 5.4 + wordpress plugin

Postby Edvard » Thu Nov 17, 2011 4:17 pm

Hi,

PHP 5.4 is still in RC1 state and is not recommended for production websites.

Currently there is no support for 5.4 version. I would suggest to downgrade to 5.3 or even better to 5.2.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4179
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: PHP 5.4 + wordpress plugin

Postby 1m5FDMR2D4al » Sun Nov 20, 2011 1:11 am

Edvard wrote:Hi,

PHP 5.4 is still in RC1 state and is not recommended for production websites.

So cool I'm not running production website but only my blog!
You can understand your script incompatibility with new PHP version before that version became stable and recommended to use becouse of people like me who uses bleeding edge software.
I will wait for ioncube for starting to work with 5.4.

By the way, please update your script with replacing links like & with normal variables - it's already catching a warning in 5.3 because it's obsolette, and even not included in 5.4.
1m5FDMR2D4al
 
Posts: 15
Joined: Sun Sep 18, 2011 12:57 pm

Re: PHP 5.4 + wordpress plugin

Postby 1m5FDMR2D4al » Sun Nov 27, 2011 10:47 pm

I updated wordpress plugin from 1.30 to 1.31 and got same issue as with the previous version. The only thing you have to do is to replace "& $data" with "$data", that's all. Please add it to your gtranslate todo list.
By the way, ioncube site is still down - it will be nice if you upload ioncube libraries for php there on forum.
1m5FDMR2D4al
 
Posts: 15
Joined: Sun Sep 18, 2011 12:57 pm

Re: PHP 5.4 + wordpress plugin

Postby Edvard » Mon Nov 28, 2011 3:57 pm

Hi,

ionCube site is not down.

There is no support for 5.4 version yet...
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4179
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest

2GLux