Pro and Joomla Cache

Popular automatic website translation tool

Pro and Joomla Cache

Postby Dawn » Tue Jan 15, 2013 11:10 pm

Hi,

When I've enabled in global configuration of my site the site wide cache, I've got some problems: In the menus, sometimes links are pointing randomly to other languages. When I disable the cache, I don't have this problem. I think this could have something to do, because in the meantime was a site of this language accessed.

Gtranslate comes after the cache in the plugin order (has the highest number; cache: 17; gtranslate 18).

Is there a solution for this problem?

Best regards,
Dawn
Dawn
 
Posts: 19
Joined: Sat Dec 22, 2012 11:20 pm

Re: Pro and Joomla Cache

Postby Yana » Thu Jan 17, 2013 12:07 am

Hi,
Please change GTranslate plugin order . Hope this will solve the problem.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm

Re: Pro and Joomla Cache

Postby Dawn » Thu Jan 17, 2013 12:17 am

And you mean with plugin order for example gtranslate 17, cache 18?
Dawn
 
Posts: 19
Joined: Sat Dec 22, 2012 11:20 pm

Re: Pro and Joomla Cache

Postby Yana » Thu Jan 17, 2013 2:12 pm

HI,
Yes, please try to change the plugins order. Also try to disable the cache for menu module .
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm

Re: Pro and Joomla Cache

Postby Dawn » Thu Jan 17, 2013 3:09 pm

I've tried it before the cache module and after, got the same problems. Some menus are randomly pointing to other languages when I enable the cache.

My cacche plugin (not the global cache) is already disabled.

I'm afraid but nothing helps - only when I disabled the cache, then it works great.

This is dangerous related to SEO because such random links can be bot-traps and prevent indexing the site correctly to the bots of the SE like google.
Dawn
 
Posts: 19
Joined: Sat Dec 22, 2012 11:20 pm

Re: Pro and Joomla Cache

Postby Edvard » Thu Jan 17, 2013 4:15 pm

Hi,

GTranslate plugin should be fired after any caching extensions you have. In that case it will be fine.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Pro and Joomla Cache

Postby Dawn » Thu Jan 17, 2013 4:39 pm

As I said, I've tried this already. I have it now AFTER the cache. As soon as I enable the cache together with Gtranslate, I run it problems.

I can redproduce it when I access a site over the menu. Switch the language for example to spanish, access a few other sites, switch back to german (my default language). Then suddently some menus are still pointing to the spanish version, even now german is active.

I only have this problem when I use the cache.

Here a screenshot (full version: http://i47.tinypic.com/2642yr9.jpg):
Image
Dawn
 
Posts: 19
Joined: Sat Dec 22, 2012 11:20 pm

Re: Pro and Joomla Cache

Postby Edvard » Thu Jan 17, 2013 7:06 pm

Please try to disable caching for the menu module from the modules manager.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Pro and Joomla Cache

Postby anfas » Sun Aug 25, 2013 10:56 am

I have the same problem, I could not solve it by reordering or disabling caching for the menu module,
Any suggestion?
anfas
 
Posts: 6
Joined: Fri Jun 28, 2013 2:00 am

Re: Pro and Joomla Cache

Postby Yana » Mon Aug 26, 2013 3:23 am

Hi,

Please try to clear the cache and then change the plugin order.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm

Re: Pro and Joomla Cache

Postby Scine » Mon May 19, 2014 11:23 pm

I've got the same issue effecting one of my web servers. Unfortunately, disabling cache isn't really an option for us. I've tried the other solutions to no avail. Any other suggestions of what we could try? Thanks in advance!
Scine
 
Posts: 4
Joined: Fri Apr 04, 2014 7:54 am

Re: Pro and Joomla Cache

Postby Edvard » Tue May 20, 2014 12:19 pm

Hi,

You need to make sure that GTranslate plugin is on the last order in the plugins manager. After that if you still have issues with some particular modules, you will need to disable the cache for the particular module from the module options list.

If it is not an option for you, then you will need to install the general version instead of the plugin. You can find the steps in our documentation.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux